I had installed the Magento on my localhost, Install and customise the theme and now when I uploaded the website to the server. I cannot access the admin page; it gives me the 404 error, and my site is not displaying correctly.

I have already change the URL to MySQL, core_config_data. Run the reindex and flush cache command also try to (php bin/Magento setup:static-content:deploy) but no luck. Current file permission: Folders: 0775, Cache Folder: 777 and files: 0644

Website: http://exhaustkings.co.uk/backup/

Admin Page with 404 Error Home page


2 Answers 2


Check on your production server to make sure that your .htaccess file is present both in the root of Magento and also in the pub directory. Anytime this happens to me, this is always the cause.

You should have the following files.

  • Thank you for the reply. After doing hours of research, it was nothing but symlink needs to be enabled on Apache.
    – Rob
    Commented May 2, 2018 at 16:13

After did some research, on cPanel cloud hosting, by default Symlink was not enabled which was causing this issue. I have enabled this with PHP Selecter and then run the following commands:

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy

Not the answer you're looking for? Browse other questions tagged or ask your own question.