An error has happened during application run. See exception log for details.

[2018-01-12 02:00:11] main.CRITICAL: Dotmailer connector API endpoint cannot be empty. {"exception":"[object] (Magento\\Framework\\Exception\\LocalizedException(code: 0): Dotmailer connector API endpoint cannot be empty. at /home/site/public_html/vendor/dotmailer/dotmailer-magento2-extension/Model/Apiconnector/Client.php:118)"} []

Hello, I just used commands:

php bin/magento setup:upgrade
./n98-magerun2.phar cache:clean

That's it, I'm using the latest Magento version at the momment: 2.2.2.

1 Answer 1


I've created a github issue to look at this:


We've identified a cron job that is attempting to initialise the api without checking if its enabled first. We're looking for other places that similar behaviour may be happening.

  • 3
    In short, best thing to do for now is to disable tha Dotmailer module if you don't plan to use it. bin/magento module:disable Dotdigitalgroup_Email
    – Cladiuss
    Jan 24, 2018 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.