0

I have some problem, on my magento,please help~

  • 2.2.0
  • php71
  • centos7
  • EasyApache 4
  • PHPfpm
  • suphp
  • MYSQL5.6.38

An error has happened during application run. See exception log for details.

[07-Dec-2017 12:49:25 UTC] PHP Warning: Module 'imagick' already loaded in Unknown on line 0 [07-Dec-2017 12:49:25 UTC] PHP Warning: Module 'imagick' already loaded in Unknown on line 0 [07-Dec-2017 12:49:25 UTC] PHP Warning: Module 'imagick' already loaded in Unknown on line 0 [07-Dec-2017 12:49:25 UTC] PHP Warning: Module 'imagick' already loaded in Unknown on line 0 [07-Dec-2017 12:49:25 UTC] PHP Warning: Module 'imagick' already loaded in Unknown on line 0

[root@XX ~]# php -v ea-php-cli Copyright 2017 cPanel, Inc. Cannot load Zend OPcache - it was already loaded PHP 7.1.12 (cli) (built: Dec 4 2017 16:11:46) ( NTS ) Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
with Zend OPcache v7.1.12, Copyright (c) 1999-2017, by Zend Technologies

[root@XX ~]# php -m Cannot load Zend OPcache - it was already loaded [PHP Modules] bcmath Core ctype curl date dom filter ftp gd hash iconv imagick intl json libxml mbstring mcrypt mysqli mysqlnd openssl pcntl pcre PDO pdo_mysql pdo_sqlite Phar posix readline redis Reflection session SimpleXML soap SPL sqlite3 standard
tokenizer wddx xml xmlreader xmlwriter xsl Zend OPcache zip zlib

[Zend Modules] Zend OPcache

1 Answer 1

0

The errors indicate that dynamic extensions are being loaded via .ini files, even though they are already compiled into the PHP binary.

To fix this problem, you must edit your php.ini (or extensions.ini) file and comment-out the extensions that are already compiled-in.

For example, after editing, your ini file may look like the lines below:

;extension=imagick.so

You may also erase those lines instead of commenting them out. Once you have disabled those lines, run php -v to see if the warnings go away.

Also, to see which extensions are compiled-in to your PHP binary, run the following command:

php -m

4
  • Hello,i already deleted extension=imagick.so in my php.ini, but still have a p roblem. i run php -v >> please see the post
    – niceonelee
    Dec 7, 2017 at 13:20
  • How did you install the extension? What php version did you use to install it? If you used php 5 and now using php 7, it might be that the file in loaded under a different name, therefore, loaded twice.
    – Greg
    Dec 7, 2017 at 13:39
  • i using EasyApache4 to install the extension. PHP Version 7.1.12.but EasyApache4 have no imagick, so i in php.net to install this extension.
    – niceonelee
    Dec 7, 2017 at 14:02
  • so how to uninstall imagick? and then reinstall?thank you
    – niceonelee
    Dec 7, 2017 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.