1

I need help figuring out whats is failing my search. I am new at this so if I need to rephrase something please let me know:

search 1 : (works) https://staging.cherrydale.com/rest/default/V1/actionlog?searchCriteria[filter_groups][0][filters][0][field]=participant_id -- worked

search 2 : (fails) https://staging.cherrydale.com/rest/default/V1/participants?searchCriteria[filter_groups][0][filters][0][field]=participant_id -- failed

I varified that the ID field I am using in the search is in both tables.

What I got back:

The server returned HTTP Status Code : 400 Bad Request The response was: {"message":"%fieldName is a required field.","parameters":{"fieldName":"criteria"}}

I don't understand why it is not accepting a field name that exists.

0

Why this is the answer I do not fully understand. I changed the "searchCriteria" to criteria. That solved the issue and now everything works correctly.

See documentation: http://devdocs.magento.com/guides/v2.0/rest/performing-searches.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.