2

Migrating (trying to) but there is an error with I don't know what to do.

[Symfony\Component\Console\Exception\CommandNotFoundException]

There are no commands defined in the "migrate" namespace.

Any ideas?

  • 2
    HI did you got any answer? – Jenith Samuel Feb 7 '18 at 6:21
  • Yes actually I managed to migrate some data but in the meantime because We decided not to move to Magento 2 yet everything is gone. Will do it again soon then probably will post a step by step guide how to. – Rob D. A. Feb 7 '18 at 11:51
  • @JenithSamuel you installed the Data Migration Tool by uploading files to app/code ? – Binod Feb 13 '18 at 16:06
2

This error goes away when the data migration tool is installed using composer.

I debugged bit deeper into this error and found that the module's code of adding its shell commands are not working correctly. I didn't spend time to correct it instead installed the data migration tool using composer and it worked!

And, just in case, if you get Wrong Credential message when installing the tool using composer, you need to type the private key in the password field. The normal pasting password function(on right click) didn't seem to work here. This made me choose to install the tool manually, LOL.

  • 1
    Great thanks for this information, will check it asap as I must rebuild Magento 2 site. – Rob D. A. Feb 20 '18 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.