0

I have recently moved my magento installation from one server to another and have had some issues with the urls not being found. I was able to solve this temporarily but using /index.php/admin and then turning of the URL rewrites. This allowed to me access all my files including the login page. However when messing around with some setting (URL rewrites) included i am no unable to access my admin page again. I can however access all other pages.

The admin page can be accessed using /index.php/admin BUT it simply refreshes the page instead of logging me in.

Anybody else had this problem and or know what is wrong ?

  • Update: I imported the original database again and turned the rewrite rule off, cleared cache then re-indexed. Everything seamed to be working as expected then a few hours later i get the same problem. I am at a loss as to what could cause this. – c2aFrederick Jun 29 '17 at 14:00
0

Ok, i believe i have found the solution. Before i get to the answer i feel it is important to state that this magento installation was transferred from a professional webhotell provider to a private server that was set up by a inexperienced user (me). Ok on to the solution.

Solution: I made a minor change to the code in the httpd.conf file

# Further relax access to the default document root:
<Directory "/var/www/html">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
</Directory> 

The line of code that was changed was..

from this: AllowOverride None

to this: AllowOverride All

Admittedly not i understand this fully but it appears to have made all the difference and i hope this can help others in a similar situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.