0

I have followed the magento-mongo github project to connect Magento with mongodb.

Everything seems to be perfect while integrating. But the problem is when I tried to change any configuration through admin panel, I tried to add a product through admin panel, then its showing some schema error in the Cm/Mongo/Model/Indexer/Schema.php file.

Can any one suggest me to solve this error? Here are I am posting the error code.

Error:

2014-03-17T09:41:24+00:00 DEBUG (7): Exception message: Notice: Trying to get property of non-object  in /var/www/mage2/app/code/community/Cm/Mongo/Model/Indexer/Schema.php on line 45
Trace: #0 /var/www/mage2/app/code/community/Cm/Mongo/Model/Indexer/Schema.php(45): mageCoreErrorHandler(8, 'Trying to get p...', '/var/www/mage2/...', 45, Array)
#1 /var/www/mage2/app/code/community/Cm/Mongo/Model/Indexer.php(116): Cm_Mongo_Model_Indexer_Schema->getEntityIndexers('catalog_product')
#2 /var/www/mage2/app/code/core/Mage/Index/Model/Process.php(331): Cm_Mongo_Model_Indexer->matchEntityAndType('catalog_product', 'mass_action')
#3 [internal function]: Mage_Index_Model_Process->indexEvents('catalog_product', 'mass_action')
#4 /var/www/mage2/app/code/core/Mage/Index/Model/Indexer.php(324): call_user_func_array(Array, Array)
#5 /var/www/mage2/app/code/core/Mage/Index/Model/Indexer.php(171): Mage_Index_Model_Indexer->_runAll('indexEvents', Array)
#6 /var/www/mage2/app/code/core/Mage/CatalogInventory/Model/Observer.php(949): Mage_Index_Model_Indexer->indexEvents('catalog_product', 'mass_action')
#7 /var/www/mage2/app/code/core/Mage/Core/Model/App.php(1338): Mage_CatalogInventory_Model_Observer->reindexProductsMassAction(Object(Varien_Event_Observer))
#8 /var/www/mage2/app/code/core/Mage/Core/Model/App.php(1317): Mage_Core_Model_App->_callObserverMethod(Object(Mage_CatalogInventory_Model_Observer), 'reindexProducts...', Object(Varien_Event_Observer))
#9 /var/www/mage2/app/Mage.php(447): Mage_Core_Model_App->dispatchEvent('after_reindex_p...', Array)
#10 /var/www/mage2/app/code/core/Mage/Index/Model/Process.php(224): Mage::dispatchEvent('after_reindex_p...')
#11 /var/www/mage2/app/code/core/Mage/Index/Model/Process.php(255): Mage_Index_Model_Process->reindexAll()
#12 /var/www/mage2/app/code/core/Mage/Index/Model/Process.php(249): Mage_Index_Model_Process->reindexEverything()
#13 /var/www/mage2/app/code/core/Mage/Index/controllers/Adminhtml/ProcessController.php(178): Mage_Index_Model_Process->reindexEverything()
#14 /var/www/mage2/app/code/core/Mage/Core/Controller/Varien/Action.php(419): Mage_Index_Adminhtml_ProcessController->massReindexAction()
#15 /var/www/mage2/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('massReindex')
1

Looking at the extension on github there is a fix that appears to solve a problem when trying to get an indexer.

This fix checks to see if there is an indexer node, before trying to work with it.

if ($this->getNode('indexer')) {

I would suggest trying the most recent version of this extension. If this does not work then try reporting an issue directly on github

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.