3

After migration by using ubertheme, my category url is not working. Its showing all category urls are like below http://domain.com/catalog/category/view/s/trouvez-le-fauteuil-ou-canape-chesterfield-fait-pour-vous/id/51/

Can you pleas help me how can i change it to seo format?

I have tried reindexing via ssh and also enable seo url for category and product from Configuration/catalog/SEO tab.

I am using magento 2.1.0

Thanks in advance.

5

Download "Regenerate Url rewrites" extension from here : https://github.com/olegkoval/magento2-regenerate_url_rewrites

Follow the below steps

MANUAL INSTALLATION

  1. Extract files from an archive

  2. Create a app/code/OlegKoval/RegenerateUrlRewrites folder in magento root directory, and copy the extracted files from Step1 folder and upload it to directory app/code/OlegKoval/RegenerateUrlRewrites

  3. Disable the cache under System > Tools > Cache Management

  4. Enter the following at the command line

php bin/magento module:enable OlegKoval_RegenerateUrlRewrites

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy

HOW TO USE IT

To re-generate all Url rewrites of the categories/products in all stores (it support a multistores) run

php bin/magento ok:urlrewrites:regenerate

To regenerate all Url rewrites of the categories/products in the specific store view (e.g.: store view id is "2")

php bin/magento ok:urlrewrites:regenerate 2

  • use that but still my categories are redirecting to 404 error . – Flutterer Oct 1 '18 at 5:59
0

This might happen because there is no URL rewrite in Magento. Check your URL rewrites, if that category doesn't exist then create it. In Marketing > URL re-writes > Add URL re-write:

Add new URL rewrite

Flush cache, reindex the site and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.