0

Magento2 is set in developer mode (deploy:mode:set developer and checked env.php file) but it is showing a HTTP ERROR 500 page isn't working screen.

Only if I add this to the index:

error_reporting(E_ALL);
ini_set('display_errors', 1);

I receive the error:

Fatal error: Class '...\Framework\App\Action\Action' not found in /data/web/public/app/code/.../Controller/Index/Index.php on line 15

Is something missing in my apache configuration? I'm using hypernode vagrant box for magento2.

1

PHP do not have API to catch FATAL Errors (especially in PHP < 7) it's why you need to enable display error by self

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.