0

I am trying to install site offline which is currently online.

But admin panel coming without css and js.

Any help.

In chrome console I got this

Resource interpreted as Stylesheet but transferred with MIME type text/html: "https://localhost/venky/admin/".
localhost/:7 Resource interpreted as Stylesheet but transferred with MIME type text/html: "https://localhost/venky/admin/".
(index):1Uncaught SyntaxError: Unexpected token <
(index):1Uncaught SyntaxError: Unexpected token <
(index):1 Uncaught SyntaxError: Unexpected token <
(index):1 Uncaught SyntaxError: Unexpected token <
(index):1 Uncaught SyntaxError: Unexpected token <
(index):45 Uncaught ReferenceError: varienForm is not defined(anonymous function) @ (index):45

I tried 'view page source'

I got code

When I click on css or js links they just reload the page.

In firefox I got this console

This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] localhost
The stylesheet https://localhost/venky/admin/ was not loaded because its MIME type, "text/html", is not "text/css".
  • did you check your console log and also your skin folder has the right permissions? – Shaheer Ali May 10 '16 at 6:55
  • do you mean you are trying to install dump of currently live site to other place ? delete var/cache folder – Minesh Patel May 10 '16 at 6:58
  • is frontend working properly? – Ashish Madankar M2 Professiona May 10 '16 at 6:59
  • I updated my question @ShaheerAli – Jatin Raikwar May 10 '16 at 7:02
  • I tried deleting var/cache folder Not working @MineshPatel – Jatin Raikwar May 10 '16 at 7:04
1

Create an .htaccess file into your root folder (or update the existing one) with this line inside

AddType text/css css 

this will tell apache to send the right content-type header for .css file

Update

your are putting https in your url . But not configured ssl on localhost. remove s from your url . try like http:\\localhost\your_store_url

|improve this answer|||||
  • Not working @ShaheerAli – Jatin Raikwar May 10 '16 at 7:08
  • @Jatin you made any more changes to .htaccess file like RewriteRule or some thing else and what is your local sever type and platform ? – Shaheer Ali May 10 '16 at 7:10
  • I am using xampp @ShaheerAli – Jatin Raikwar May 10 '16 at 7:15
  • I updated my question @ShaheerAli – Jatin Raikwar May 10 '16 at 7:17
  • 1
    put http in your url @Jatin – Shaheer Ali May 10 '16 at 7:28
0

First check the permission. if all oks then

Try this:

SELECT * FROM core_config_data WHERE path LIKE '%merge%';

You should get two results. Try setting them to 0 if they are enabled, and then remove your /var/ folder to clear cache.

|improve this answer|||||
  • I tried not working @AshishMadankar – Jatin Raikwar May 10 '16 at 7:06
  • I updated my question @AshishMadankar – Jatin Raikwar May 10 '16 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.