I have just installed magento2.4 with sample data. Setup looks fine from frontend and backend also, but facing 2 issues -
1 - when I run 'indexer:reindex' command, it giving me below issue -

Catalog Search index process unknown error: {"error":"MapperParsingException[No handler for type [text] declared on field [_search]]","status":400}

don't know why it is giving this issue,

2 - I have created one more website/store in same instance. Created a different root category and 2sub categories in it, and also assigned products to these new subcategories, but products not showing on frontend over this website. On default website they are showing properly. I checked, they are in-stock, have qty greater then 0, assigned to respective website also.
run indexer and cache clean command multiple time..but no success.

Both site's frontend URl's are -

http://localhost/mage2/us (on this products showing properly)

http://localhost/mage2ca (Same products not showing here)

Plz helo me to solve this. enter image description here

  • Do you have elasticsearch enabled? as this error is well known when running elasticsearch locally Commented Sep 8, 2020 at 12:51
  • Error was due to ElasticSearch version, Below solution remove the errors but solution not worked for me. So. I have uninstall the old Elastic Search and install the latest one version 7.9. And installed the magento again after that...and that works fine now ....thanks guys
    – Atul
    Commented Sep 29, 2020 at 8:28

3 Answers 3


While upgrading did you came across with errors? If yes please install the setup again.

I can share the stepwise guide to install setup with error-free code.

Let me know in case it is required because I am also working on this setup and it is working fine.

Make sure you are using the correct version of xamp(7.3/7.4)

FOR Elasticsearch please run this command: php bin/magento module:disable Magento_Elasticsearch6 Magento_Elasticsearch Magento_Elasticsearch7

Still, if issues come let me know.

For installation steps please go through : https://github.com/rashigoyal14/main/blob/master/installation%20steps.odt

Thanks, Rashi

  • Hi #Rashi, after disable the respective elastic search module that error is gone but while running indexer command getting this error now - Catalog Search index exception: Type Error occurred when creating object: Magento\Search\Model\EngineResolver Can you help me to solve this...
    – Atul
    Commented Sep 23, 2020 at 11:13
  • Hi Atul, The interceptor file needs to be re-created. So kindly run di:compile and clean cache. Also, confirm if you are creating something custom? Any custom file in which you are using classes or creating custom functions? Commented Sep 24, 2020 at 12:10
  • I did same but same result, Now I have uninstall the elasticsearch and now trying to install again but for elasticsearch version 7.4or 7.9 getting this issue - failure: repodata/repomd.xml from elasticsearch-7.4: [Errno 256] No more mirrors to try. artifacts.elastic.co/packages/oss-7.4/yum/repodata/repomd.xml: [Errno 14 ] HTTPS Error 404 - Not Found
    – Atul
    Commented Sep 24, 2020 at 12:22
  • @Atul there is no need to install ElasticSearch. Just install Magento 2.4 setup and Xampp 7.3. After that follow the steps I mentioned in the last comment. Everything will work fine Commented Sep 28, 2020 at 4:58
  • @RashiGoyal form me disabling all those modules throws the following message: php bin/magento module:disable Magento_Elasticsearch6 Magento_Elasticsearch Magento_Elasticsearch7 Unable to change status of modules because of the following constraints: Cannot disable Magento_Elasticsearch because modules depend on it: Magento_ElasticsearchCatalogPermissions: Magento_ElasticsearchCatalogPermissions->Magento_Elasticsearch
    – Radu
    Commented Jan 5, 2021 at 15:40

Hi First of all please check your catalog search engine using below command

<root>bin/magento config:show catalog/search/engine

Now if it set to MYSQL which is deprecated in magento 2.4, which you can read here in the official release notes:-


Now Change your Catalog Search engine to elastic search 7 by using below command.

bin/magento config:set catalog/search/engine elasticsearch7

Now you just need to configure your elastic search in


you can also follow this blog to know more about configure elastic search https://magecomp.com/blog/magento-2-how-to-configure-elasticsearch/

PLEASE NOTE THIS THING IF YOU WANT TO UPGRADE TO MAGETNO 2.4.0 IN FUTURE:- You must install and configure Elasticsearch 7 before upgrading to Magento 2.4.0. New installations require a connection to Elasticsearch to complete.


The catalog search index error generally occurs when Elastic search is not compatible with Magneto installed. In magento 2.4, elastic search is not setup automatically. So you can disable the elastic search for the moment using below command:

php bin/magento module:disable Magento_Elasticsearch6 Magento_Elasticsearch Magento_Elasticsearch7

And then check. The issue must get solved. But this would affect your catalog search for products. So I would suggest you to reinstall Magneto2.4.

You can check the installation steps here: https://meetanshi.com/blog/install-magento-2-4-via-command-line/

Make sure your elasticsearch is configured before installing magento 2.4, otherwise the same issue will be seen again.

Please let me know if this solves your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.