Hot answers tagged

44

SOLUTION # 1 (IF YOU WANT TO EDIT XML FILE) I would like you to download Magento 2 zip from magentocommerce.com/download with sample data, create new db in phpmyadmin, extract zip in htdocs folder. Install Magento 2 but do not use localhost use 127.0.0.1 in store URL and admin URL. After successful installation DO NOT run magento. Now we are going to clear ...


13

Kick off the log cleaning yourself, manually (or set up in a CRON as I usually do): Usage: php -f log.php -- [options] php -f log.php -- clean --days 1 clean Clean Logs --days <days> Save log, days. (Minimum 1 day, if defined - ignoring system value) status Display statistics per log tables help ...


10

If you are facing problem of css and js page load design after installation in magento2 please follow the following step-: open the terminal and navigate to magento web root $ cd /var/www/html/magento2 Step 1. $ php bin/magento setup:static-content:deploy Step 2. $ php bin/magento indexer:reindex Step 3. make sure apache “rewrite_module” is ...


8

you just need to update the apache2.conf file. On Ubuntu 16.04 Open and edit the file /etc/apache2/apache2.conf Navigate to the place in the apache2.conf file <Directory /var/www/> Change "AllowOverride None" to "AllowOverride All" Save the file Restart apache2 -> sudo service apache2 restart


8

I just updated to Magento 2.1.6 on Windows and had this same issue. I did a little searching and came across a post on Github here. In a nutshell you need to do two things in vendor/magento/module-catalog/Model/View/Asset/Image.php. The first thing is replace all occurrences of DIRECTORY_SEPARATOR with '/' The second is edit the getRelativePath function ...


7

I have been running a live e-commerce site now on server 2008 for about 3 years now. (Running Magento 1.7) I was told initially that this would be supported, and a piece of cake to run, however I have never run into this many issues, especially with speed, and support of third party extensions. All of my .Net application run fine, and the web/db server ...


7

most likely not the answer you want, but here it is: http://magento.com/resources/system-requirements Supported Operating Systems: Linux x86, x86-64 Supported Web Servers: Apache 1.3.x Apache 2.0.x Apache 2.2.x Nginx (starting from Magento 1.7 Community and 1.12 Enterprise versions) In the 5+ years I have been using magento, I had never come ...


5

Try to disable cache if you do not disable it before Make sure you have the latest version of Magento with clean code. If you modify or customize something make sure fix all errors. Run several commands below may help you. php bin/magento indexer:reindex php bin/magento cache:flush Remove folders in pub/static/frontend/* var/cache var/view_preprocessed/* ...


5

I had the same issue resolved by adding sudo nano /etc/apache2/apache2.conf Modify this <Directory /var/www/> Options Indexes FollowSymLinks AllowOverride None Require all granted </Directory> to this <Directory /var/www/html> Options Indexes FollowSymLinks AllowOverride All Require all ...


5

Here is the simplest solution if showing version name in css path like : pub/static/version323334/ then run this query in mysql INSERT INTO core_config_data (path, value) VALUES ('dev/static/sign', 0) ON DUPLICATE KEY UPDATE value = 0; after that clear the config cache bin/magento cache:clean config you can also disable static file version from ...


5

It seems like you have Xdebug installed. Try increase the value of xdebug.max_nesting_level in your php.ini: ini_set('xdebug.max_nesting_level', 200) http://xdebug.org/docs/all_settings#max_nesting_level


5

the only thing you should pay attention to is not having class names with uppercase letters inside the class path. This works on both: Namespace_Module_Model_Classname. This may fail on linux: Namespace_Module_Model_ClassName. If you instantiate the class mentioned above as Mage::getModel('module/classname') it works on both Linux and Windows if you ...


4

I don't know what your problem might be, but to answer your question... I can confirm that Magento 2.0 (at least the dev-73 build - the last one I installed) is working on windows. I've successfully installed it on xampp 1.8.3 on windows 7 and on windows 8 (without xampp). Even on xampp on windows XP (may he rest in piece).


3

For me it was simply because mod_rewrite wasn't enabled. sudo a2enmod rewrite and service apache2 restart


3

I managed to figure it out. The problem was difference of timezones between Magento and Database. Mysql was GMT but Magento was set at +3.5 (Asia/Tehran). So There was no problem actually. If you reach this problem set the Start Time based on Timezone you set in Magento before, but remember that that time in database may be saved differently. And it is ...


3

MySQL seems to complain that table or view already exists during install. I would start with wiping the database by dropping all the tables.


3

Introduction: The Windows Subsystem for Linux (WSL) is a new Windows 10 feature that enables you to run native Linux command-line tools directly on Windows, alongside your traditional Windows desktop and modern store apps. The Windows Subsystem for Linux lets developers run GNU/Linux environment -- including most command-line tools, utilities, and ...


2

As others have already said, Magento 2 will work on Mac, Linux and Windows. The issue you are experiencing is caused by the default xdebug max nesting level value of 100. The error you are seeing will only exist if: Xdebug is installed xdebug.max_nesting_level hasn't been increased from the default value I suggest that you find the php.ini file being ...


2

Edit your app/etc/local.xml file and add these lines in the section: <cache> <backend>Zend_Cache_Backend_WinCache</backend> <slow_backend>file</slow_backend> </cache> Do the same steps as described above or here: Magento LAMP vs WIMP: Running Magento with IIS and WinCache After saving your local.xml file be ...


2

According to the Magento System Requirements IIS is not supported out of the box by Magento: Operating System : Linux x86-64 Web Server: Apache 2.x Nginx 1.7.x However, it seems like some people achieved to install Magento on IIS and even better, they documented how to do it. You can find a detailed guide here: http://tarunjadav....


2

Either the file cron.sh or cron.php must be executed periodically by the server's system cron in order to trigger Magento's internal cron. It's a two step process. You can simulate having the cron job set up by calling cron.php from a web browser, wget or curl periodically to see if Magento is internally setup properly, for Magento cron jobs to fully run, ...


2

just fall back to default sessions in your app/etc/local.xml file. <session_save><![CDATA[files]]></session_save> and remove the redis_session configuration


2

You have to run indexing command. if you are using windows than run below command in cmd. you have to run these commands in your magento root directory: php bin/magento indexer:reindex php bin/magento cache:clean NOTE: If you have just installed magento than you might need to run below commands as well: php bin/magento setup:upgrade php bin/magento setup:...


2

you have issue of indexing. You can indexing using cli, Commnad php magento indexer:reindex After successfully run indexing , your issue are gone. Thanks.


2

reindex magento2 using command Your path like var\www\html\magento2\bin Now You have to enter command sudo php magento indexer:reindex Show your index management all indexes are re-indexed. I hope this will help you.


2

You can create cron.bat file like this @echo off cls :start echo This is a loop cd %magento_root% bin/magento cron:run sleep 10 goto start to emulate cron.


2

You must configure a cron.job in your server to automate a some internal tasks like reindexing, email sending and cleaning between others, there is 3 cron jobs in magento2 you will find all information about that in: Configure and run cron Magento has a complex db schema to save categories and products data and "render" all these information to a single ...


2

Solved !!! Run following commands in CLI interface of your Magento2 root folder: php bin/magento setup:static-content:deploy php bin/magento indexer:reindex Then delete var folder by this command at your root of magento2. rm -rf var/* Then refresh your homepage and admin panel. Its Working !!!!! Cool !!!!


2

I found a solution, modify app.js in your skin folder and at line 153: Change var pointerEvent = 'touchend'; to var pointerEvent = 'mouseover'; There is also a bug with the zoom on the product view (zoom isn't active on the first image), change line 711 from: ProductMediaManager.createZoom($j(".no-touch .gallery-image.visible")); //set zoom on first ...


2

In my case I accidentally deleted .htaccess file from ROOT/pub/ and ROOT/pub/staticfolders. Then it is started working when I revert it back.


Only top voted, non community-wiki answers of a minimum length are eligible