Skip to main content
6 votes
Accepted

how to solve Magento vulnerability issue

While I have no idea which report you ran, this is how you should be able to solve it: vulnerability Name: Php Info File You most certainly have a file named phpinfo.php in your document root (=main ...
Anna Völkl's user avatar
  • 17.3k
3 votes
Accepted

Magento 2.3.0: Magento Unprotected XML

The permissions for .user.ini can be -rw-r----- (or 640 in octal). This removes access for anyone other than owner and group members. (As Hunter said, you can check permissions by running ls -la in ...
BugBuddy's user avatar
  • 206
3 votes

Should I be worried about the latest Zend-Mail RCE Vulnerability similar to the PHP-Mailer/Swift Mailer Vulnerability if I use Magento?

Yes, you should be worried about this. Magento also published a post on their security center, describing a temporary workaround until they released a patch: https://magento.com/security/news/new-zend-...
Aad Mathijssen's user avatar
3 votes

Log4j CVE-2021-44228 Magento 2.3 / 2.4 with ElasticSearch

Question 1: By the logs, it seemed to be infected. Question 2: To update your .jar files you need to update your ElasticSearch to the last version launched today Dec 13, 2021. It brings the new .jar ...
Rafael Corrêa Gomes's user avatar
2 votes
Accepted

Use of Jquery 1.10 with Known Vulnerability

The jquery issue is fixed with a simple patch https://github.com/jquery/jquery/issues/2432#issuecomment-403761229 It sounds severe but really is a minor issue https://www.cadence-labs.com/2018/07/...
Dominic Pixie's user avatar
2 votes

Magento 2.3.0: Magento Unprotected XML

PRODSECBUG-1883: Leakage of Custom PHP settings from .user.ini File Description: Access to certain private files is not protected. You can find more information about this and other bugs here. This ...
Hunter's user avatar
  • 809
2 votes
Accepted

Add to Compare: is there known exploitation?

The indexAction of the Product Compare Controller does an $items = explode(',', $items); on all the items sent via URL. This means ,..%c0%af..%c0%af..%c0%af..%c0%af..%c0%af..%c0%af..%c0%af..%c0%afetc/...
Anna Völkl's user avatar
  • 17.3k
2 votes

Should I be worried about the latest Zend-Mail RCE Vulnerability similar to the PHP-Mailer/Swift Mailer Vulnerability if I use Magento?

To your point about sanitization, the issue for most Magento shops would be introduced if control of the sender was given from a client-side form. Consider this core code: class ...
Rick Buczynski's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible