New answers tagged

1

Logging in via SSH The first thing you need to do is gain access to the system via ssh. If you're on Windows you'll have to download PuTTY. If you're a Mac user, you can use the Terminal app to run ssh The SSH protocol runs over port 22 and gaining access happens either via username & password, or via an SSH key. Here's an example where you use the ssh ...


0

As far as i know; magento assign a X-Magento-Vary cookie to each visitor first you visit website. So your first request always be non-cached version. After you got a X-Magento-Vary you see cached version served by Varnish. No, that is not correct. This cookie is set only when changing HTTP context, e.g. upon user login, adding to cart, etc. For a regular ...


0

Based on some VCL snippets I found on GitHub, this is probably the code that is responsible for creating the cache variation you want to get rid off: sub vcl_hash { if (req.http.cookie ~ "X-Magento-Vary=") { hash_data(regsub(req.http.cookie, "^.*?X-Magento-Vary=([^;]+);*.*$", "\1")); } # For multi site ...


0

Thanks, guys but I resolved this issue there was nginx.config.sample file was missing from project directory, so replaced it and restarted the server. it resolved this issue. but really thanks for your support.


0

Please have a look at https://magento.stackexchange.com/a/316381/86404 for a more detailed answer. It uses the varnishlog binary to get more insight in why an HTTP/503 is returned.


1

As the error message states Varnish cannot communicate with the content (Magento2) server. If you are using health checks in your Varnish VCL, varnish will also show this error if the content server is "unhealthy". To check your content server status login to the varnish server and enter varnish admin with the varnishadm command. Enter backend.list ...


0

May be you are missing to clear cache, then try again. By the way which url is trying to redirect you as 302 ?


0

I found a solution to this at Varnish - NGINX serving all resources HTTP instead of HTTPS (Magento 2) Since I had such a hard time finding the solution specifically for my setup I'll copy the answer here as well: Find the line like this in nginx.config: location ~ (index|get|static|report|404|503|health_check|phpinfo).php$ { .... } Add this line: ...


0

What are your configuration for cloudflare? Any special settings? Have you modiefied cloudflare to cache html? (its not standard) from cloudflare documentation: Cloudflare does not cache HTML resources automatically. This prevents us from unintentionally caching pages that often contain dynamic elements. For example, the content on certain HTML pages may ...


0

You can check your Varnish configuration with n98-magerun2 Use the command n98-magerun2.phar config:show | grep full_page_cache You should see something like the following where magento2_php-apache_1 is the hostname of your Magento 2 server and backend_port is the tcp port of the content (magento 2) server system/full_page_cache/caching_application - 2 ...


0

Ban & purge The standard Magento VCL configuration has logic inside the vcl_recv subroutine to invalidate the cache. This uses the ban VCL function. Here's an extract: if (req.http.host && req.http.host != "" && req.http.host != "127.0.0.1") { ban("obj.http.X-Host ~ " + req.http.host + " && ...


Top 50 recent answers are included