31

This message means that one of the blocks that is used in your Magento store is not on the whitelist. With Security Patch SUPEE-6788 and Magento CE 1.9.2.2 a new whitelist for blocks was introduced. Magento now includes a white list of allowed blocks or directives. If a module or extension uses variables like {{config path=”web/unsecure/base_url”}} and {{...


5

Remove % from 'Image Watermark Opacity, Percent'. Just put in a number, like 15.


4

May be problem with caching issue, check it with my below suggestion. Remove /var/cache folder from root path. Run below command for re-indexing. php bin/magento indexer:reindex I hope it will solve your issue.


3

In app/Mage.php method log(): if (!self::$_isDeveloperMode && !$logActive && !$forceLog) { return; } A log will be written if the system is in developer mode, or the log is active, or the $forceLog parameter is true. Since you say logging is disabled, and since the error handler does not force logging (as defined in app/...


3

If you take a look at the function getFeedData() in class Mage_AdminNotification_Model_Feed you can see that your error line 173 is Magento calling new SimpleXMLElement with a parameter $data. /** * Retrieve feed data as XML element * * @return SimpleXMLElement */ public function getFeedData() { $curl = new Varien_Http_Adapter_Curl(); $curl-&...


3

What Varien_Autoload tries is to find files for the following classes: ReallySimpleCaptcha WPSEO_Frontend All_In_One_SEO_Pack Woocommerce Search your code base for these to find out where they are referenced. To me it looks like these are classes from Wordpress plugins. The last error also proves that you included Wordpress code - maybe from the Fishpig ...


2

Pretty simple: You're trying to cast $value as a string for the comparison, but $value is an array. If $value has some kind of value you need in it (perhaps it's nested inside an array) for the comparison, then you must process it so that it is not array. Do this before the if statement. var_dump($value); die; Or Mage::log($value); // Check var/log/...


2

In your app/code/local/Magerevol/Brands/Prodpage.php before line 29 you can do the following, I assume it's an array problem and line 29 contains some code like this: $array[0] To find out the product that's causing problem you can do: if (array_key_exists(0,$array)) { // Do what's your code is supposed to do } else { Mage::log("This product is ...


2

If you go to the file mentioned in the log - /app/code/local/Magerevol/Brands/Block/Prodpage.php on line 29 Here you can add your own logging, the line should be throwing some sort of exception, wherever it fails, add the following: $logger = Mage::getModel('core/log_adapter', 'my.log'); $logger->log(Mage::helper('core/url')->getCurrentUrl()); Now, ...


2

It is not an error, it is just a notice, you can ignore it. Otherwise fix it in this way: $currentId = count($dynamicValues) ? $request->getParam($dynamicValues[0]) : null; Also try: $currentId = isset($dynamicValues[0]) ? $request->getParam($dynamicValues[0]) : null; You can also suppress notices in PHP by changing the error_reporting php ini ...


2

I got this solved by running the below query to the database: delete from catalog_product_entity_varchar where attribute_id=98 and value=""; where 98 is the attribute_id of url_path attribute. Hope this helps someone!


2

This could be the solution according to Github (Link to Github) Keep the URL key column blank, and make sure you have added the correct category name with upper and lower case letter. Make sure the total length of your categories CSV column is shorter than 255 characters. You can check your url_key length too, but I haven't run into issues with my data set ...


2

You need to create the helper as it will be used in your system.xml for translation purpose. As soon as you write: <custompaymentmethod translate="label" module="custompaymentmethod"> The module attribute specifies the helper to be used. All you need to do is create an empty helper class Helper/Data.php : <?php class ...


2

You are getting errors because the code is trying to get properties of an object even if its not set. Above code should look something like this. public function getTitle() { $pagetype = $this->metaHelper()->getPageType(); if ($pagetype && $pagetype->_code != "cms") { if (!$pagetype->_model->getMetaTitle()) ...


2

It is about your cron job issue. you also get these entries in your database. Check your CRON table. This is CRON notification. You can disable log from admin


2

Try this commands as a root user find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + sudo chown -R <Magento user>:<web server group> .  It seems to be a permission issue only, if the image is not found there you will be getting ...


1

Your extension of ::helper() isn't compatible with the class you are extending. Even though you are manually setting the helper name in your custom file, you should still pass in the $name property if you are in strict mode, even if you don't use it. You could probably even do this: public function helper($name = 'as_freeshippingmsg') { return parent::...


1

There are multiple issues on Github about this and the conclusion is that these errors are a "known issue", no-one really cares to fix them, and they're not actually Critical. Discussed for example here: https://github.com/magento/magento2/issues/5627


1

It looks like there is come code that is logging the layouts that are being called whenever a view is loaded. Magento allows you to log data using the following: Mage::log('some data'); The above will result in DEBUG (7): some data in the system.log file Perform a search for Mage::log on you app > code > local folder, find the line that is ...


1

Ssh to your root magento installation, then reindex data with bellow command: php bin/magento indexer:reindex Then remove the cache: php bin/magento cache:flush And finally give access to your apache user: chown -R www-data:www-data ./* I believe this will solve problems of that type.


1

The mentioned error log is of compiled files. Either disable compilation Or recompile by navigating to System > Tools > Compiler


1

add this file if you are using the blog app/code/local or community/AW/Blog/Controller/Router.php other wise commnet this code inside app/code/local or community/AW/Blog/etc/config.xml <events> <controller_front_init_routers> <observers> <blog> <type>singleton</type&...


1

It looks like something is breaking the adminhtml feed module. The cause could be a third-party module that is retrieving invalid XML. Check whether your site code contains any class which extends Mage_AdminNotification_Model_Feed. Once you find it: ->Try to disable that module from app/etc/modules/ ->Clean the system.log. ->See if the error is gone....


1

Probably issue comes on working category URL. please ignore backslash('/') in categories column "Default Category/Shop/" Wrong categories assign = Default Category/Shop/ Right categories assign = Default Category/Shop


1

For those that are importing the products via a CSV file or a excel spreadsheet and it was working before but suddenly stop to work. You probably have a PRODUCT or a CATEGORY been uploaded that already contain the same default URL KEY. Check the products or categories that you manually added or updated. Check their URL KEY attribute. A painful way to find ...


1

I guess there is an Mage::log() call with param $forceLog = true: public static function log($message, $level = null, $file = '', $forceLog = false)


1

For me at least, both the EMPTY NEEDLE issue and the SCRIPT_FILENAME issue, seems to be resolved. Turns out the answer was linked in my original post for this problem, but either it was updated when I went back to research it again, or I didn't get it the first time. If you go in to your Cron Jobs at your Host or wherever you are originally calling them from,...


1

The $includeFilePath is a calculated/modified value and not directly the source of your trouble. In order to track that down, you need to find out what $this->_viewDir . DS . $fileName (l. 239) evaluates to and what block type (class name of $this, descendant of Mage_Core_Block_Template) is affected when the error occurs. I am pretty sure that an ...


1

Quick fix is to add some dummy files in the app/code/community folder eg 'ReallySimpleCaptcha.php' That worked for me, just make sure that the start with <?php


1

The simplest solution would be to move your Magento install from that subdirectory into a subdomain. So you would then have store.yourdomain.com. A WordPress plugin appears to be triggering the Mage Autoload function. Alternatively you could disable your WordPress plugins until the errors stop and then you will find the culprit. It seems likely a caching/...


Only top voted, non community-wiki answers of a minimum length are eligible