SUPEE-6788 is a security patch released for Magento CE <= 1.9.2.1 / EE <= 1.14.2.1

SUPEE-6788 is a security patch released for most Magento CE versions below 1.9.2.2 on October 27th, 2015. The patch was initially released a week earlier before being retracted to evaluate compatibility and migration requirements. Versions prior to 1.7.0.0 currently do not have a patch available, although it is expected to be released in the first week of November, 2015.

This patch provides protection against several types of security-related issues, including remote code execution, information leaks and cross-site scripting.

The patch includes a number of fixes for APPSEC security issues and includes breaking changes which will likely require modifications to installed extensions. The patch requires all previous security patches to have been applied as a pre-requisite.

Details of the issues addressed are included in the 1.9.2.2 release notes and on this official blog post.

history | excerpt history