12

So far, I have come across the following issues with the SUPEE-10975 patch: It is not possible anymore to delete customer groups via the admin because of a missing return statement in the new method Mage_Adminhtml_Block_Customer_Group_Edit::getDeleteUrl (issue found by @mikhail-chelevich). This is the case when secret keys are enabled for the admin, which ...


11

Missing return parent::getDeleteUrl() in app/code/core/Mage/Adminhtml/Block/Customer/Group/Edit.php + public function getDeleteUrl() + { + if (!Mage::getSingleton('adminhtml/url')->useSecretKey()) { + return $this->getUrl('*/*/delete', array( + $this->_objectId => $this->getRequest()->getParam($this-&...


8

I ran into an issue with the 10975 patch. After some investigation I was able to track down the answer as to where the patch was messing up and why. To summarize the below check and make sure you patched SUPEE 9767 V2 properly. That is the root of my issue. sh PATCH_SUPEE-10975_EE_v1.12.0.2_v1-2018-11-27-10-36-30.sh Checking if patch can be applied/...


5

Firstly, sorry for the duplicate of erej's answer, i can't comment nor edit because of my reputation score. The patch creates a new file here : app/code/core/Zend/Controller/Request/Http.php Which is added to override this file : lib/Zend/Controller/Request/Http.php Problem is for Magento under 1.9.0.0 (EE 1.14.0.0) : This method : /** * Everything in ...


4

With version 1.8.1.0 after applying this patch we also had to change app/code/core/Mage/Core/Controller/Request/Http.php::getBaseUrl() function to be public function getBaseUrl($raw = false) { $url = parent::getBaseUrl($raw); $url = str_replace('\\', '/', $url); return $url; } because this patch adds app/code/core/Zend/Controller/Request/Http....


4

I have a problem with 'Hunk #1 FAILED at 28' Rejects are supposedly saved to config.xml.rej but this file doesn't exist, neither is there any description of what part of the script failed in my terminal window. Basically the patch fails and there is no indication why - at least not to a dumbass like me! On first run the patch attempted to delete three ...


3

The Mage_Backup Module will be disabled by the patch. This is mentioned in the official release notes (https://devdocs.magento.com/guides/m1x/ce19-ee114/ce1.9_release-notes.html#ce19-1940). However the suggested solution to re-enable it is wrong: ("Alternatively, you can use one of these two methods to enable database backups") You actually need to use ...


2

There can be issues with handling tax calculation correctly. As is customary in many countries, our customer uses the "prices include taxes" configuration of Magento. So, after the update from 1.9.3.10 to 1.9.4.0, the tax got added to the grand total in checkout, on top of the item prices already including taxes. I tracked the issue down to a change in ...


1

I have found jQuery versions hidden in the following places while updating our client's sites. Codebase (phtml/xml files) Backend Config HEAD/Footer html areas CMS Blocks Modules / JS Libraries loading their own version of jQuery Being dynamically injection after the sites loaded via javascript somewhere First thing would be to check if its within the ...


1

It looks like you missed to install some earlier patches. Check your /app/etc/applied.patches.list file and check that all the patches for your version are installed. You find all the patches on the same site where you have downloaded supee-10975. Maybe you fix your problem if you install the missing patches in the right order.


1

Can you attach the contents of the patch file and the contents of the Get the original file contents of the file app/code/core/Mage/Core/etc/config.xml. All you have to check in the patch file about what changes are being done to this file. Also, check what is expected at the line 28 of the file app/code/core/Mage/Core/etc/config.xml. Alternatively, what ...


1

Specific problem, but if you disabled Mage_Sendfriend (which previously was a module you could safely disable) it will throw an exception error.


Only top voted, non community-wiki answers of a minimum length are eligible