Skip to main content
26 votes

Security Patch SUPEE-10415 - Possible Issues?

The below files are updated/added after applied patch SUPEE - 10415. app/Mage.php app/code/core/Mage/Adminhtml/Block/Report/Review/Detail.php app/code/core/Mage/Adminhtml/Block/Report/Tag/Product/...
Rama Chandran M's user avatar
12 votes

Security Patch SUPEE-10415 - Possible Issues?

SUPEE 10415 Requires 8788 v2 patch I encountered the same error as a previous post but it seems to have been removed. a:5:{i:0;s:23:"Unsupported data type N";i:1;s:2942:"#0 /chroot/home/mywebroot/...
danmentzer's user avatar
11 votes

Security Patch SUPEE-10415 - Possible Issues?

We've had an issue with this patch where the every page on the site started showing "404: Page Not Found" error from the errors/ directory. After a little digging it turns out it was caused by a PHP ...
Tomas Gerulaitis's user avatar
9 votes

'Unsupported data type N' after patching SUPEE-10415

See: Security Patch SUPEE-10415 - Possible Issues? You basically need to have SUPEE-8788 V2 installed. Failing that download Magento 1.9.3.7 and copy lib/Unserialize/Parser.php lib/Unserialize/...
Matt Antley's user avatar
  • 1,210
8 votes

Security Patch SUPEE-10415 - Possible Issues?

1.Resolved:Invalid Secret Key issue when when a user loads the Admin In this patches , Magento no longer displays the “Invalid Secret Key. Please refresh the page.” message when a user loads the ...
Amit Bera's user avatar
  • 77.6k
7 votes

Security Patch SUPEE-10415 - Possible Issues?

If you've already applied SUPEE-10358^, or manually patched app/code/core/Mage/Adminhtml/Controller/Action.php for the "Invalid Secret Key" issue, then you will need to manually delete that section ...
kmdsax's user avatar
  • 562
5 votes

Security Patch SUPEE-10415 - Possible Issues?

Issue: patch does not work on vanilla 1.9.1.1 Edit 1: fix added below. Edit 2: my fix is no longer needed, Magento provided SUPEE-10497 which fixes this problem. Problem: # file: PATCH_SUPEE-...
Jeroen Vermeulen's user avatar
3 votes

Security Patch SUPEE-10415 - Possible Issues?

Here is the complete change log and what I understand with this changelog And which files were affected by what cause is listed below Escape Html change file app/code/core/Mage/Adminhtml/Block/...
Murtuza Zabuawala's user avatar
3 votes
Accepted

After applying SUPEE-10415 Magento 1.9.3.3 404s but works fine if redis is removed from the local.xml

I'd give https://magento.stackexchange.com/a/203746/41117 a read. I had a similar issue when testing SUPEE-10415 and having Redis enabled, if you revert SUPEE-10415 and enable the Developer logs ...
Matt Antley's user avatar
  • 1,210
2 votes
Accepted

SUPEE-10415 prevents basket control

I've got Magento 1.9.2.4 and lib/Unserialize/Reader/Null.php was already present? contents; <?php /** * Magento * * NOTICE OF LICENSE * * This source file is subject to the Open Software ...
Ricky Odin Matthews's user avatar
2 votes

'Unsupported data type N' after patching SUPEE-10415

I had the same problem on Magento 1.9.2.4. Rolled back all SUPEE patches until the version SUPEE 8787 V1 (including this one) according to the app/etc/applied.patches.list and installed SUPEE-8788 ...
Jaanek Liiskmaa's user avatar
2 votes

How to solve Security patch 10415 Error?

You need to make sure you have all previous security patches applied or there will be conflicts like the ones listed above. A hunk FAILED error is when the content within the file being patched doesn'...
Matt Antley's user avatar
  • 1,210
1 vote

Security Scan supee-10415 false positive?

It is showing with grey background color in magereport ? Recheck in your root if it is correctly installed grep '|' app/etc/applied.patches.list Check the magereport suggestion on why the patch is ...
Ylgen Guxholli's user avatar
1 vote

How to solve Security patch 10415 Error?

If you are sure about installing all the previous patches of this patch(PATCH_SUPEE-10415_CE_1.9.2.3_v1-2017-11-27-06-50-52.sh) try to compare the code diff in the patch file to that of the file where ...
Kalyan Chakravarthi V's user avatar
1 vote

Patch SUPEE-10415 applied but Form Key Validation message still appears

You still need to enable the form key validation on the checkout as per SUPEE-9767/Magento 1.9.3.6. Login to admin and go to: System > Configuration > Advanced/Admin > Security > Enable ...
Matt Antley's user avatar
  • 1,210
1 vote

Security Patch SUPEE 10415

After patching SUPEE-10415, causes an error “Unsupported data type N” Solution: The cause of this issue is not having SUPEE-8788 V2 installed. To fix this, download Magento 1.9.3.7 and copy lib/...
Meetanshi's user avatar
  • 979
1 vote

Magento 1.9.3.7 / SUPEE-10415: PHP "Cannot redefine" and "Cannot redeclare" errors after merge

unserialize If you have this problem, there should be two declarations of unserialize in app/code/core/Mage/Core/Helper/String.php. Remove the top one, it should be on or near line 84. This way you ...
Toon Spin's user avatar
1 vote

Security Patch SUPEE-10415 - Possible Issues?

Attempting this on Magento EE 1.13.0.2 and it seems this patch doesn't play nice if SUPEE-6482 is installed. Checking patch app/code/core/Mage/Api/Model/Server/Adapter/Soap.php... error: while ...
DanCarlyon's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible