New answers tagged

0 votes

Magento 2: Errors on running setup:di:compile after upgrade from Magento version 2.3.6 to 2.4.5

It's common having errors like that after upgrading Magento 3rd party modules companies are responsible to update their modules to make them compatible with latest Magento version. You'd want to check ...
user avatar
  • 3,333
0 votes

setup:di:compile fails after updating to 2.4.4

Need to require Laminas i18n which was removed with 2.4.4 release. composer require laminas/laminas-i18n
user avatar
  • 1
0 votes
Accepted

How can i overwrite file from vendor so that setup:di:compile won't read it

One option could be to use a patch via composer. You could generate a patch for the class to make it compatible, basically create a diff on the original class and the new compatible class with your ...
user avatar
0 votes

Magento 2.3.2 compilation error

In the Compilation feature of Magento will allow you to compile all files of a Magento installation, in order to create a single include path to increase performance. The performance increase is ...
user avatar
1 vote
Accepted

Error on compilation: Incompatible argument type: Required type: \Aheadworks\Blog\Api\CategoryManagementInterface. Actual type: array; File:

Please try below code and let me know if it works for you <?php declare(strict_types=1); namespace X\Blog\Block\Sidebar; use Aheadworks\Blog\Api\CategoryRepositoryInterface; use Aheadworks\Blog\...
user avatar
0 votes

setup:di:compile fails after updating to 2.4.4

I edited /var/www/html/magento2/vendor/composer/ClassLoader.php and added the line "echo $file . PHP_EOL;" to the includeFile function. Then i ran setup:di:compile again. This showed be the ...
user avatar
  • 23
0 votes

setup:di:compile fails after updating to 2.4.4

you have to sure to remove all modules from the vendor folder before updating itto new Magento version. I suspect some files are hanging in IDE or Docker sync. So: rm -rf vendor/* && composer ...
user avatar
0 votes

setup:di:compile fails after updating to 2.4.4

You have to upgrade your composer version from one to two. sudo composer self-update --2
user avatar
0 votes

setup:di:compile fails after updating to 2.4.4

The issue is from the vendor files especially in the composer auto-loaded. Install the composer module then change the file permission once again as per the magento prerequisites Run the below command ...
user avatar
  • 458

Top 50 recent answers are included