Hot answers tagged

15

Mage::getStoreConfig(Mage_Core_Model_Url::XML_PATH_SECURE_URL); I mention this because no one else has, but I prefer using Mage::getUrl or Mage::getBaseUrl. Both of those automatically detect if the page is already secure when you do not specify it.


14

ITS NOT THAT SIMPLE... There is a problem with changing the store unsecured url to https. Any links to existing pages, including links from ads, indexed pages in Google, etc, that point to http://yoursite.com/your_product.html will be redirected to https://yoursite.com/ You will need to go through your theme and make sure that there are no references to ...


13

Set your base url for both your secured and unsecured site to https://yoursite.com/. That's all you need to do.


11

as @Aphroz said, you can use Mage::getBaseUrl( Mage_Core_Model_Store::URL_TYPE_WEB, true ); in order to retrieve secure base url. This returns secure url because we have specified it through second parameter true. Here first parameter is specified as Mage_Core_Model_Store::URL_TYPE_WEB. This means the method returns value correspond to this system ...


6

For a small scale business Magento EE is probably overkill since the license will probably burn through a good portion of the budget. Magento GO is a hosted solution which means your client will have to pay for it monthly or yearly. And, as far as I know, allows for less modifications than Magento CE. I've built several large projects on the CE version ...


6

The https redirection does not work for cms pages because the Router that matches the cms pages (Mage_Cms_Controller_Router) does not check if some page should be secure. Here is a little workaround to achieve this. It involves changing the router for the cms pages. You will have to create a module. Let's call it Easylife_Secure: For this you will need the ...


5

My suggestion is, hold your horses. For example, if you are using Magento Enterprise Edition, HTTPS for the whole site will stop Magento’s Full Page Cache from working. We created a fix, for anyone to use - https://github.com/elastera/EnterprisePageCacheSSL (your feedback is greatly appreciated). Your Page Load time could be increased significantly, due to ...


5

Enable Frontend SSL. SSL urls are used by default for only certain areas (like checkout and login) in Magento. All that is required is to fill in the SSL url fields of System > Configuration > Web > Secure: Make sure to Enable the option for Frontend SSL. A well-configured theme will have url links back to the CMS portion of Magento that break ...


5

Are you sure that the "trust" is bound to SSL certification here and not just to fact that checkout might be confusing and your clients only go to the checkout to get to know/see the full price with shipping and taxes? You have installed the certificate but have you checked if everything on checkout page is over ssl and you don't get the security warnings ...


5

Below URL Access list Get URLs in CMS pages or static blocks Base URL: {{base url=''}} Store URL: {{store url='test.html'}} also only store URL {{store url=""}} Media URL: only get media URL {{media url=''}} if you get some folder path {{media url='imagefolder/imagename.jpg'}} Skin URL: {skin url='images/imagename.jpg'}} only get skin URL {...


5

Try this: <a href="{{store direct_url="" _secure=1}}">Some text</a> if that does not work try <a href="{{store direct_url="" _force_secure=1}}">Some text</a>


5

I got it fixed now, i'll explain the process below... My admin panel was loading through HTTPS URL's due to our server configuration. However in the Magento Admin panel this option Config > General > Web Use Secure URLs in Admin was set to NO I knew changing this to Yes would probably fix all our admin panel issues. However changing it to yes and ...


5

To secure custom forms, you should take care of the following: 1. Add frontend validation This will not just help the user entering the data in the right form, but might also prevent standard typing mistakes. There are a lot of validation rules in Magento 2 which you can use per default. See also app/code/Magento/Ui/view/base/web/js/lib/validation/rules.js....


4

Based on the comments above, it sounds like your Magento frontend isn't using the frontend cookie for the PHP session. Instead it's using the adminhtml cookie. for both the frontend and backend area. Because of this, when you browse to a frontend page the frontend session code is set in the adminhtml session, and you lose your login. This (most likely) ...


4

You can do so by using the _secure parameter: <?php echo Mage::getUrl('productquestions/productquestions/saveanswers',array('product_questions_id'=>$id, '_secure' => true));?>


3

Customers dropping off just before paying is a fairly common behaviour on a lot of ecommerce sites. It could well be that they are dropping off just before paying for many reasons other than your SSL certificate, or the in-line payment. Often users browse to the checkout screen to see the absolute final totals including shipping and taxes for the order. ...


3

Fixing links like this is going to depend on what created that link. I have seen so many times some custom navigation or footer templates that hard code their URLs. For reference, here is a handy way to check the current protocol and build a URL based on that: $this->getUrl('my-page', array('_forced_secure' => $this->getRequest()->isSecure())); ...


3

Add "is_secure" attribute to product attributes: Attribute Code: is_secure Scope: global Used In Product Listing: yes Visible on Product View: yes Join this attribute to any attribute set. Open any product and set is_secure attribute to "yes" . Use this code while generating the link to the product: <a href="<?php echo $_product->getUrlModel()-...


3

If,you want to used for secure url for any other modules then you need to some change in config.xml of that modules.. First for frontend used tags <secure_url> <productfaq>/productfaq</productfaq> </secure_url> And ,if you for productfaq url then change $this->getUrl('productfaq/index/index', array('_secure'=...


3

There is a function just for that, called shouldUrlBeSecure located in app/code/core/Mage/Core/Model/Config.php on line 1477. Here is the complete function: /** * Check whether given path should be secure according to configuration security requirements for URL * "Secure" should not be confused with https protocol, it is about web/secure/*_url settings ...


3

If you want you site to always use https then you simply need to change the secure and the unsecured URL's to use https via the admin configuration section. System->Configuration->Web->Secure/Insecure This will then make sure that any URL that Magento generates will be over https. After making this change you will probably need to re-index and clear your ...


3

You need to add the secure_url node under frontend in the config.xml of the extension to force the use of the secure-url. Below the snippet used in the config.xml for the Mage_Sales: <frontend> <secure_url> <sales>/sales/</sales> </secure_url>


3

This should work for all page types - my guess is a cached block. Try the following: Append ?no_cache=true to the end of your HTTP-only url Disable all caches and retry Relocate your check to another region - e.g. place it in page/3columns.phtml to verify that it is working as expected.


3

This should do the trick: Mage::getBaseUrl('link',true); Short and sweet.


3

If you use Firebug or Chrome Dev Tools (e.g. Ctrl+Shift+J) you can see there are many errors on your page. For example it's giving a 404 not found error for jQuery. So you need to add jQuery (maybe you just need to fix the path or the permissions) And there are permission denied messages Cross-Origin Request Blocked: The Same Origin Policy disallows ...


3

If this happening after applying the latest magento patch SUPEE-6788 try to disable cms block cache. I had the same problem which also persisted after me adding those cms blocks to magento whitelist.


2

It is not really the URL which is matched against the XML path frontend/secure_url but the module-controller-action path. In your case this would be /cms/page/view. If you insert /cms/page/view all CMS pages would be delivered via HTTPs. The test is happening in Mage_Core_Model_Config::shouldUrlBeSecure which is called from Mage_Core_Model_Url::getSecure() ...


2

Make sure your session cookies are accessible via both http and https. You will need to enter in .domain.com in Magentos admin->system->configuration->web->cookie domain. You will need to make the cookie available to your other domains in order for it to be read. This is the same with all web applications. Reference: http://www....


Only top voted, non community-wiki answers of a minimum length are eligible