What's the deal with Deno? We talk with a major contributor to find out. Listen now.

New answers tagged

1

This might also be related to some kind of an infinite loop into your code or internal error in your code. You might want also to check on your var/log/system.log to see if there isn't any error that could explain that. If you have no error, then in your special case, the most appropriate would be to rise the max execution time before your import with the ...


0

Hi this is definitely a PHP version error. I had Magento 2.1.2 and the Godaddy hosting server was running PHP 7.3. After downgrading PHP to version 5.6, problem was solved.


0

Update to "~3.1.0". You can get list of available versions like this composer show magento/magento2-functional-testing-framework 3.*.* --all | grep -m 1 versions


1

You can use this free extension available and use it accordingly. https://landofcoder.com/advanced-magento-2-product-reviews.html


0

Please use the code to sort review. This code is for sort by ratings. $countColumn = new \Zend_Db_Expr("COUNT(*)"); $percentColumn = new \Zend_Db_Expr("SUM(percent)/".$countColumn ); $this->_reviewsCollection->getSelect()->joinLeft( ['rating_vote'=>$this->_reviewsCollection->getTable('rating_option_vote')], '...


1

Try the following way: if($request->getPackageWeight() > $this->getConfigData('max_weight')) { return false; }


1

explode can split a string by a string into an array Here is a reference sample. $customerGroup = $this->_customerSession->getCustomer()->getGroupId();//1 $groupsInString = $this->getConfigData('groups'));//(string) "1,5,9,10" $groupsInArray = explode(",",$this->getConfigData('groups'));//(array) [1,5,9,10] if(!in_array($...


0

You receive a comma separated string from the db. use explode (php native function) and then in_array() docs for explode https://www.php.net/manual/en/function.explode.php


0

Was there ever a solution to this? gets a lot of traffic would be good to know a lot of M1 users coming up to issues pertaining to this now. Like me as well. Currently running 1.9.4.4 perfectly fine on 7.2, but server moving to 7.3 and want to make sure it will still be ok! By the way, i had to post an answer because i do not have enough reputation to ...


Top 50 recent answers are included