New answers tagged

0

What magento mode do you use? Is the module enabled? php/bin magento module:status Js compnent belongs to a "frontend" layer and should be compiled with bin/magento setup:static-content:deploy (in case that you are in production mode) f you are in developer mode and module is enabled then remove data from <dir>/pub/static/* and flush web client cache ...


0

I get the solution by I changed the following code /** * @var string protected $_code = 'prepaid'; /** * @var string */ protected $_gatewayCode = 'prepaid';


0

I have fetched same issue after migration. May be the issue related sequence table in database. Update sequence_order_0 and sequence_order_1 table, set primary key sequence_value and insert two or three number entry.


0

I'm having the same problem at the moment, just using stock paypal express module. And we're getting this error.. Property "DisableTmpl" does not have accessor method "getDisableTmpl" in class "Magento\Quote\Api\Data\PaymentInterface". In the IWD Onepage checkout, it doen't matter if i disable it or not.. it's very frustrating.. we're also working with ...


0

The above method also worked for me, but my file location was different. /httpdocs/app/design/frontend/base/default/template/onestepcheckout/material/onestepcheckout/payment_method.phtml


1

You need to create an INVOICE and thats all. When you create the invoice Amount Due will become paid (Your admin user has just to create the invoice once order is created, or you can create it programatically so he does not take that step) NOTE : Why don't you just use check / money order method ? Do your custom method have specific logic? Before invoice :...


0

I was able to solve the issue by setting the "Apply customer Tax" to "Before Discount": Shop => Configuration => Sales => Tax Standard Setting is: Now I receive a Magento Warning in the backend. But at least everything works. Still, I think there is something wrong with Klarna Payment.


4

I tried this on a vanilla installation of Magento 1.9.3.6 Below are the files. app/code/local/Gta/FindPaymentGateway/etc/config.xml <?xml version="1.0"?> <config> <modules> <Gta_FindPaymentGateway> <version>0.1.0</version> </Gta_FindPaymentGateway> </modules> <...


1

I worked on similar functionality in magento 2, maybe it can help, let me know if you need anymore help in it. I created functionality for a specific customer group which will eligible for reward point $getCustomerGroup = $this->_scopeConfig->getValue('Reward_Section/Reward_group/Reward_Third_field', \Magento\Store\Model\ScopeInterface::...


0

I had this same issue in Magento 2 and solved it as per details in my Gist. Adding here as it was one of the top links from relevant Google searches.


-1

Please follow this blog https://meetanshi.com/blog/disable-payment-method-programmatically-in-magento/ you need to add your condition in this code


0

if you'r running production mode try this steps worked with me : 1- switch to developer mode php bin/magento deploy:mode:set developer 2- run these commands one bye one php bin/magento setup:upgrade php bin/magento setup:di:compile php bin/magento setup:static-content:deploy -f php bin/magento indexer:reindex php bin/magento cache:flush php bin/...


0

Try below steps and you get your result. 1) Go to stores->Configuration->Sales->Payment methods. 2) Go to Amazon Pay -> Advanced -> Frontend 3) Now change the dropdown(Show Amazon Pay in payment methods) value No to Yes. 4) Now Click on save config and you get result you want.


0

you can insert this directly via magento admin interface in the layout update xml field. works fine for me. thank you


0

Working code: Create a mixin for the default payment method view: app/code/MageWorx/Checkout/view/frontend/requirejs-config.js var config = { config: { mixins: { 'Magento_OfflinePayments/js/view/payment/method-renderer/purchaseorder-method': { 'MageWorx_Checkout/js/view/payment/method-renderer/purchaseorder-method-...


Top 50 recent answers are included