21 votes
Accepted

Class "Zend_Http_Client" not found Magento 2.4.6

As Zend usage deprecated since 2.4.6, Now you can use Laminas instead. Replace Zend_Http_Client with \Laminas\Http\Request (Replace constants from GET to METHOD_GET, POST to METHOD_POST) For example:...
Team Dolphin's user avatar
16 votes
Accepted

Zend replacement in 2.4.6

Zend usage deprecated since 2.4.6 Now you can use Laminas. Usage: replace Zend_Json with \Laminas\Json\Json Be sure that you have installed laminas/laminas-serializer
Edward  Skrupskyi's user avatar
10 votes
Accepted

Magento 2.4.6 : Could not validate a connection to the OpenSearch. No alive nodes found in your cluster

Replace --search-engine=opensearch with --search-engine= elasticsearch7, it will solve your issue. It is intended to bypass the Magento installation/upgrade process, you can change the configuration ...
Tu Van's user avatar
  • 6,763
9 votes

Magento 2.4.6 : Could not validate a connection to the OpenSearch. No alive nodes found in your cluster

By default OpenSearch uses SSL, but magento doesn't use it. So it needs to disable SSL plugin in OpenSearch for successful magento installation: sudo nano /etc/opensearch/opensearch.yml And add this ...
Litvinenko Sergey's user avatar
9 votes

Adobe commerce cloud upgrade to 2.4.6 gives me a error

This is a bug in Magento 2.4.6. Github issue: https://github.com/magento/magento2/issues/37208 And it was resolved by the below commit in Magento core code: https://github.com/magento/magento2/commit/...
Tu Van's user avatar
  • 6,763
8 votes
Accepted

ZendClient replacement with LaminasClient in Magento 2.4.6

I have try replacement ZendClient with class Laminas\Http\Client and it working. This would help me compatible module with Magento version 2.4.6 and the old version 2.4.x can use it too. Some change ...
Shou's user avatar
  • 160
6 votes
Accepted

Zend_Filter_Input replacement

You can replace with Magento\Framework\Filter\FilterInput. Like: $inputFilter = new \Magento\Framework\Filter\FilterInput( ['date_from' => $this->dateFilter, 'date_to' => $this->...
Sohel Rana's user avatar
  • 35.7k
5 votes

Class "Zend_Http_Client" not found Magento 2.4.6

You can resolve this (for the time being) by adding magento/zendframework1 back into your build. composer require magento/zendframework1 Then do a full clean and it should all work again.
ItsJhonny's user avatar
  • 379
5 votes
Accepted

Import Process in Magento 2.4.6 Interfering with Each Other (Magento 2.4.6 )

This is default Magento bug and they are working on it, I have found temporarily solution for it, Increase the batch size of the default import to avoid interfering with each other. Default batch size ...
Mohammad Bharmal's user avatar
4 votes
Accepted

Deprecated Functionality: Creation of dynamic property $_coreRegistry is deprecated

Deprecated Functionality: Creation of dynamic property \Helper\Data::$_coreRegistry is deprecated You must declare this property ($_coreRegistry) in your class. To do this, add the following code ...
Tu Van's user avatar
  • 6,763
3 votes
Accepted

sudo php bin/magento module:status didn't run?

It may be files and folder permission issue. so give proper permission by follow this link Magento 2 folder/file permissions then try to run status command.
Vikas Pandey's user avatar
3 votes

TypeError: addslashes(): Argument #1 ($string) must be of type string after upgrade Magento 2.4.3 to 2.4.6

Without modify core code - simple update the core_config_data table with this sql statement: UPDATE core_config_data SET value = 'welcome' WHERE path ='design/header/welcome'
BergMedia's user avatar
3 votes
Accepted

Magento2.4.6 how to verify that varnish is already running

Varnish is successfully running on port 80 in your setup. Port 80 is the conventional HTTP port. However, requests sent to http://127.0.0.1 are redirected to the HTTPS version of the website. Based on ...
Thijs Feryn's user avatar
  • 1,031
3 votes
Accepted

Two Cart Price Rules are applying incorrect discounts

This calculation is perfectly correct. If you first subtract 20% from 1700, 1360 remains. Then rule 2 where 30% is subtracted from 1360: 408. 1360 - 408 = 952 which is 748. If you want to give 50% ...
JKıngma's user avatar
2 votes

Magento 2.4.6 Paypal Braintree error when adding item to cart

Found this that answers my above issue. https://github.com/magento/magento2/issues/37242 After consultation, I have learned that the Braintree V4.5.0 module in M2.4.6 includes new functionality and is ...
Rich D's user avatar
  • 21
2 votes

Class "Zend_Http_Client" not found Magento 2.4.6

Zend framework (ZF1) components that have reached end of life have been removed from the codebase. See Backward-incompatible changes highlights.
Son Nguyen's user avatar
2 votes

Magento 2.4.6 : Could not validate a connection to the OpenSearch. No alive nodes found in your cluster

Try changing --opensearch-host=os-host.example.com to --opensearch-host=localhost \ HTH, Tom
Tom van den Heuvel's user avatar
2 votes

TypeError: addslashes(): Argument #1 ($string) must be of type string after upgrade Magento 2.4.3 to 2.4.6

Solution: Add the below line in the di.xml file. <preference for="Magento\Theme\Block\Html\Header" type="Vendor\Packagename\Block\Html\Header" /> Create a new Header.php ...
Milan Maniya's user avatar
2 votes

Is Elastic Search still require after move to Open Search

No, since you use OpenSearch you don't need to use Elasticsearch anymore. The config for the search engine for Catalog is located in Stores > Catalog > Catalog Search > Search Engine (config ...
Tu Van's user avatar
  • 6,763
2 votes

installed magento 2.4.6 and running php 8.1 but the frontend still asking for php 8.1.0 or later

There is something wrong with your php version, For more details please print phpinfo and provide more details regarding your problem.
Jaydip Darji's user avatar
2 votes
Accepted

How to set magento 2 sudo chown -R username:www-data

It is not recommended to set root as the file system owner for Magento files and directories. To keep your server safe, it is better to use another file system owner (the command-line user) with fewer ...
Tu Van's user avatar
  • 6,763
2 votes
Accepted

magento 2.4.6 installation failed due to Plugin initialization failed (require(app/etc/NonComposerComponentRegistration.php): Failed to open stream

The issue has been resolved after upgrading the composer version to the latest. sudo composer selfupdate --2 composer -v ______ / ____/___ ____ ___ ____ ____ ________ _____ / / / __ \/ ...
Amit Bera's user avatar
  • 77.4k
2 votes

Email not sent from custom module

Rename : From customform_email_template.xml To email_templates.xml File name. Path : app/code/Magelearn/Customform/etc/email_templates.xml
Vrajesh Patel's user avatar
2 votes
Accepted

Magento 2.4.6: Getting error "Namespace not defined properly" when compile command running

Edit the isBracedNamespace method in the setup/src/Magento/Setup/Module/Di/Code/Reader/FileClassScanner.php file to replace the following code: throw new InvalidFileException('Namespace not defined ...
Tu Van's user avatar
  • 6,763
2 votes
Accepted

Magento 2 after upgrade to 2.4.6-p1 on checkout sidebar issue

Please check your default file vendor/magento/module-checkout/view/frontend/web/template/summary/cart-items.html <!-- /** * Copyright © Magento, Inc. All rights reserved. * See COPYING.txt for ...
Msquare's user avatar
  • 9,043
2 votes
Accepted

How to override IsCorrectQtyCondition.php?

Step:-1 Create di.xml MyCompany/ModuleName/etc/di.xml and add below code <?xml version="1.0"?> <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:...
Mufaddal Dhansurawala's user avatar
2 votes

How to upgrade Magento from 2.4.1 to 2.4.6

Please Try below steps for update existing project First you need to check magento system requirements as per the version which link is given below and update first if required Like :- (php, composer, ...
Mufaddal Dhansurawala's user avatar
2 votes
Accepted

Deprecated Functionality: parse_url(): Passing null to parameter #1 ($url) of type string is deprecated

Instead of null you can use empty string. chnage below code from $canonicalUrl = $currentProduct->getData('canonical_url'); to $canonicalUrl = $currentProduct->getData('canonical_url') ?? '';
Pawan's user avatar
  • 5,846
2 votes

Magento 2.4.6. Error message: Invalid security or form key. Please refresh the page

<?xml version="1.0" encoding="UTF-8"?> <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:...
Harun's user avatar
  • 556
2 votes
Accepted

Magento 2.4.6 Uncaught TypeError: locations.each is not system.js:195 a function

I see you already know there is a Patch for this issue and it work but if you want to directly apply patch then it not works because there always few changes in JS file based on versions So you have ...
Nilesh Dubey's user avatar
  • 1,067

Only top scored, non community-wiki answers of a minimum length are eligible