Skip to main content
Share Your Experience: Take the 2024 Developer Survey
28 votes
Accepted

The consumer isn't authorized to access %resources

In magento2.4.4 we have to make configuration like this to work rest api with integration token
M2 Dev's user avatar
  • 538
20 votes

Magento 2 - Upgrade From 2.4.2 to 2.4.4 Class "Vertex\Tax\Setup\Schema\Triggers\MigrateVertexInvoiceSent" does not exist

I encountered this issue when upgrading to Adobe Commerce 2.4.4-p1. I was able to solve it by manually flushing the Redis cache databases being used by the instance. Sometimes the cache holds on to ...
jdubbya's user avatar
  • 201
17 votes
Accepted

Error when upgrading to Magento to 2.4.4

One of your custom modules is not Magento 2.4.4 compatible.. How to fix? add PHPDOC block for all consumer class in your custom module. How to find all consumer class? you can set break point debugger ...
JorgB's user avatar
  • 328
10 votes

Error: Command "require-commerce" is not defined, while Magento 2.4.4 upgrade

Please try to run: composer require magento/composer-root-update-plugin --no-update composer update prior to composer require-commerce magento/product-community-edition 2.4.4 --no-update
Marcin Jędrzejewski's user avatar
10 votes

Static content deploy error after upgrading magento 2.4.3-p1 to 2.4.4

Make sure that logo of theme is here app/design/frontend/[Your Vendor]/[Theme Name]/web/images/logo.svg It is necessary. But I guess it is bug of Magento 2 with PHP 8.1
Arni's user avatar
  • 291
8 votes

Static content deploy error after upgrading magento 2.4.3-p1 to 2.4.4

The issue has been caused because your custom theme doesn't have a preview image, then PHP 8.1 throws that error due to Magento core logic. Fix that by adding an image to your custom theme. For ...
Rafael Corrêa Gomes's user avatar
7 votes

Error when upgrading to Magento to 2.4.4

find your not compatible custom modules in Magento 2.4.4. add code in vendor/magento/framework/Reflection/MethodsMap.php line 143 if($paramReflection->detectType() == NULL) { ...
Jitendra Thakor's user avatar
7 votes

Magento 2.4.4. password reset link always expired

Simple steps to overcome this problem Go to Admin dashboard Click on Marketing -> Email Templates Create new template by clicking on Add one Template Template Name: Forgot Admin Password(New) ...
Arun Sharma's user avatar
  • 1,315
5 votes
Accepted

Magento 2.4.4 error in setup:upgrade

I had same issue after migrate of Magento version. I was used insertOnDuplicate . Update magento file. vendor/magento/module-catalog/Setup/Patch/Data/UpdateMultiselectAttributesBackendTypes.php ...
S.P's user avatar
  • 1,544
5 votes
Accepted

Error message "Some of the products are disabled" on checkout

check your magento file vendor/magento/module-checkout/Model/GuestPaymentInformationManagement.php the GuestPaymentInformationManagement.php file is updated in magento2.4.4 version. Magento\Checkout\...
S.P's user avatar
  • 1,544
5 votes

Magento upgrade 2.4.4, phpunit issue

you need to find the "require-dev" in your magento root composer.json file "require-dev": { "allure-framework/allure-phpunit": "~1.5.0", "...
pankaj parmar's user avatar
5 votes

Magento 2.4.4. password reset link always expired

In my case I had to change my custom theme (porto) file: app/design/frontend/Smartwave/porto/Magento_Customer/templates/form/resetforgottenpassword.phtml and introduce new form param id like following:...
Maciej Lemiesz's user avatar
5 votes

Magento2.4.4 swagger

If you didn't change deploy mode for your instance, by default deploy mode is default (not developer) You need to change mode to developer for Swagger How to display current mode (CLI) bin/magento ...
Victor Tihonchuk's user avatar
5 votes

Magento 2.4.4 suddenly adds cache tag to env.php

vendor/magento/framework/App/Cache/Frontend/Pool.php line 89 changed from if (null !== $cacheInfo) { to if (null !== $cacheInfo && isset($cacheInfo[FrontendPool::KEY_FRONTEND_CACHE])) { That ...
Dumindu Perera's user avatar
5 votes

Magento 2.4.4 suddenly adds cache tag to env.php

If you don't have a cache entry in your env.php array, Magento will break when the GraphQL module decides to add a salt entry within the cache key. The moment ['cache'] exists, Magento also expects ['...
Josh Davenport-Smith's user avatar
4 votes

The consumer isn't authorized to access %resources

Thanks for above solutions. I also encountered this smiliar issue after upgrade magento from 2.4.1 to 2.4.4-p2. My customized rest API can not work and get the same error. I debug the codes and found ...
Zoe's user avatar
  • 61
4 votes

jquery.mobile.custom js file error after upgrade to Magento 2.4.4

jquery.mobile.custom was removed from Magento Theme in Magento 2.4.4 onwards. PR: https://github.com/magento/magento2/pull/33107 Commit: https://github.com/magento/magento2/commit/...
Mukesh Chapagain's user avatar
4 votes
Accepted

Error: Command "require-commerce" is not defined, while Magento 2.4.4 upgrade

EDIT: This is a better solution. From the docs (which I missed the first time): https://devdocs.magento.com/guides/v2.4/comp-mgr/cli/cli-upgrade.html composer require magento/composer-root-update-...
Akif's user avatar
  • 1,541
4 votes

jquery.mobile.custom js file error after upgrade to Magento 2.4.4

jquery.mobile.custom js is removed from magento 2.4.4. You should to look for another solution
Andzejs Nereds's user avatar
4 votes
Accepted

How to install PWA in Magento 2.4.4 in windows

You cannot (technically you can but shouldn't) since Magento is not supported on Windows. See https://experienceleague.adobe.com/docs/commerce-operations/installation-guide/system-requirements.html#...
Petar Borisovski's user avatar
4 votes

Magento 2.4.4 (PHP 8.1) Error while running setup:di:compile

Looks like you have incorrect using of \Magento\Framework\View\Element\Template (in current namespace instead of global) in \Rsg\Enquiry\Controller\Index I suggest to review \Rsg\Enquiry\Controller\...
Victor Tihonchuk's user avatar
4 votes
Accepted

How to update product salable quantity in Magento 2.4 programmatically?

To set the saleable quantity of a product , you need to look at this table = "cataloginventory_stock_item" , in this the field = "qty". So in order to set the qty in this table , ...
Bharath Kumar's user avatar
4 votes
Accepted

Extension Attributes not storing data in database

That tutorial only shows you how to add new fields to default checkout forms but not mentioned how to save the field data (extension attribute value) into the database. To save the extension attribute ...
Tu Van's user avatar
  • 7,153
4 votes

Facing issue when i upgrade magento 2.4.4 and php8.1 and mysql 8 after composer upgrade

I think the problem may be that you've upgraded to PHP 8.1 before you've upgraded your composer packages. Have a read of this github issue, seems others had the same issue: https://github.com/magento/...
Liam Toohey's user avatar
4 votes

complex type 'mixedDataType': The content model is not determinist

First backup this file then remove one line check it vendor/magento/module-elasticsearch/etc/esconfig.xsd <xs:element type="xs:string" name="default" minOccurs="1" ...
Ravindrasinh Zala's user avatar
3 votes
Accepted

How Can I check Coding Standards Of my module for magento 2.4.4 and php 8.1?

You should find what you need here: https://github.com/magento/magento-coding-standard
Coch's user avatar
  • 68
3 votes

Magento 2.4.4. password reset link always expired

magento 2.4.4 has changed email template variables, compare email templates from vendor module and make changes if you have override them
bhargav shastri's user avatar
3 votes
Accepted

Magento 2.4.4 EE composer update issue

Wrong credential in auth.json. Credentials should be used from enterprise account
Claims's user avatar
  • 1,209
3 votes

How to Convert InstallSchema.php to Db_Schema.xml in Magento 2 ? is Possible Or Not

Please follow the following steps to successfully Migrate your install/upgrade scripts to declarative schema Go to your database search for setup_module table and delete all the modules for which you ...
HIren Kadivar's user avatar
3 votes
Accepted

Access Token Expiration settings have no effect

I found the solution. There is another setting here: I set the expiration here to 600 minutes and it works perfectly.
Pethő Jonatán's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible