New answers tagged

1

I've got it! inside the gallery:loaded i can now listen to event fullscreenenter when fullscreen mode shows when image is clicked essentially like so: ... var item = $(document).find('.fotorama-item'); console.log(item); item.on('fotorama:fullscreenenter',function () { console.log('okokokokkokko'); }) ...


0

from what I experienced while, I was upgrading Magneto, It could be one of theses things: app/code/Bss/MultiStoreViewPricingPriceIndexer/Model/Indexer/Product/Price/Action/Full::execute() may use a removed method. may a method that its encapsulation (from protected to private) was changed . may use a removed property. may use a property with changed ...


0

Remove all you have, and add this code to any container you want. This should give you the account link with a custom css class: <block class="Magento\Customer\Block\Account\Link" name="customer-account-navigation-account-link"> <arguments> <argument name="label" xsi:type="string" translate="true">Account Dashboard</...


0

issue is not related to the magento the third party extension is not compatible with magneto2.3.2 first disable the extension BSS_MultiStoreViewPricingPriceIndexer and clear cache and run the indexer command again


1

You can simply go to Content → Design → Configuration-> Edit(Storeview) → Transactional Emails → Logo Image


1

Add to all grids If you want to add your custom export format to all grids at once, like it is done with the default xml and csv exports, then have a look at the following GitHub issue, at the moment there is a bug to accomplish this: https://github.com/magento/magento2/issues/24543#issuecomment-530265065 Add to specific grid If you want to add only to a ...


0

Like what I have explained in your previous question, you have 2 options to fix the error: upgrade your Multiple Store View Pricing module, or edit the method declaration from Bss\MultiStoreViewPricing\Model\Quote\Item\Collection::_assignProducts() to Bss\MultiStoreViewPricing\Model\Quote\Item\Collection::_assignProducts(): parent


1

You are getting this error because "data type" of any third party extension's table column is enum. So you need to find out column name using debug in following file. See below file /vendor/magento/framework/Setup/Declaration/Schema/Db/DefinitionAggregator.php and check this fromDefinition() and add debug code to find column name. public function ...


0

https://github.com/magento/magento2/issues/17193 Magento 2.3.0. This fix cant resolve the issue for me. I fixed it via adding translation in template and variables: vendor/magento/module-ui/view/base/web/templates/modal/modal-popup.html <footer class="modal-footer"> <% _.each(data.buttons, function(button) { %> <...


1

If you check the method declaration here (2.1.9) and here (2.2.2), you will see the difference that the older version uses \DateTime type for parameter named $date, but the newer version uses \DateTimeInterface type. You have 2 options to fix the error: upgrade your Multiple Store View Pricing module edit the method declaration from Bss\...


3

Add below script on your website to make it work. <script> require([ 'jquery' ], function ($) { $(document).ready(function () { $("body .minicart-wrapper .showcart").on("click", function(){ $('#search_mini_form').removeClass("active"); $('#search_mini_form .label').removeClass("active"...


1

This works for me : ->getSelect()->reset(\Zend_Db_Select::FROM)->from(array('main_table' => 'table_2')); I think I was doing something wrong as the above also needs the alias set and now it works!.


0

Please try running these following in the right orders: bin/magento setup:upgrade bin/magento indexer:reindex bin/magento deploy:mode:set production -s bin/magento setup:di:compile bin/magento setup:static-content:deploy Let me know if it works!


0

Try this: <block class="Magento\Customer\Block\Account\SortLinkInterface" name="customer-account-navigation-address-link"> <arguments> <argument name="label" xsi:type="string" translate="true">Manage Address</argument> <argument name="path" xsi:type="string">customer/address</argument> <argument name="...


0

I just use this and solved for me. try it and comment here. bin/magento setup:upgrade bin/magento indexer:reindex bin/magento deploy:mode:set production -s bin/magento setup:di:compile (Run the di:compile after production mode is set) bin/magento setup:static-content:deploy


2

This is just a guess, but maybe the problem is the space in your events.xml file? It should be: Namespace\Module\Observer\SendMailToAdmin instead of: Namespace\Module \Observer\SendMailToAdmin <event name="customer_register_success"> <observer name="sendmail_toadmin" instance="Namespace\Module\Observer\SendMailToAdmin"/> </event> ...


Top 50 recent answers are included