29

Change your base URL from localhost to 127.0.0.1. Using localhost as the domain in your base URL causes problems in Magento 2. Magento's base URL configuration is located in the core_config_data table. The following values may need to be changed: web/unsecure/base_url web/secure/base_url For example, if you previously had http://localhost/...


15

SOLUTION # 1 (IF YOU WANT TO EDIT XML FILE) I would like you to download Magento 2 zip from magentocommerce.com/download, create new db in phpmyadmin, extract zip in htdocs folder. Install Magento 2 but do not use localhost use 127.0.0.1 in store URL and admin URL. After successful installation DO NOT run magento. Now we are going to clear / delete caches ...


12

Simply replace the Base URL with this : http://127.0.0.1/ Another solution is to add a line in your hosts file (/private/etc/hosts for OSX users, /etc/hosts for Unix/Linux users) such as: 172.27.0.1 test.magento.com and then to use the corresponding URL while installation: Base URL = http://test.magento.com


11

Please change localhost to 127.0.0.1, To change directly from database Goto -> core_config_data table Then change secure and unsecure base url http://localhost/ to http://127.0.0.1


8

Open php.ini file and find the line ;extension=php_intl.dll and remove semicolon (;) and save the file and then restart your xamp or wamp server and refresh the installation page.this error will be gone. Note:- for more information on the above error see http://pradeepsanku.com/2015/11/20/php-intl-extension-is-missing-during-installation-of-magento-2-...


8

I tried everything and the only thing it works is the virtual machine that provides bitnami. https://bitnami.com/stack/magento/virtual-machine Seriously, I don't know what has this vm, but goes really fast. I tried creating my VM using a fresh installation of Ubuntu, CentOS, etc. But no works so fine like this VM.


7

Yes, Magento 2 was released today. You're missing a PHP extension. I don't know your setup, but on Ubuntu with Apache you can install the missing extension with: sudo apt-get install php5-intl After that you should reload apache sudo service apache2 restart


6

Just figured it out! Apparently Chrome doesn't play nice with cookies when they are single-level domain (like localhost). Changing my environment to localhost.dev and mapping it in my hosts-file and changing the configuration of Magento 2 solved this problem! I'll leave this answer here to save other people hours of debugging and mashing their head on their ...


6

Those who don't wish to change the localhost url for this problem. The problem is due to form_key mismatch. The form key which gets posted during add to cart action is getting mismatched with store session form key. Go to vendor/magento/module-checkout/Controller/Cart/Add.php execute() method and comment out the below If condition. if (!$this->...


6

disable CSS/JS merging and minifying: Stores > Configuration > CSS Settings (Javascript Settings) > Merge CSS (Merge JS) > NO Stores > Configuration > CSS Settings (Javascript Settings) > Minify CSS (Minify JS) > NO Also see this guide on how to improve Magento 2 performance.


5

Try to run below command php bin/magento setup:static-content:deploy And if it gives any error while running this command, like file missing as you already said ,then compare your project file structure with fresh magento2 file structure . If any file missing in your project then copy appropriate file into your project. And if you got any other error then ...


4

Check the table 'core_config_data' and seach for paths 'web/secure/base_url' and 'web/unsecure/base_url'. They should point to your local site.


4

In order to stop using REDIS, you simply need to remove the references from your local.xml. It's one thing to delete and start over but your must understand what you actually needed to do. If you look you will see either one or both of the bellow sections, this is what you need to remove. Once it is removed clear your cache and you will be good to go. <...


4

I found that developer mode disable everything - which was overkill. There's certain aspects I do wish to cache, such as translation. Thankfully in env.php you can still set which caches to use specifically: 'cache_types' => array ( 'config' => 1, 'layout' => 0, 'block_html' => 0, 'collections' => 1, ...


4

Suggestions from Magento posted after this question was answered. Reading other answers I think this information could be a helpful addition http://devdocs.magento.com/guides/v2.2/extension-dev-guide/build/optimal-dev-environment.html Optimal Configuration The following is a list of optimizations you can make on your local development machine Magento ...


4

You can use the SMTP for this. And for SMTP configuration you can use any extension. https://github.com/emizentech/magento2-custom-smtp From this extension you can configure your SMTP detail in admin and based on that you can send email from local system


4

Check below solution, May be helpful to you. You have created Gregt/Hello/controller/index - index.php And Gregt/Hello/block - helloworld.php Also layout file wrong, It should be Gregt/Hello/view/frontend/layout - helloworld_index_index.xml folder name should be Controller not controller, Block not block. Please correct folder name and check.


4

You did a small mistake <?php echo $this->getHelloWorldTxt(); ?> Should be <?php echo $block->getHelloWorldTxt(); ?> Also have to change name="helloworld" template="helloworld.phtml" to name="helloworld" template="GregT_Hello::helloworld.phtml"


3

I finally stopped Redis! Just commenting out and/or removing all references to Redis would not work. Not even restarting Wampserver would stop Redis. Not even flushing/clearing cache with n98-magerun would work. SO FINALLY I SIMPLY DELETED MY local.xml AND RECREATED IT WITHOUT ANY REFERENCES TO REDIS AND IT WORKED.


3

Alan Kent posted a great article recently on Magento 2 behavior similar to what you describe that linked to this Stack Overflow discussion, but the key concepts are relevant to 1.X as well since it's more generally about cookie implementation logic not specific to Magento's codebase. In short, the fundamental implementation of cookie handling logic has some ...


3

Maybe this problem is with local.xml configuration's file. I had the same problem I fixed creating a new one.


3

moving files and database I assume these two steps are obvious: copy all of your local files to production server dump your magento local db and import it into your production server db editing in production server now on your production server you need to follow these two steps: edit app/etc/local.xml file and change database info in production db,in ...


3

I have recently installed Magento 2 on Valet+ on my Mac. Here are the steps I have taken to successfully install it: Install Homebrew if you don't have it on your Mac already Install PHP 7 brew install homebrew/php/php71 Install Composer brew install homebrew/php/composer Install Valet+ by weprovide composer global require weprovide/valet-plus Add export ...


3

Download cacert.pem file from following link https://curl.haxx.se/docs/caextract.html open php.ini file and paste following path in php.ini file openssl.cafile="c:/xampp/cacert.pem"


3

Controller path should be like this: app/code/Gregt/Hello/Controller/Index/Index.php in execute() try to put inside return "Hello"; Call this path : domaine.com/helloworld and see If you see Hello


3

Check that you have enabled To include the store code in URLs as explained in user guide here. Try to either the .htaccess or index.php override. So you can remove, $params[\Magento\Store\Model\StoreManager::PARAM_RUN_CODE] = $mageRunCode; $params[\Magento\Store\Model\StoreManager::PARAM_RUN_TYPE] = $mageRunType; References: devdocs.magento.com/v2.3/...


2

There are quite a few things to check for this, most have been covered, but the really tricky ones you won't find in most places. Most Common A redirect, such as an apache server hidden .htaccess or an nginx configuration file location block. Second most common is that you've done everything correctly, but not cleared the cache. You can just delete the ...


2

ANSWER: I had to update the media_url and skin_url in the back database with http://localhost:8888/magento/skin etc


2

use this System-> Configuration -> left menu you can find web-> under that Use Web Server Rewrites-> set no


2

Put http://127.0.0.1 instead of localhost The following method will also work: http://www.templatemonster.com/help/avoid-installation-base-url-verification-error-on-localhost.html The easiest way to avoid the verification error is to change the Base URL field class. Open the browser development tool (for example Firebug for Mozilla Firefox) Select the ...


Only top voted, non community-wiki answers of a minimum length are eligible