Hot answers tagged

4

There are a few things you can do. The first thing is to clear the email queue table. The is stored in the core_email_queue table so truncating this table should clear the backlog of emails along with the core_email_queue_recipients table. You can also disable emails being sent in the Magento admin in System -> Configuration -> Advanced -> System -> Mail ...


4

Try to replace localhost to 127.0.0.1 and check This is commonly caused by a different instance of PHP being used by the PHP command line compared to the web server. In particular, mysql.sock might be misconfigured. Refer this magento devdocs link http://devdocs.magento.com/guides/v2.0/install-gde/trouble/php/tshoot_phpini.html You can also refer - PDO ...


4

I was not able to find a direct Magento CLI command so far, I could work around with a Bash and Magerun: $ THEME_ID="$(n98-magerun2.phar dev:theme:list --format=csv \ | grep 'Vendor/code' | cut -d, -f1)" \ ; test -n "${THEME_ID}" \ && n98-magerun2.phar config:set design/theme/theme_id "${THEME_ID}" This sequence sets the configuration path ...


4

You using terminal and enter command bin/magento indexer:reindex. This command create new index of magento in your database. You can read more about setup cron job in Magento2 at http://devdocs.magento.com/guides/v2.0/config-guide/cli/config-cli-subcommands-cron.html


4

you need to change the php configure script to include --with-freetype-dir=/usr/lib64/ where /usr/lib64 contains the libfreetype.so file. My final configuration so far looks like: ./configure --with-apxs2=/usr/bin/apxs --enable-bcmath --with-curl --with-gd \ --with-jpeg-dir=/usr/lib64/ --with-png-dir=/usr/lib64/ --with-freetype-dir=/usr/lib64/ \ --enable-...


4

Yes The error shows correct . Because Magento 2 won't support PHP version 7.1.1. Both Magento 2.0.x and Magento 2.1.X both Support PHP 7 Version but with limited version Edition. Magento 2 compatible with PHP Version 7.0.x to 7.0.6 in that 7.0.2 and 7.0.4 So ultimately you need to downgrade your PHP version 7.1.1 to At least 7.0.4 Kindly check Technolgy ...


3

I found fix for development environment, because I use Mac OS and the apache php doesn't support these fonts and it's a lot of work to get it working and not mess up my system. open vendor/zendframework/zend-captcha/src/Image.php and add return in the constructor after the parent is called like this /** * Constructor * * @param array|\Traversable $...


2

This does not accomplish OP's goal of utilizing the Magento CLI, however it does work for usage in automation which is what OP (and myself) was looking to achieve. If your automation has access to the database, we can set the theme by querying the appropriate tables and performing INSERT statements. Set Theme at a global scope: INSERT INTO ...


2

To work with XAMPP installed on Windows, First redirect to PHP folder in XAMPP by : cd C:\xampp\php Then enter following command : php C:\xampp\htdocs\magento2\bin\magento indexer:reindex This will help you to remove the error.


2

modified this file: /downloader/lib/Mage/HTTP/Client/Curl.php (line 371) protected function makeRequest($method, $uri, $params = array(), $isAuthorizationRequired = false, $https = true) { to protected function makeRequest($method, $uri, $params = array(), $isAuthorizationRequired = false, $https = false) {


2

See below references might helps: https://magento.com/security/vulnerabilities/new-linux-operating-system-vulnerability https://goo.gl/WyzMdF


2

It's so simple. You can export the database to any directory which you want. To do so: Open terminal (CTRL + ALT + T) and put the following command first: cd /opt/lampp Now run the mysqldump command from here: mysqldump -u root -p[root_password] [database_name] > dumpfilename.sql This will export the database to /opt/lampp directory. You can change ...


2

You need to run below command to disable MSI modules in Magento 2.3+ versions. To disable modules run below command php bin/magento module:disable Magento_Inventory Magento_InventoryAdminUi Magento_InventoryApi Magento_InventoryGraphQl Magento_InventoryBundleProduct Magento_InventoryBundleProductAdminUi Magento_InventoryCache ...


2

for installation please follow the link, Magento 2: How to configure Nginx to use multiple websites with sub-folder you can also check the below link for your problem. Magento 2: How to configure Nginx to use multiple websites with sub-folder Thank You.


2

Can you follow below blog they have setup this. https://devdocs.magento.com/guides/v2.4/config-guide/multi-site/ms_nginx.html


2

You can follow this video which help you into installation. https://www.youtube.com/watch?v=2y5OMAFLAZU


2

You should change --elasticsearch-host=es-host.example.com to --elasticsearch-host=localhost Elasticsearch for Magento 2.4.x must be 7.x version Hope that it resolves your problem. :)


1

You can follow Meetanshi's link as it is tried, tested, and approved in local as well as three live websites too. Thank you.


1

you dont have to configure proxy. your elasticsearch must be running on local or private ip. and magento connects to 9200 port. but the only proxy you need is to kibana service, configuring that you can set SSL termination and HTTP auth (or use firewall) to open it in your browser. as example: proxy domain elk.myshop.com that listens on port 9537 to ...


1

Check if the phar.so extension is present in your PHP installation. It has to be enabled in your php.ini file. If it is not, you can either change your php.ini file, or should be able to call n98-magerun like this: php -d extension=phar.so n98-magerun.phar


1

Add below code on the top of your index.php(of Magento) file then you will get the exact error: ini_set('display_errors', 1); ini_set('display_startup_errors', 1); error_reporting(E_ALL);


1

Try to launch in your magento directory : sudo find . -type d -exec chmod 770 {} \; && sudo find . -type f -exec chmod 660 {} \; && sudo chmod u+x bin/magento It will fix perm like Magento documentation.


1

My recommendations: Use Apache2 or Nginx (Both web servers, in their latest versions, can compete with each other in most areas) Use php-fpm and opcache for improving performance Use varnish cache Use Mariadb Minify and Merge js and css Use PHP version 7.1.X If you achieve Time To First Byte below 500ms, your server configuration seems good. If you have ...


1

You should enable this: Magento Admin > Stores > Settings / Configuration > General / Web > Default Cookie Settings


1

There is no possible way to undo a chown command. What you can do is run the chown command again with the user and group that previously owned the files. If you don't know which user was that then it may be better to contact your hosting company because the users vary from host to host. Additionally you can find what user apache is running as: ps aux | ...


1

Magento itself officially only supports a Linux based stack - see the System Requirements here. I have heard of others using Windows for Magento so my suggestion is to go with whatever works best for you. Especially now that Windows ships with a Linux subsystem prior objections might me a moot point.


1

For this you have to use alternative option as this is also happen for me you should boot your system from a usb drive then back your data and if there is problem of boot loader then it will be fixed when you restat after booting. this works for me try this once.


1

For this you have to use alternative option as this is also happen for me you should boot your system from a usb drive then back your data and if there is problem of boot loader then it will be fixed when you restat after booting. this works for me try this once.


1

Give 775 permission to your var and pub/media directory. Run below command for the same. sudo chmod -R 775 /var/generation sudo chmod -R 775 /pub/media If in case in your server 775 not work then try same command with 777 for those 2 folders and check.


1

Try following steps. Create info.php file in your Magento2 root directory and put following code in it. <?php phpinfo(); ?> Now run this file in browser and find path for Loaded Configuraton File. Enable given three extensions in it by removing comment. Restart apache server and try again.


Only top voted, non community-wiki answers of a minimum length are eligible