New answers tagged

0

You Can Do it Using Just simple thing in Your Magento 2 Root Directory Run this line of code in CLI to delete the content of the Generated Code and Generated Meta Data Directories. 1.$rm –rf <magento_root>/ generated/metadata/* <magento_root>/generated/code/ or can remove directly from your magento2 root directory after that run below cli ...


0

Hash Hash is not PHP library. As of PHP 5.1.2, the Hash extension is bundled and compiled into PHP by default. (source) To check if hash is enabled in your PHP, you can run $ php -i | grep -i hash You will see something similar to hash hash support => enabled Hashing Engines => md2 md4 md5 sha1 sha224 sha256 sha384 sha512/224 sha512/256 sha512 sha3-...


0

if you tried everything above and didn't succeed , you probably installed magento in a subdirectory in your webserver , which will lead to 404 on assets , what you should do is open the .htaccess in your pub/static find the next lines : ## you can put here your pub/static folder path relative to web root RewriteBase /magento/pub/static/ you should notice ...


0

I spent 2 days fixing this issue. In my case I was using nginx reverse proxy proxy_pass magento 2.3 site hosted on apache2 virtual host. I tried to set all these configs: web/seo/use_rewrites -> 1 and 0 web/unsecure/base_url -> http://.. and https:// web/unsecure/base_link_url -> http://../ and https://../ web/secure/base_url -> https:// web/...


1

please enable verbose mode or run command with strace bin/magento setup:upgrade -vvv and tail magento logs to see whats going on, strace -s 99999 bin/magento setup:upgrade see at the end whats going on


1

From Magento version 2.4.0, you can not install Magento using URL. you have to use Command Line Interface for this. Also, MySql has been replaced with Elastic Search for catalog search so you have to install Elastic Search in your localhost first. Check this link for System Requirements: https://devdocs.magento.com/guides/v2.4/install-gde/system-requirements-...


0

This works for me. Place a new copy of .htaccess from a fresh Magento package and delete the cache and session folder as well. Then refresh and it should be good. Or another way is, ( Setting up the database ) In the “core_config_data” table remove the value of “web/cookie/cookie_domain” and set “web/cookie/cookie_httponly” to “0”. ( rm -rf var/cache )Clear ...


0

You can check elasticsearch is installed or not using the below command: curl -XGET '<host>:9200/_cat/health?v&pretty' If you haven't installed elastic search yet, you can install it using this reference link: https://www.elastic.co/guide/en/elasticsearch/reference/current/install-elasticsearch.html For more detail information please refer Magento ...


0

I have installed Elasticsearch in my Linux Mint & It's working fine. Here is the steps. Run the below command to Install Elasticsearch In locally. Download and install the public signing key : wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add - Installing from the APT repositoryedit You may need to install the apt-transport-...


0

I resolved this error by removing Security malware softwares from my browser and just reload browser by controls Ctrls Shift R. And second thing is angular.js stores data in browser local storage while installations process, and if it is not stores it then this issue might be occured.


0

Removing the backslashes was the problem for me with this error: too many arguments expected arguments command.


0

I found this question looking for my own problem The answer by OP did lead me to try with specifying the full php path instead of just calling bin/magento which, when that just worked, made me run php -v and aha! In my case the default CLI php version used when I ran "bin/magento" had reverted to 7.2 when it needs to be 7.3 or up Putting this here ...


Top 50 recent answers are included