24

Ok Finally.... here is the process i did follow to get rid from this. Step1:: Please make sure that LoadModule version_module modules/mod_version.so is loaded from httpd.conf file to resolve Invalid command '<IfVersion', perhaps misspelled or defined by a module not included in the server configuration error. Step2:: Please make sure that below ...


11

For the unexpected error (e.g 500), we should enable error reporting on the bootstrap: app/bootstrap.php ini_set('display_errors', -1) // Should enable error reporting with -1 value. In your case, we need to check the places where you call your custom attributes which have been deleted. Another way, we need to check the Apache error log.


8

This problem is caused when apache's mod_version module is not enabled. Unfortunately, my host does not allow me to enable this module and so I have devised the following workaround: Step 1 Open [magento_root]/.htaccess with your favourite text editor. You will notice, towards the end of the file, there are numerous entries following this format: <...


5

At first, please, provide Magento version of your application. Starting Magento >= 2.1.3 version the Magento\Vault\Api\Data\PaymentTokenInterfaceFactory is no more autogenerated factory (the autogenerated code is "private" and can be changed in any patch release). Instead of using PaymentTokenInterfaceFactory you should specify concrete factory for payment ...


5

It seems you're using the Magento Compiler. You'll need to refresh or disable. In my case, I prefer to disable the Compiler. The easier way is using Magento shell. Go to the shell directory and then run: php compiler.php state Now you'll see the current status of or compiler. If is enabled and/or compiled then please execute these commands: php compiler....


4

I had a similar issue with configurable products (not 503 error but infinite loop) after upgrading from 1.6.2 to 1.9.1 As @ladle3000 suggests it was also related to shopping cart rules that had a condition related to a category. If I deactivated or deleted the rules, no more issues. Check out the changes I did here: "Please specify the product's ...


4

This is a server error. if you have a developer store, please go to index.php under your root magento store and enable developer mode. Just paste this code after line 72 Mage::setIsDeveloperMode(true); and uncomment ini_set('display_errors', 1); if it is commented. Then you are able to view the error and can research for it on google or can comment here.


4

Note you will need to remove the "IfVersion" commands from every .htaccess file in Magento, after the installation too. These are the files I had to modify with a fresh install Magento2 (2.4) and on the godaddy linux platform. app/.htaccess bin/.htaccess generated/.htaccess lib/.htaccess phpserver/.htaccess pub/.htaccess var/.htaccess vendor/....


3

I have made it work not sure how that worked but ok. So i tried every little thing i could think of so i went to conf.d/ folder inside my php etc/php/7.0/cli and there i saw file 10-opcache.ini and inside there was a line zend_extention=opcache.so So i have commented it with ; in front, Restarted my computer and it worked for some reason. Which is ...


3

The problem was that the Apache that he has has no module_version check and the <IfVersion> tags in the htaccess where not recognized. We temporarily removed them and he will see this with his host EDIT : After some more digging we installed mod_version on the apache and now it works


2

I was finally able to sort this mess. Although I hadn't tried it, reading this other post error 404 after login to admin, nginx and index.php issue, how to solve made me realised that there may be something wrong with index.php After being able to log in via the weird XXX.com/index.php/admin I moved installation from /magento to root public directory. When ...


2

Could you try to refresh your cache (System -> Cache Management -> Flush Magento Cache)? Could you try to disable flat tables for products? It can be done via updating System->Configuration->Catalog->Frontend->Use Flat Catalog Category and Use Flat Catalog Product to No.


2

I know the answer. For our store the situation arose from an old shopping cart rule. It seems there is some issue with old rules that use certain conditions in which an infinite loop is caused. Such as name contains, etc. It sounds like this is your issue too, because probably you have a rule that only applies to certain groups. Hope it helps, I got a ...


2

This is more of a guess, but it's most likely not a problem with the database. You might try these to find out what causes this error: Clear cache from Magento panel Go to System > Cache Management and clear all caches. Or even better disable them for the time of debugging. This will make sure, that all cache is cleared. Check RewriteBase in .htaccess ...


2

This is a server error. if you have a developer store, please go to index.php under your root magento store and enable developer mode. Just paste this code after line 72 Mage::setIsDeveloperMode(true); and uncomment ini_set('display_errors', 1); if it is commented. Then you are able to view the error and can research for it on google or can comment here.


2

You should first disable MstCore (Mirasvit_MstCore) extension from app/etc/modules/ and try reindex. If it still just hangs, try to reindex by CLI (shell) commands, listed here Re-index magento via ssh / putty If you want to clear fulltext (catalogsearch) data, you should truncate catalogsearch_fulltext, catalogsearch_query and catalogsearch_result. You ...


2

Check for var Module permission. First run php bin/magento list Above one gives u where the error is & check error logs in var folder. If above things not work, then follow below ones Go to magento\vendor Delete All Files. Go to command line to ur Magento Root Path Run composer install php bin/magento setup:upgrade php bin/magento setup:di:...


2

Enable the developer mode. By running the below commend. php bin/magento deploy:mode:set developer after that you can see the errors trace in frontend.


2

As you already noted, this is a permissions problem. Try the recommended approach to setting permissions, maybe you made some kind of mistake which excluded some files from receiving the appropriate write permissions. First navigate to your Magento directory on your server: cd /var/www/magento Afterwards, try setting the permissions via this command: ...


2

You need to reset the permissions on your media folder and files. run this from your Magento installation folder find . -type f -exec chmod 644 {} \; find . -type d -exec chmod 755 {} \; If this fixes the problem you should then review the permissions of your Magento installation according to best practice. Further info here What permissions should I give ...


2

Just in case someone else comes across this, I finally got it to work. There seemed to be a problem with two files inside the var/di folder: frontend.ser and global.ser. Once these files were deleted, everything works just fine and the internal server error disappears. I am still not sure what caused these files to become a problem, but at least just ...


2

It seems your magento have compilation enable. Please make it disable and clear cache. Use Below Steps: Via Magento admin Navigate to System > Tools > Compilation page and click on Disable button Navigate to System > Cache Management screen and use Flush Cache button. Via FTP, by editing the includes/config.php file To disable compilation in Magento, ...


2

Your call is misformatted. It should look like this: <web>/rest/V1/orders?searchCriteria[filter_groups][0][filters][0][field]=increment_id&searchCriteria[filter_groups][0][filters][0][value]=086160005&searchCriteria[filter_groups][0][filters][0][condition_type]=eq


2

You Can try to remove static content and then try static Content Deploy as describe below. 1) Set Magento 2 developer mode. sudo php bin/magento deploy:mode:set developer 2) Remove Static Content for adminhtml. sudo rm -rf pub/static/adminhtml/* 3) try forced Content Deploy sudo php bin/magento setup:static-content:deploy -f 4) Give permission ...


2

I faced the same issue. 1.rest/default/V1/carts/mine/estimate-shipping-methods 500 Internal Server Error 2.rest/default/V1/carts/guest/estimate-shipping-methods 500 Internal Server Error At checkout page shipping methods were not displaying. This is issue with Magento_Amqp ,Magento_MysqlMq and Temando_Shipping modules. I solved this issue by updating ...


2

Your module is disabled but it's helper is calling from this observer file: app/code/local/MW/Credit/Model/Observer.php line no 399 Remove helper calling or remove this observer from app/code/local/MW/etc/config.xml then your issue would resolve


1

Seems like this error might be due to keep-alive setting or also the php max execution time, check your apache/nginx error log and php error log as well. You can change the php max execution time within your observer, altough I would not recomend it, at least try it with: ini_set('max_input_time', 3600); Also check apache or nginx keep alive. And if it's ...


1

Try to run it from the console instead, if your indexer runs for a long time then you will see this error, you can clean your cookies and login again to the backend to avoid seen this error. To run the indexer form the console: php shell/indexer.php #this will print the usage information, check it out php shell/indexer.php info #this will display the ...


1

I have fixed this issue by following below steps: Open /setup/index.php/componentGrid/components in new tab It showed me an actual error, in my case, it was the last extension installed through composer. I have removed that from composer After updating composer, I have to execute following commands as well. bin/magento setup:upgrade bin/magento setup:static-...


1

Mostly "HTTP ERROR 500" occur due to code error or wrong file/directory permission. First you need to check/set proper permission and then enable error reporting to find actual error, after that you need to fix code/bug. To enable error reporting add following code at top after php tag <?php in index.php or app/bootstrap.php file error_reporting(E_ALL)...


Only top voted, non community-wiki answers of a minimum length are eligible