Hot answers tagged

20

Go to Below File /vendor/vertex/module-tax/Model/FlexField/Processor/OrderCurrencyGetterProcessor.php At the end of the "use" clauses in add the following two lines: use Vertex\Tax\Model\FlexField\Processor\InvoiceFlexFieldProcessorInterface; use Vertex\Tax\Model\FlexField\Processor\TaxCalculationFlexFieldProcessorInterface;


13

I run into the same problem. It seems only a speeling problem: https://github.com/magento/magento2/issues/24930#issuecomment-543949135 So it is better to change only the namespace spelling without adding the two use-lines: namespace Vertex\Tax\Model\FlexField\Processor; FlexField instead of Flexfield It could make a difference for external functions that ...


12

In order to help you debug what's going on, I would suggest to temporary edit the file vendor/magento/framework/Data/Argument/Interpreter/Constant.php From this... public function evaluate(array $data) { if(!isset($data['value']) || !defined($data['value'])) { throw new \InvalidArgumentException('Constant name is expected.'); } return ...


10

If your var/importexportxxx file is blank try; php bin/magento queue:consumers:start exportProcessor https://github.com/magento/magento2/issues/23450


6

Please run the below commands and try again: php bin/magento module:disable Temando_Shipping rm -rf var/cache/ generated/code pub/static/frontend pub/static/adminhtml php bin/magento setup:upgrade php bin/magento setup:static-content:deploy -f php bin/magento setup:di:compile sudo chmod -R 777 var/ pub/ generated/ Edit Also, remove the Temando_Shipping ...


5

you can go to pub directory and find below path: pub/errors/default/503.phtml and quick edit on the 503.phtml file and edit this lines also css add here


5

To resolve this issue Create a file in your pub directory phpinfo.php and add this code in it: Execute this file from your browser www.yourwebsite.com/phpinfo.php If you are getting 404 error, then you magento .htaccess is not allowing this file, in that case try to execute this file from shell php pub/phpinfo.php The point of running this file is to ...


4

For this You need to update below file pub/errors/default/503.phtml and design accordingly but best practice to override this into custom error page for this follow below steps. Go into the pub/errors Create a copy of the local.xml.sample and rename it as local.xml Edit the with your custom name. Ex – customerrorpage <skin>customerrorpage</...


4

if you're using Apache as a web server you can display error from apache error.log to your browser with adding this line code to your root .htaccess. php_flag display_errors on php_flag display_startup_errors on


4

\vendor\magento\framework\View\Element\Template\File\Validator.php Around line 133 find function isPathInDirectories add $realPath = str_replace('\\', '/', $realPath); // extra code added like protected function isPathInDirectories($path, $directories) { if (!is_array($directories)) { $directories = (array)$directories; ...


3

Edit following class and replace following code: Ibnab\MegaMenu\Block\Html\Topmega protected function _getHtml( \Magento\Framework\Data\Tree\Node $menuTree, $childrenWrapClass, $limit, array $colBrakes = [] ) {


3

if you are not able to upgrade Magento version by admin then you can try with command line or CLI here is the commands to upgrade with CLI : php bin/magento maintenance:enable composer require magento/product-community-edition 2.3.2 --no-update composer update rm -rf var/cache/ rm -rf var/page_cache/ rm -rf var/generation/ chmod +x bin/magento php bin/...


3

If you use redis, run: redis-cli flushall or you'll need to run the following commands: Clear generated Clear var/cache Enable Magento modules: php bin/magento module:enable --all Compile DI php bin/magento setup:di:compile I hope this will help


3

You have to run cron by command line as mentioned here: php bin/magento cron:run https://github.com/magento/magento2/issues/23450#issuecomment-507581035 Then refresh the export page and you should see the file at the bottom.


3

By mistake, you have added code files in the design folder, so I would suggest try to remove app/design/code/Infortis/Infortis and run Magento commands. php bin/magento cache:flush php bin/magento setup:upgrade php bin/magento setup:static-content:deploy -f Hope this will help you.


3

use 127.0.0.1 instead of localhost. UPDATE `core_config_data` SET `value` = 'http://127.0.0.1/zain/accessories/' WHERE `core_config_data`.`path` = 'web/unsecure/base_url'; UPDATE `core_config_data` SET `value` = 'http://127.0.0.1/zain/accessories/' WHERE `core_config_data`.`path` = 'web/secure/base_url'; http://127.0.0.1/zain/accessories/ in this write ...


3

If like me you can't edit the file (because our CD will fail) follow these steps: In the root of your project, create a directory patches/composer Create a file called vendor-vertex-compilation-issue.diff In your composer.json add this to the list of "require" "cweagans/composer-patches": "1.6.7" Still in your composer.json add this to the extras "...


3

you have this line if(customerGroup == 'ID/5'){ customerGroup does not have the variable sign $ in front of it. But even if you add it, you will get an error because the variable is not defined. I guess you want something like $customerGroup = $this->customerSession->getCustomer()->getGroupId();


2

Try to set Stores -> Configuration -> Advanced -> Developer -> JavaScript Settings -> Translation Strategy option to value "Dictionary (Translation on Storefront side)" ..or use that query: UPDATE `core_config_data` SET `value` = 'dictionary' WHERE `core_config_data`.`path` = 'dev/js/translate_strategy' LIMIT 1;


2

In my case, I found created_by attribute on the "STORE -> [Attributes]Product". And changed frontend_label to "any_sting...", It should be has value. This fix the problem.


2

In my case I found this attribute and changed text to text area. This fix the problem. To do that you need edit attribute but in inspection mode. Click right mouse button on Label of 'catalog input Type' , go down to find 'select option' and remove disabled='disabled' , This will activate option select and you can change to text now and save.


2

This is because of currency mismatch in you store and business account you are using for getting payment. You have to add currency in you seller account to accept store currency payment. Here how the list of currency accept https://prnt.sc/phymxt You can add currency as many as you want by clicking Currencies link.


2

if you are on windows open the folder and give permissions to generated folder to "uncheck" read only and for linux operating systems use chmod -R 755 generated and you will be able to install the magento 2.3.1


2

I have facing same issue in export customer and fixed to override module-customer/Ui/Component/DataProvider/Document.php file. Follow below steps to create custom module for override Document.php file and updated code. File path:magento/app/code/Vendor/CustomerExport/registration.php <?php \Magento\Framework\Component\ComponentRegistrar::register( ...


2

This is actually to do with the Moogento PickPack extension mentioned in the error. Disabling this extension seems to have resolved the issue. I will get in touch with the extension provider to try to resolve the issue. Thanks to @ARUNPRABAKARAN M for putting me on the right track Update: Upgrading to the latest version of the extension seems to have ...


2

If I look at the Magento marketplace link of this module, I see that it's not compatible with Magento 2.3 as of this moment https://marketplace.magento.com/sendgrid-email-delivery-simplified.html


2

As we can see in the error message, the insert is not correct as there are only two columns in the statement and that is obvious wrong: INSERT INTO vendorname_modulename_entity (created_at, updated_at) VALUES ('2019-03-01 06:04:57', '2019-03-01 06:04:57'). The problem might be in your model or resource model: Did you define a method setEntityTypeId in your ...


2

It turns out that customer-data.js uses the localStorage to store a variety of stuff (probably for caching purposes). This means that when a module (or Magento) updates, you'd better make sure to flush your local storage as well. Reference - You can find some more solution here : https://github.com/magento/magento2/issues/6410 https://github.com/magento/...


2

First of all, check that you are getting "from" key in GET / POST request or not. Also, you can use magento way to get parameters fo get or post a request. $fromVar = $this->getRequest()->getParam("from", false); if ($fromVar == 'key') { //Your logic goes here. }


2

Adding an answer for posterity as this was already correctly resolved in the comments by Anthony. When using Redis to store the session data, the Warning: session_start(): Failed to read session data error can be fixed by increasing the max_concurrency value.


Only top voted, non community-wiki answers of a minimum length are eligible