Hot answers tagged

2

I had exactly the same issue. I set a JS breakpoint in the line, which threw the error and looked at the attributes variable. There were multiple old attributes, which were migrated from M1. They lead to these issues. I simply deleted those old attributes in the database (table eav_attribute) and the error was gone.


1

Please run below command from your SSH terminal: composer require fooman/pdfcustomiser-m2:* --ignore-platform-reqs


1

The problem might be caused due to the incorrect value or no value available for the isExcludingDisplayed() and haveToShowCoupon() functions. These two functions are available in shipping.js file isExcludingDisplayed : module-tax/view/frontend/web/js/view/checkout/summary/shipping.js haveToShowCoupon : module-checkout/view/frontend/web/js/view/summary/...


1

For me it was the case where a dependent module was disabled. I didn't have to enable all the modules php bin/magento module:status review the modules, and only enable what you think may be the cause


Only top voted, non community-wiki answers of a minimum length are eligible