New answers tagged

1

It seems to be pretty simple, The default e-mail template that is sent by Magento is: Customer: vendor/magento/module-sales/view/frontend/email/order_new.html Guest: vendor/magento/module-sales/view/frontend/email/order_new_guest.html You must not edit those files directly on vendor. They can be loaded on admin panel: Marketing > Communications > ...


0

Take the back_url out of the query and append it with '&' and pass the url where you cant to redirect the customer after account confirmation. <a href="{{var this.getUrl($store,'customer/account/confirm/',[_query:[id:$customer.id,key:$customer.confirmation,_nosid:1])}}&back_url={{store url='checkout/cart'}}" target="_blank">{...


0

You need to set your custom data in transport data object, for that you can use below observer app\code\Vendor\Module\etc\events.xml <?xml version="1.0"?> <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Event/etc/events.xsd"> <event name=&...


0

First, you need to create “events.xml” file inside your extension folder. app\code\Mital\EmailSubjectItems\etc\events.xml <?xml version="1.0"?> <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Event/etc/events.xsd"> <event name="...


1

You have to save that quote value to the order table and then get direct value in an email template. For save quote value to order table. Define Events in the events.xml file. <?xml version="1.0"?> <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Event/...


0

Try Checking this template in email marketing templates in Magento admin. But first create a demo content HTML template in this location. add your content of email templates in app/design/frontent/Vendor/Theme/Vendor_Module/email/custom_email_template.html


0

add your content of email templates in app/design/frontent/Vendor/Theme/Vendor_Module/email/custom_email_template.html


0

You can try this <p style="" text-decoration: none; font-size: 13px; font-family: arial;""> {{trans ""You’ve got ""}} <span style=""color: #F3198F"">{{var store_credit_amount}}</span> {{trans ""in store credit.""}} </p>


1

This is fixed using {{var store_credit_amount | escape }}


0

So I found out what's wrong. I had to configure an SMTP in the BO but there was a checkbox checked that prevent any mail to be sent in developer mode.. If Enable, Magento will not delivery any email to receiver. This is useful for developers. I just needed to uncheck this. For anyone that got the problem, its in Store > SMTP > Configuration > ...


0

This works: Comment: {{var data.comment|nl2br}}


0

The step is as normal as every other bugs. You need to identify where the code break. How to do it is follow the flow of your application. Does the form display? When you submit, does it send the request to the server? (can it reach the controller?) When it comes to the server, is everything in the form get sent correctly? (has all the data sent to the ...


1

When an email is sent via cron or from CLI - need to make sure that the Translate Area Part is loaded. For me the following piece of code has helped (I used it right before the email message template content is prepared): //do not use object manager directly. this is only for the demonstrating purpose. $o = \Magento\Framework\App\ObjectManager::getInstance();...


0

Hunter You just add your style in the _email.less file which located below path app/design/frontend/{{YOUR THEME NAME HERE}}/default/web/css/source/_email.less You have add the below less .wrapper { .button { .inner-wrapper { tr { td { background-color: #000000; a { ...


0

There's also this open-source module that makes tracking numbers clickable. The URLs can be configured in store-config: https://github.com/shipperhq/module-shipping-tracker


Top 50 recent answers are included