37

Just put a .htaccess (or if nginx/whatever a config) into the downloader directory with Disallow from all in it to forbid any request on the directory. If you wanted to allow a few IP addresses in (like your own), try something like this in your .htaccess order deny,allow deny from all allow from 1.2.3.4 5.6.7.8 Where 1.2.3.4 and 5.6.7.8 are IP ...


17

Along with @daniel-sloof's recommendation I would say to ditch the Magento Connect installer altogether. I generally add it to .gitignore when setting up a new repository. The reason being, as Fabian points out in his answer comments, that there is no way to ensure the replication of your production environment in source control without committing the ...


15

There's two things that would likely cause this. You aren't using OpenSSL Your OpenSSL build is out of date To solve 1. Check that you aren't using OpenSSL, php -r "print_r(curl_version());" | grep ssl_version If it displays anything other than OpenSSL - then that's your answer. The solution would be to remove/comment the line in question. To ...


7

I asked Nexcess (referencing this post) and got this answer: The page you found is actually correct. We've been seeing this a lot with the new update. What happened is that Magento updated some code to be more secure, but they made the assumption that curl would be compiled against SSL libraries that they could check with certain commands. ...


6

What you can try here is to delete the file downloader/connect.cfg. This file should be created the next time you load the Magento Connect section of the website. I would always suggest taking a backup of files before deleting them though just for the case that something goes wrong.


6

I usually delete the downloader directory, but also found the following directive in the root htaccess helpful: RewriteRule ^downloader/ - [L,R=404] Which will make Apache send a 404 response even if the downloader directory is present.


5

what about renaming the downloader folder? In case of need can easily be renamed back to "downloader", doing update and install as needed, and then changing it again. It seems to work for me.


5

on our server Centos 6, NSS is up to date for this release but not the last release. other solutions commenting line, adding line are not working. the only solution which works is forcing https to false by adding line $https = false; before line $uriModified = $this->getModifiedUri($uri, $https); and commenting $this->curlOption(...


4

Go to http://www.magentocommerce.com/download and click on release archives and scroll down to the 1.7 section.


4

Did all the above, but realised I was using Nginx and so it turned out to be not loading the default /downloader/index.php automatically. Accessing the connect manager directly worked for me: www.example.com/downloader/index.php Then added some restrictions in nginx conf to restrict to my IP address ore present basic auth login:- location ~ /downloader/ { ...


4

Solution of Redirect install(Downloader) wizard but already installed Open this file : app/Mage.php Find this below code : $localConfig = simplexml_load_file($localConfigFile); Change it to the below code : libxml_disable_entity_loader(false); e$localConfig = simplexml_load_file($localConfigFile); Note : Clear cache or check to private ...


4

On 1.9.2.3 use the follwing on downloader/lib/Mage/HTTP/Client/Curl.php line 370 ish: $uriModified = $this->getModifiedUri($uri, $https); $this->_ch = curl_init(); $this->curlOption(CURLOPT_URL, $uriModified); $this->curlOption(CURLOPT_SSL_VERIFYPEER, false); //$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1'); $this->curlOption(...


3

Magento redirects to the install wizard if there is no app/etc/local.xml file. In this file, all the configuration stuff is stored. So if that is not present, Magento assumes that you did not install it yet. Most probably you have to restore that file.


3

It seems like the controller Mage_Connect_Adminhtml_Extension_LocalController is not available. Please make sure that you did not delete or deactivate Mage_Connect: app/code/core/Mage/Connect should exist and be readable The module should not be deactivated in app/etc/modules (check all XML files)


3

1 Download magento in https://www.magentocommerce.com/products/downloads/magento/ delete the download folder on your server, replacing by the newly downloaded magento. NOTE: Replace only the download folder. Good luck!


3

I found the problem, which was my command to pack files. I was using "j" option with old habit (compress archive with bzip2) tar -cvjf Eightdigits_MarketingSuite-1.0.0.tgz * when I used following command to pack, it just worked fine tar -cvf Eightdigits_MarketingSuite-1.0.0.tgz *


3

You need to republish the extension using the appropriate settings, just as you did originally.


3

You do not need the downloader directory to run Magento. If you are not planning to install Magento Connect extensions via downloader, then you can delete the directory. I personally never deploy the downloader directory. Naturally the downloader implementation allows download, unarchive and installation capabilities. In case of new Magento security ...


3

Depending on your server configuration and running webusers you need to setup write access to some directories. All other files should be read only to the webuser! This will make sure your website isn't defaced easily. First of all, there are a lot of reasons to not have a /downloader directory on production environments. There have been some patches in the ...


3

Maybe your admin/developers did their job and either removed or protected the connect manager. It's 1.) a potential security risk . 2.)And untested extensions might break your site. That's why you should not use the connect manager directly on a production site. Instead download the extension to a development site, test it, then move the code to ...


3

For Installing extension from magento connect your downloader folder should have write permission because magento stores extension there and after that process start for installing , so please give write permission to downloader folder you will get this folder in magento root Hope this will help you


3

You need to create csv folder inside your area(frontend/adminhtml) app/code/{Namespace}/{Modulename}/view/{area}/web/csv/en_US.csv call directly inside template files, echo $this->getViewFileUrl('Namespace_Modulename::csv/en_US.csv');


2

As mentioned in the comment check what you have under System->Config->Web as the downloader link is built from Mage::getBaseUrl('web') If you are still having these issues this can be debugged by looking into the controller Mage_Connect_Adminhtml_Extension_LocalController /** * Redirect to Magento Connect * */ public function indexAction() { $...


2

There's no changes in 1.9 that made Magento Connect stop tracking community extensions. Magento Connect stores a list of your installed extensions in the downloader/cache.cfg file. My guess is something happened during the upgrade (either a Connect Bug or unexpected termination) that reset the list of extensions in this file. One possible additional ...


2

To resolve this problem just navigate to Settings and find Magento Connect Channel Protocol: You have to change it from HTTP to FTP! This will resolve your problem. Tested and working, please if it works for you mark my answer as an answer for your question!


2

I have the same problem, for a temporary solution: you can download the source files directly off of MagentoConnect using this tool: http://freegento.com/ddl-magento-extension.php and then upload them manually!


2

@ben there is one more sub case in 1. Commenting the line alone may not work if curl and nss are not out of date. If not built with openssl, curl may be built with nss (CentOS/RHEL curl). Ensure the curl and nss libraries are uptodate.


2

This error is pop up because your downloader folder have not writable permission, Go to Magento home directory and just give permissions for your webroot. chmod 777 -R downloader/* Hope this will help.


2

If you get the error like above, please goto Download extension method.


2

It's not really a bug, I'd say it's a human mistake because fortunately for us, this curlOptions method is never used in the Magento core. However, you'll face issues if you have extensions using it but as it sits in the downloader folder it should not be used externally as the right class to use is the Varien_Http_Adapter_Curl class.


Only top voted, non community-wiki answers of a minimum length are eligible