Skip to main content
Share Your Experience: Take the 2024 Developer Survey
3 votes
Accepted

I ran 'composer update' and it brought the website down. How to fix?

As you can see, you should run bin/magento setup:upgrade to upgrade database. Updated When @Allysin running bin/magento setup:upgrade it does not complete (stuck) but does not show any errors in the ...
Tu Van's user avatar
  • 7,143
2 votes

Composer update created error: require(vendor/magento/composer-root-update-plugin/registration.php): failed to open stream: No such file or directory

You can try this: rm -rf vendor composer install composer update bin/magento setup:upgrade bin/magento setup:di:compile bin/magento setup:static-content:deploy -f or you can remove composer.lock and ...
Rana Zain's user avatar
  • 658
2 votes
Accepted

Composer update created error: require(vendor/magento/composer-root-update-plugin/registration.php): failed to open stream: No such file or directory

You don't need to upgrade to Magento 2.4.4 before upgrading to Magento 2.4.5. You can upgrade to Magento 2.4.5 directly. Solution 1: Try the following steps to upgrade your Magento site to 2.4.5-p1: ...
Tu Van's user avatar
  • 7,143
1 vote
Accepted

How to upgrade Magento in live site?

You will do these steps to Upgrade to the Magento2.4.5. Change the composer version from 1 to 2 Change the PHP version to PHP 8.1 Upgrade the version through Composer this ...
Rana Zain's user avatar
  • 658
1 vote

Upgrading from Magen2.3.4 to 2.4.5

Rewrite Composer.json Make inventory_stock1 structure in database and copy&paste from old database CREATE OR REPLACE VIEW inventory_stock_1 AS select distinct legacy_stock_status.product_id AS ...
Shiba Y.'s user avatar
1 vote
Accepted

Upgrading from Magen2.3.4 to 2.4.5

You are using composer version 2.2.0, it is compatible with Magento 2.4.5. As you are using Magento 2.3.4, you can use PHP 7.3 or 8.1 to upgrade to Magento 2.4.5. As you are using PHP 7.2, you have to ...
Tu Van's user avatar
  • 7,143
1 vote
Accepted

Risks of updating composer from 1.10.24 to 2.1.0 on a Magento 2 instance

You can install keep Composer 1 and Composer 2 on the same server, look at this topic: https://stackoverflow.com/questions/65273012/keep-composer-1-2-both-in-same-machine Even if you update Composer ...
Tu Van's user avatar
  • 7,143
1 vote

Magento cloud setup install failure

Some steps ahead were made but still unable to run composer. Now it returns this error: W: [Composer\Downloader\TransportException] ...
sp-thron's user avatar
1 vote

Issue while upgrading the Magento Instance Upgrade

Composer will not let you install conflicting requirements like this. Your options are: Remove the package that requires "league/flysystem": "^2.4", Try and install a version of ...
Liam Toohey's user avatar
1 vote

Upgrading from 2.3.5-p1 to 2.4.3-p1 install issue

You cant update from 2.3.5-p1 to 2.4.3-p1 directly. First you have to upgrade to 2.4.2 Then can change your PHP version to 7.4 and the Composer to 2.x
WebHostingAce's user avatar
1 vote

No lockfile found. Unable to read locked packages Magento2.4.3 composer update issue

I had the same issue and after searching for a while I noticed that my composer.lock file was missing from my project. after adding it back from local history, the issue got fixed.
rukrlf's user avatar
  • 148
1 vote

Getting Conclusion: don't install symfony/console v4.4 while upgrade Magento 2.4.1 from Magento 2.3.3

The magento/data-migration-tool version needs updating to match the magento version that you're updating to. That should remedy the version conflict.
Mark Rees's user avatar
  • 356
1 vote

Composer can't install any module due to "Your requirements could not be resolved to an installable set of packages"

I looked into composer.json in root and found "require": { "experius/module-exceptiondebugger": "^1.0", "fooman/printorderpdf-m2": "^3.0", ...
director_PR's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible