New answers tagged

0

<?php /** * @package Vendor_Module */ declare(strict_types=1); namespace Vendor\Module\Helper; use \Magento\Framework\App\Helper\AbstractHelper; use Magento\Checkout\Model\Session; use Magento\Quote\Model\QuoteRepository; class Data extends AbstractHelper { /** * @var Session */ private $checkoutSession; ...


1

Try this <?php $orderItems = $_order->getAllItems(); $productItemcount = 0; $productItemcount = count($orderItems);


0

I had exactly the same issue: customers were being logged out after the checkout process (usually new registered customers. We had a custom module to let them sign up directly in checkout: Firecheckout). Your case might be different, but I'll hope this can help you: Check your new order email templates. Have you added any custom blocks using the {{block ...}}...


0

This is core Magento bug. Please see here: https://github.com/magento/magento2/issues/33741 The fix is here: https://github.com/magento/security-package/pull/302/files


1

Try This app/code/VendorName/ModuleName/view/frontend requiejs-config.js var config = { config: { mixins: { 'Magento_ReCaptchaFrontendUi/js/reCaptcha' : { 'VendorName_ModuleName/js/reCaptcha-mixin' : true } } } }; app/code/VendorName/ModuleName/view/frontend/web/js reCaptcha-mixin.js define([ ...


1

Create requiejs-config.js file and add this mixin : app/code/Vendor/Module/view/frontend/requirejs-config.js var config = { config: { mixins: { 'Magento_ReCaptchaFrontendUi/js/reCaptcha' : { 'Vendor_Module/js/reCaptcha-mixin' : true } } } }; Create reCaptcha-mixin.js file and add below code : ...


0

Check The Below Code <block class="Magento\Checkout\Block\Cart\Item\Renderer" as="simple" template="Vdcstore_QuantityDropdown::cart/item/default.phtml" /> Correct "Vdcstore\QuantityDropdown" to "Vdcstore_QuantityDropdown" Check the Other Solution <referenceBlock name="checkout.cart.item....


0

To check for errors in Magento you can search for them in: var/log/exception.log var/log/system.log var/log/debug.log Also in your case Magento only collects abandoned carts (due to customer added to cart but not yet checked out) this is not the fault of your website


0

Vendor/Module/view/frontend/layout/checkout_index_index.xml <?xml version="1.0"?> <page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" layout="1column" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd"> <body> <referenceBlock name=&...


0

Go to Store -> Configuration -> Sales -> Shipping Setting and here set default address as per your need.


0

The solution: You basically click the Continue button with Jquery and then hide the respective step/steps with CSS (/catalog/view/theme/default/stylesheet/stylesheet.css): #checkout, #payment-method { display:none; }


Top 50 recent answers are included