13

Creating a console command would be your best bet in my opinion. Edit: the module is available here if you need: https://github.com/digitalpianism/changepassword Here's a module that will do it (only tested on 2.1.2): app/code/DigitalPianism/ChangePassword/etc/module.xml : <?xml version="1.0"?> <config xmlns:xsi="http://www.w3.org/2001/...


11

Go to app/etc/env.php then update this: 'db' => array ( 'table_prefix' => '', 'connection' => array ( 'default' => array ( 'host' => 'localhost', 'dbname' => 'database_name', 'username' => 'database_username', 'password' => 'database_password', 'active' => '1', ...


8

For an easy way to change the password for existing customer, you can import customer CSV file data of existing customer email id and password field. You can give your password which you want to change and password_hash should be blank. Please refer the below sceenshots: Please visit link for the solution: http://tagvibe.com/magento2/how-to-change-customer-...


6

I was able to resolve this issue by going into the admin_passwords table, and removing the stored passwords associated with the admin users' ID. Not sure if this was the right way to go about it, but it solved this issue and hasn't caused any adverse effects, as far as I can tell.


6

This is an issue in Magento 2.2.6 (check here) This patch fixes it. In app/code/Magento/Customer/Model/AccountManagement.php, in function resetPassword: BEFORE $this->sessionManager->destroy(); $this->destroyCustomerSessions($customer->getId()); $this->customerRepository->save($customer); AFTER $this->...


4

I have seen you are passing parameter in Form-Data that might be the reason you are facing this kind of issue instead of Form-data select parameter as RAW - then choose JSON(application/json) ! Also you are passing customerId=146 in URL - so you actually don't need to pass this in parameter - as it is for that specific user only so !! Below i am ...


3

You can update passoword from phpmyadmin. Go to table "admin_user" and run this sql: UPDATE `admin_user` SET `password` = MD5('YourPassowrd') WHERE `username` = 'USERNAME'; Check and let us know.


3

Go to app/etc/local.xml and set your new password here too: <default_setup> <connection> ... <username><![CDATA[your_user]]></username> <password><![CDATA[your_password]]></password> ...


2

This is a bug in Magento 2.2.6 and Magento 2.2.7. Go to the file vendor/magento/module-customer/Model/AccountManagement.php and patch it like this: Fix M2.2.7 - MAGETWO-96079: Cannot update password using received link diff --git a/Model/AccountManagement.php b/Model/AccountManagement.php index 8f25651..b5b1905 100644 --- a/Model/AccountManagement....


1

If your link isn't working then there is an alternative option. Alternative option to change password: 1. Login to admin and click on Account Settings as show below: 2. Then you will be redirected to change password screen as show below: 3. Now you can change your admin password with new one.


1

I had similar issue but for me there was an option where I can set the minimum Time between password reset requests as shown below. In my case, it was set to 10 min. After I change it to 0 the issue was resolved. The configuration exists in the same path as you have mentioned but not sure why you do not have this configuration in your Magento.


1

I solved it from /Magento/app/etc/env.php See How to edit Magento 2 Database Configuration file?


1

Try following event <adminhtml> <events> <controller_action_predispatch_adminhtml_system_account_save> <observers> <custom_controller_action_predispatch_adminhtml_system_account_save> <class>custommodule/observer</class> <method>...


1

You can try following sql query UPDATE admin_user SET password = CONCAT(SHA2('xxxxxxxYourNewPassword', 256), ':xxxxxxx:1') WHERE username = 'admin'; Keep xxxxxxx as it is in the query. Alternatively, you can try the command bin/magento admin:user:create For more details on using this command go through https://devdocs.magento.com/guides/v2.2/install-gde/...


1

Magento\Customer\Model\ResourceModel\CustomerRepository has an extra argument passwordHash Use this argument to set a new password: $customer = $this->customerRepository->getById($customerId); $this->customerRepository->save($customer, $this->encryptor->getHash($password, true));


1

Go to Admin-Configuration-Advanced-Admin-Security Remove "Password lifetime" value


1

You can change your password in the admin_user table in your database.. The Password in MD5() format so you use the MD5() function when change your Password.. UPDATE `admin_user` SET `password` = MD5('YourPassowrd') WHERE `username` = 'USERNAME';


1

There are 3 ways to clear this issue. Way 1: You can update password from phpmyadmin. Go to table "admin_user" and run this sql: UPDATE `admin_user` SET `password` = MD5('YourPassowrd') WHERE `username` = 'USERNAME'; Way 2: Go to app->etc->local.xml file and check the user name and password details. Way 3: Delete the local.xml file and run the ...


1

If you are using nginx, add this to your config file: location = /js/index.php/x.js { rewrite ^(.*\.php)/ $1 last; }


1

This is a known bug in certain versions of Magento. Try overriding the below template. Then remove the onclick and change the button type to a submit (code is below): app/design/adminhtml/default/default/template/forgotpassword.phtml change <button class="forgot-password" onclick="loginForm.submit()" type="button"><span><span><span&...


Only top voted, non community-wiki answers of a minimum length are eligible