While it may offer you a temporarily solution, you should considering not modifying the core code like that to solve problems. Changing the source code of an application will create problems that are much more difficult to track down. There's a number of different issues that cause the errorless admin login behavior you're seeing, but they all go back to ...


I'm having the same symptoms on some Magento installations(not only 1.9). In my case, it happens only in Chrome. I'm fixing this by logging in Firefox/Safari/Opera, and changing 'Use HTTP only' to 'No' in 'Session Cookies Management' of the 'Web' settings.


You can get the details by below command in you Magento 2 instance. php bin/magento info:adminuri you can get the result like Admin URI : /kqasuydi Hope this is the simple and quick way to get.


Access your MySQL and use these commands: UPDATE `core_config_data` SET `value`='0' WHERE `path`='dev/js/merge_files'; UPDATE `core_config_data` SET `value`='0' WHERE `path`='dev/js/enable_js_bundling'; UPDATE `core_config_data` SET `value`='0' WHERE `path`='dev/js/minify_files'; UPDATE `core_config_data` SET `value`='0' WHERE `path`='dev/css/...


You can get it from app/etc/env.php file, You have to get frontname from this file and suffix in your base url. 'backend' => array ( 'frontName' => 'admin', ), Now your value is Remove cache and check in your browser.


I had the same problem and could fix it by setting the correct web/cookie/cookie_domain and web/cookie/cookie_path values in the table core_config_data. Don't forget to clear all session and cookie data in your browser and the Magento session and cache files/data afterwards.


In Magento 1.9.2 the middle name has been added to this column: Source: https://github.com/OpenMage/magento-mirror/blob/magento-1.9/app/code/core/Mage/Sales/Model/Resource/Order.php#L93-L99 $ifnullFirst = $adapter->getIfNullSql('{{table}}.firstname', $adapter->quote('')); $ifnullMiddle = $adapter->getIfNullSql('{{table}}.middlename', $...


Find: /vendor/magento/framework/View/Element/Template/File/Validator.php:139 find: foreach ($directories as $directory) { if (0 === strpos($realPath, $directory)) { return true; } } Replace with: foreach ($directories as $directory) { $realDirectory = $this->fileDriver->getRealPath($directory); // and replace `$directory` ...


Recently had a very similar issue with a Magento 2 site. Managed to track down the issue to a very important .htaccess file missing in the pub/static folder on the server. It's unclear how this file was mysteriously removed but re-adding this file from a clean Magento 2 installation rectified the issue.


There is no setting to change Magento's backend logo. If you want, you can change it by replacing at: <magento_root>/pub/static/adminhtml/Magento/backend/en_US/images/magento-logo.svg Note: Where <magento_root> is the path of your Magento installation. Update: As @matinict said, above solution is not a permanent solution. So below is the ...


Unfortunately, those options are gone now in Magento. Regarding the visitor log, everything is logged via the \Magento\Customer\Model\Logger model and via events observers declared under \Magento\Customer\etc\frontend\events.xml. However, the automatic cleaning seems to be totally gone. Regarding the system and exceptions logs, same issue, it's not ...


The problem is caused due to the permission issue on the static files. To fix this issue, 1) Go to file path pub/static/ 2) Check whether .htaccess file is available (hidden file - Press cntrl+H to view it). 3) If not available, based on the Magento version get .htaccess file in the file path pub/static/ and move into your server. 4) Finally, clear ...


I have just make Link and redirect it product detail page. Please check my answer and change as per your need. Create a actionsColumn in ui component xml like below : <actionsColumn name="product_id" class="<<vendor>>\<<modulename>>\Ui\Component\Listing\Columns\ProductActions"> <argument name="data" xsi:type="...


I had the same issue. Solved it by deleting my cookies.


I had this problem too. Turned out sessions couldn't get written to var/session, even though the directory itself is set to 0777. Magento created session files, but they all remained zero bytes. Changing session storage from files to db solved the problem for me.


Let us divide your problem into 3 sections and review it. 1. You need to add a template file to your CMS Page The method you adopt here will work for sure. That is you need to add this code snippet inside your cms page , under design tab <reference name="content"><block type="core/template" name="home-content" template="test.phtml" /></...


System=>Config=>General=>Web Current config scope. If this is a simple store, it's probably defined in Default Config, check other scopes to make sure it hasn't been redefined elsewhere. (unchecked box, non gray text field) In the Scope where it's defined, select the title you changeed it to from the dropdown, save, clear cache.


I used these queries and could login again DELETE FROM core_config_data WHERE path='web/cookie/cookie_domain'; DELETE FROM core_config_data WHERE path='web/cookie/cookie_path'; and please make sure that webserver user has right to write to session storage. checking session_save_path setting if you save session to files. It looks like this <session_save&...


Open up app/etc/di.xml find the path Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink and replace it with Magento\Framework\App\View\Asset\MaterializationStrategy\Copy Note: Remove entire files and folder under pub/static except .htaccess


I just wasted a day on this and eventually figured out that NO, the certs are not the problem. Composer is the problem. /home/alpinewi/m2.alpinewines.co.uk/magento2/vendor/composer/composer/src/Composer/Util/RemoteFilesystem.php(801): Composer\Util\RemoteFilesystem->getSystemCaRootBundlePath() I eventually went digging on the bug tracker of Magento 2 ...


I had the same issue this morning. I updated Sales email templates, then suddenly admin pages stopped working. The problem was solved when I re-deployed the assets for admin pages. I run these commands: grunt clean; grunt exec; grunt less bin/magento setup:static-content:deploy -f -s standard bin/magento cache:clean Maybe, the CSS has to be re-deployed ...


Add the code in your controller file public function saveAction() { ... if (!empty( $_FILES['main_image']['name'] )) { $data['main_image'] = $_FILES['main_image']['name'] ; } else { if (isset($data['main_image']['delete']) && $data['main_image']['delete'] == 1) { if ($data['main_image']['...


I don't think Magento 2 admin path is stored in the database. You can find the randomly generated path in the app/etc/env.php file, e.g.: 'backend' => array ( 'frontName' => 'admin_1ai8c5', ) Also an easy way to retrieve the admin path is by using the following Magento 2 CLI: php bin/magento info:adminuri


php bin/magento config:set dev/js/merge_files 0 php bin/magento config:set dev/js/enable_js_bundling 0 php bin/magento config:set dev/js/minify_files 0 php bin/magento config:set dev/css/merge_css_files 0 php bin/magento config:set dev/css/minify_files 0


1)Open localhost/phpmyadmin or which certainly gives you an error. 2).To fix this, restart server to start the service of PHPMYADMIN. 3).if you are on local server, open your xampp or wampp, stop all services then start it. 4).This will fix your all issues for sure


In case you haven't figured this out or for future reference, Magento checks to see if the order email has already been sent or not and if it has, it returns out of the function without any error, thus pretending everything worked out. Copy: app/code/core/Mage/Sales/Model/Order.php Into: app/code/local/Mage/Sales/Model/Order.php on line 1275 (Magento 1.9....


Find path admin/security/session_lifetime in core_config_data table If it's present then set its value to 86400 If that path is not present then add it with value 86400 INSERT INTO `core_config_data` (`scope`, `scope_id`, `path`, `value`) VALUES ('default', 0, 'admin/security/session_lifetime', '86400'); After that, refresh Magento cache: ...


To get the Adminhtml Frontname in Magento local.xml try Mage::getConfig()->getNode('admin/routers/adminhtml/args/frontName'); From etc/local.xml <admin> <routers> <adminhtml> <args> <frontName><![CDATA[admin]]></frontName> </args>


You can add the new group in sales with following code. Add it to your modules system.xml file. <config> <sections> <sales> <groups> <newgroup translate="label" module="sales"> <label>New</label> <frontend_type>text</...


I found the cause for the issue. It is due to enabling of SSL. Use the below code in .htaccess for Apache server. <IfModule mod_ssl.c> SSLOptions StdEnvVars SetEnv HTTPS "on" </IfModule> Using nginx with php-fpm add these lines to nginx.conf: fastcgi_param HTTPS on;

Only top voted, non community-wiki answers of a minimum length are eligible