28

How to Remove index.php from Magento URLs Magento is a fantastic platform for selling online, arguably the best, but there’s one thing that has always left me frustrated as an SEO… That pesky index.php directory in the URL of ALL internal pages – nightmare! There’s no benefit to them. They’re bad for SEO, bad for site structure and consistency, and then ...


20

Please try Below steps Delete var/cache folder Go to database SELECT * FROM core_config_data WHERE path = 'web/seo/use_rewrites' and make it 0 Then enter url in your browser magento_base_url/index.php/your_admin_url try and let me know if you face any issue.


19

For Linux edit the file /etc/apache2/apache2.conf To edit this file use sudo vi /etc/apache2/apache2.conf command <Directory /var/www/> Options Indexes FollowSymLinks AllowOverride None Require all granted </Directory> to <Directory /var/www/> Options Indexes FollowSymLinks AllowOverride All ...


18

Css and js will created at run time in pub/static folder In first time,if css and js missing then run below command if you are using windows: php bin\magento setup:static-content:deploy if using linux of 'git bash': php bin/magento setup:static-content:deploy


16

As @Cags said, this is not (easily) possible because the ACL tree is loaded when the session is initialized (AKA when the admin logs in). A possible workaround would be to override the _isSectionAllowed method in system configuration controller: (Mage_Adminhtml_System_ConfigController::_isSectionAllowed) and make it reload the ACL tree. Something like: ...


16

The reason for this error is that store_id and website_id for admin should be set to 0 (zero). But, when you import database to new server, somehow these values are not set to 0. Open PhpMyAdmin and run the following query in your database:- SET FOREIGN_KEY_CHECKS=0; UPDATE `core_store` SET store_id = 0 WHERE code='admin'; UPDATE `core_store_group` SET ...


12

I was also facing this problem. Admin gives 404 error and frontend didn't attach css(i.e. Luma didnot showing in proper format..).so i did these steps to solve these both problems in magento 2. 1)go to terminal and run this command sudo gedit /etc/apache2/apache2.conf And change:- <Directory /var/www/> Options Indexes FollowSymLinks AllowOverride ...


11

You're not going to get out of this without a little debugging. The following applies to Magento CE, but should be relevant for Magento EE. Also, this post summarizes a lot of material found in my Magento Dispatch series. If you want to really engage in some bottom up debugging, start there. To start, most of the Magento problems I see boil down to "I was ...


10

Make sure you have a working .htaccess file, optionally you can take it from a fresh Magento version download. Also check if mod_rewrite is enabled on your server. That can be done by reading the phpinfo(); from a script on your server. This Stackoverflow post tells you how.


10

I fix this by the https://github.com/magento/magento2/issues/2504#issuecomment-159663316 Here is the code My nginx site config upstream fastcgi_backend { server unix:/var/run/php/php7.0-fpm.sock; } server { listen 80; server_name YOUR_IP_OR_DOMAIN_NAME; set $MAGE_ROOT YOUR_MAGENTO_FILE_PATH; set $MAGE_MODE developer; include ...


10

My solution, go to file app/Mage.php on line 808, replace $file = empty($file) ? 'system.log' : basename($file); to $file = empty($file) ? 'system.log' : $file; and comment the following line /* if (!self::helper('log')->isLogFileExtensionValid($file)) { return; }*/


9

I found a way around this with very little customization. What we need is: A new controller action that reloads the ACL (without logging out and in), then redirects back to the previous page: class SSE_AclReload_Adminhtml_Permissions_AclReloadController extends Mage_Adminhtml_Controller_Action { public function indexAction() { $session = ...


9

404 issues are quite common when migrating Magento installations between servers. As per this post on SO please see the following answer Magento Admin 404 You need to go your server directly and do this via SSH/ FTP You have to delete the following file: app/etc/use_cache.ser If you get an error after that like: Notice: Undefined index: 0 in /srv/www/...


9

This is a general error, usually occurs when you transfer your magento-2 installation from one location to another. The reason behind this error is that the value store_id and website_id for the admin should be 0 , but when you import the database to a new server, somehow these values are not set to 0. So to solve this error you will need to make some ...


8

For those who are using wamp server, then run these commands in your CLI. C:\wamp\bin\php\php5.5.12>php.exe C:\wamp\www\\bin\magento setup:static-content:deploy


8

For individual product, try saving the product in admin without any change. For all products, try running the following command (this will take some time to complete): php bin/magento catalog:images:resize


7

Some troubleshooting tips: Do you have a module registered in app/etc/modules? If not, it should be as such: <?xml version="1.0"?> <config> <modules> <ThomasRyan_Checkoutajax> <active>true</active> <codePool>local</codePool> </ThomasRyan_Checkoutajax> &...


7

I had a problem that responded well to commenting out the line you suggest too.: Mage::dispatchEvent('catalog_controller_product_view', array('product' => $product)); so this got me thinking to look for anything using that event, so i did a grep on app/code for catalog_controller_product_view not, much, considering the first one is just that which has ...


6

First off, be sure to rebuild your indexes via shell php shell/indexer.php reindexall They're set to "Scheduled" in admin, and you can see exactly how that's handled by checking - System->Configuration->(Advanced)Indexing They should be set to "On Save", but experience tells me that you should do it manually anyway. If that fails, open your ...


6

You shouldn't delete the store with id 1. In the method Mage_Code_Model_App::getStore there is this if (!Mage::isInstalled() || $this->getUpdateMode()) { return $this->_getDefaultStore(); } This means that when you are installing, or running upgrade scripts, the result of _getDefaultStore is used as a store. _getDefaultStore() looks like this: ...


6

To remove index.php from URLs follow the below steps : Log-in Magento Admin Go to System -> Configuration -> Web From Search Engine Optimisation tab Use Web Server Rewrites select YES. Make sure your Secure and Unsecure base urls should end with “/”. Now edit your .htaccess ( will be in magento root folder ) and paste the code which is given at ...


6

I was also facing this issue. After fresh install of magento 2 with demo data when navigating to the frontend and backend too in localhost. Got MIME type mismatch errors for calendar.css and require.js. Nothing worked for me unless deployed the static content through php bin/magento setup:static-content:deploy in git bash and while it is default mode.


6

you can add set setTimeout <script type="text/javascript"> function scr(){ window.location = "http://www.yoururl.com"; } setTimeout(scr,10000); </script>


5

Looks like the table report_event_types is empty. If yes, run the following query and it will work. CREATE TABLE IF NOT EXISTS `report_event_types` ( `event_type_id` smallint(5) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Event Type Id', `event_name` varchar(64) NOT NULL COMMENT 'Event Name', `customer_login` smallint(5) unsigned NOT NULL DEFAULT '0'...


5

One explanation is your .htaccess isn't being picked up. Can you try to add in index.php in the URL and see if this solves the issue? index.php/url_key


5

I ran into this same issue with an empty url key for an inactive category. It didn't pop up until I tested reindexing in EE 1.13.0.0 after the upgrade. Same deal, 404 on the home page. I'm probably well oversimplifying Alan's detective work, but I ended up just querying the new enterprise_url_rewrite table for an empty request_path. SELECT * FROM `...


5

You does not need to change other than following points . just do these two settings and you will be ok . in System -> Configuration -> Web -> Search Engines Optimizations, select YES. And in System -> Configuration -> Web -> Secure -> Use secure URLs in the frontend, select YES. Refresh your cache if still facing issue do following in your httpd.config ...


5

Try re-indexing using the Magento 2 CLI ssh into the server where your Magento files are and go into your Magento root folder. cd /var/www/html/magento2 From that folder you can access the magento 2 cli with bin/magento If you can't start it, use chmod +x bin/magento in order to re-index data via the CLI, use the following command bin/magento indexer:...


5

Enter in you database and run this : SELECT * FROM `url_rewrite` WHERE request_path=''; Delete the rows and after that do : php bin/magento setup:upgrade php bin/magento cache:flush Disable the Page Cache , and see if the error persist . Check if you have redis cache , and clean it . See the template assigned in homepage , check the console for any ...


4

In my experience this is most often caused by poorly written CMS integrations. It's not uncommon for a CMS integration to rewrite the noRoute action to catch when Magento would issue a 404, grab content from a CMS (if available) and then serve it up in the content section of the page. What goes wrong, however, is when these custom integrations then fail to ...


Only top voted, non community-wiki answers of a minimum length are eligible