The Stack Overflow podcast is back! Listen to an interview with our new CEO.
15

SOLUTION # 1 (IF YOU WANT TO EDIT XML FILE) I would like you to download Magento 2 zip from magentocommerce.com/download, create new db in phpmyadmin, extract zip in htdocs folder. Install Magento 2 but do not use localhost use 127.0.0.1 in store URL and admin URL. After successful installation DO NOT run magento. Now we are going to clear / delete caches ...


7

You can download corresponding file from the official Magento 2 repository. That will solve your problem.


6

The following rewrite rule should forward all non-https requests to the corresponding page via https with a 301 redirect. RewriteEngine on RewriteCond %{HTTP_HOST} ^example.com [NC,OR] RewriteCond %{HTTP_HOST} ^www.example.com [NC] RewriteRule ^(.*)$ https://www.example.com/$1 [L,R=301,NC]


5

Install Wordpress in a different location, ideally outside of the Magento root and add this rule to the .htaccess file of Magento: RewriteRule ^/de/blog/(.*) /path/to/wordpress/$1 [QSA] This way the server redirects requests like /de/blog/anything internally to /path/to/wordpress/anything (Note that the former is a URL, the latter a path on the server) [...


5

What you have so for should work pretty well. The actuall redirect part I've added below RewriteEngine On Options +FollowSymLinks RewriteCond %{HTTPS} on RewriteCond %{REQUEST_URI} !^/customer/account/ RewriteCond %{REQUEST_URI} !^/checkout/ RewriteCond %{REQUEST_URI} !^/wishlist/ RewriteCond %{REQUEST_URI} !^/ebizautoresponder/ RewriteCond %{REQUEST_URI} !^...


5

Try to run below command php bin/magento setup:static-content:deploy And if it gives any error while running this command, like file missing as you already said ,then compare your project file structure with fresh magento2 file structure . If any file missing in your project then copy appropriate file into your project. And if you got any other error then ...


4

I got this from apache wiki https://wiki.apache.org/httpd/RewriteHTTPToHTTPS This will enable the Rewrite capabilities RewriteCond %{HTTPS} !=on This checks to make sure the connection is not already HTTPS RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]


4

The web server user must have write access to the following files and directories: var app/etc pub Magento also recommends setting the permissions as follows: All directories have 770 permissions. 770 permissions give full control (that is, read/write/execute) to the owner and to the group and no permissions to anyone else. All files have 660 permissions....


4

Thats the correct behavior. Most of the Mail Clients can't or do not want interpret the password protection, because it can be used for phishing attacks. Web Mail-Clients like google, even didn't show the original Image path in the Mail. They try to catch the Image from the server and display it by it own. What you can do is to modify the .htaccess and ...


4

I fixed it by adding RewriteCond %{HTTPS} !=on RewriteRule ^(.*)$ https://mydomain.co.uk/$1 [L,R=301] To my .htaccess and setting Auto-Redirect to base url to No Hope this helps someone


3

No, without the .htaccess in the root directory your magento project won't force (non-existent) page look ups to go via the index.php and the magento core. Try copying one from a fresh install. You can download the files from https://www.magentocommerce.com/products/downloads/magento/ - be sure to match the correct version with your install. You might just ...


3

To remove category paths from product url set "Use Categories Path for Product URLs" to "No" under System -> Configuration -> Catalog -> Search Engine Optimizations. To remove parent category path from child category url Rewrite class Mage_Catalog_Model_Url override method public function getCategoryRequestPath($category, $parentPath) like below ...


3

It is hard to do it via htacces you only need to change few settings at the backend: Go to the Magento Admin Panel -> System -> Configuration -> Catalog -> Seo Options Select yes or no from "Use Parent Category Path for Category URLs" Refresh category url index Option YES => http://www.example.com/category/subcategory.html Option NO => http://www.example....


3

What you could do is listen to the event admin_user_authenticate_after and check the ip if it matches. This event is fired when a user is authenticated in the admin login process. It has the result passed in so you should be able to check the ip and if you want to limit the access simply set the result to false and thus the authentication will fail. Mage::...


3

A CNAME record or Canonical Name record is a type of resource record in the Domain Name System (DNS) that specifies that the domain name is an alias of another, canonical domain name. The most popular use of the CNAME-record, is to provide access to a web server using both the standard www.domain.com and domain.com (without the www). This is usually done by ...


3

Allright, after messing around with Apache config I found the following: I had missing "-pass-header Content-Type" from fastcgi.conf Make sure you have it on this line: FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi -host 127.0.0.1:9000 -pass-header Authorization -pass-header Content-Type


3

order deny,allow deny from all allow from 111.222.333.444


3

You can use the IP and Authentication together Below I have two ip's incase you needed an example for how to handle additional. If your image upload is hitting the authentication still then you should use your server's actual IP address instead of the localhost IP. AuthName "Authorized users only" AuthType Basic AuthUserFile /root/web/html/.htpasswd ...


2

When you access localhost (even when you use full name or IP address) your client machine identifies itself as 127.0.0.1 (it's localhost IP equivalent). Since 127.0.0.1 is not in your deny list, it allows you to continue. If you want to investigate this thing further, use PHP to print out $_SERVER["REMOTE_ADDR"] to see how server recognises your client ...


2

Setting environment variables in the .htaccess or virtualhost means they become available in PHP's $_SERVER superglobal array. This bit of code in the index.php file grabs the store codes from $_SERVER and passes them to Mage::run when bootstrapping Magento. /* Store or website code */ $mageRunCode = isset($_SERVER['MAGE_RUN_CODE']) ? $_SERVER['...


2

The errors folder should not be accessible. See an example here. Most probably you are missing something in the .htaccess file. Try to get one from the fresh Magento copy. Also make sure that you have this .htaccess file inside the errors folder. <FilesMatch "\.(xml|phtml)$"> Deny from all </FilesMatch>


2

I think a .htaccess rewrite would do the trick RewriteCond %{REQUEST_URI} !^/(it|de)/ RewriteRule ^/(.*).html$ http://www.site2.com/$1.php [R=301,NC,L] This will redirect all the urls from site1.com that don't start with /it/ or /de/ to site site2.com


2

Please check with your hosting provider that: they are using Apache as web server. If they're using Nginx then .htaccess doesn't work at all and special configuration is needed Ask if their Apache configuration supports .htaccess files. Create a simple .htaccess with some very basic directive and check if it works. If it works check your Magento's .htaccess ...


2

Yes looks like it but I don't think you will be calling the cron.sh from a browser so no need for: allow from localhost I'd just do the following <Files cron.sh> order allow,deny deny from all </Files> Also I'd look at permissions and on the file and possibly change it's owner/group to a different user than the webserver'...


2

There are dozens of different bots and not all of them play nice, but you have handful of tools at your disposal: robots.txt has crawl-delay command. This makes sure that crawler waits at least specified number of seconds before making next query to the server. Google Webmaster Tool provides an option to set crawl rate. Obviously it only works for Googlebot....


2

With regards to this error: Fatal error: Maximum execution time of 30 seconds exceeded in /home/saltante/public_html/pcstore/lib/Zend/Cache/Backend/File.php on line 747 You should adjust this setting in your php.ini file. Ideally you will increase the value from 30 seconds. max_execution_time Also Should i be using Magento caching as well as ...


2

You can try the following: RewriteEngine on RewriteBase / RewriteCond %{REQUEST_URI} !^/admin RewriteCond %{REQUEST_URI} !^admin RewriteCond %{REQUEST_URI} !^/index.php/admin RewriteCond %{REQUEST_URI} !^index.php/admin RewriteRule (.*) http://www.b.co/$1 [R=301,L] You can change admin if you use another path for your admin area.


2

It seems you already answered your own question. I've placed the RewriteCond line and the RewriteRule line from your question in my .htaccess file (after the already existing 'RewriteEngine on') and did a curl request from my terminal to see what happens; ➜ hackathon curl -vvv http://hackathon.dev/customer/account/index\?___store\=tienda * Trying 127.0....


2

Your .htaccess file for Magento should not look like that. You may have a default OSX file or something in the folder. I would recommend looking at this sample .hataccess file from Creare. https://github.com/Creare/magento-htaccess/blob/master/.htaccess It is an optimized version of the default Magento file, but enhanced for speed and SEO. Keep in mind ...


2

Try appending [R=301] to your RewriteRule entries. If you have existing parameters (like [L]), comma-separate them: [R=301,L].


Only top voted, non community-wiki answers of a minimum length are eligible