Questions tagged [vulnerability]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
21 views

How to prevent Host Header Poisoning in Magento 2?

I'm using magento 2.4.1 , i tried to make a GET request, i added ':22345' as suffix in my host header so it will look like this: when I invoke this code in phtml file echo $block->getRequest()->...
1
vote
1answer
796 views

Use of Jquery 1.10 with Known Vulnerability

We launched a website 2 weeks ago and our client launch a pen test to check if everything was safe. Unfortunately It looks that we have two issues because of : Vulnerable javascript library: jQuery....
0
votes
1answer
94 views

Magento 1.9 - Sanitization of Fields Required

I have to find PCI vulnerabilities in the Sanitization of fields. I have one form to submit data. In this, input fields of form should be sanitized.how to add a script for sanitization in magento1.9 ...
1
vote
0answers
57 views

Magento 2.3.3: XSS Vulnerability in URL

I'm wondering if there is a fix/patch in Magento 2.3.3 for escaping URL's because it's still vulnerable for XSS attacks.
1
vote
1answer
185 views

Magento Security Scan Erroneous Results (falses positive)?

The Magento Security Scan returned this vulnerability: API ACL - Failed. API ACL Patch not detected (APPSEC-1679) Apply the Magento 2.0.14/2.1.7 Security Update immediately. However, my site is ...
4
votes
2answers
393 views

Magento 2.3.0: Magento Unprotected XML

I'm getting the following vulnerability issue when using the Magento Security Scan: We have determined that your Magento installation's configuration file(s) are publicly accessible over HTTP. '....
3
votes
0answers
37 views

Magento 2 - PHP Vulnerabilities message

I am getting PHP Vulnerabilities notification and it is showing critical. Reminder on PHP VulnerabilitiesMS-ISAC has issued an alert related to multiple vulnerabilities that could allow for ...
0
votes
1answer
165 views

Add to Compare: is there known exploitation?

Last week, one of my site received a bruteforce attack. When I check log/reports, I see this in my report: a:5:{i:0;s:313:"SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or ...
5
votes
2answers
337 views

Should I be worried about the latest Zend-Mail RCE Vulnerability similar to the PHP-Mailer/Swift Mailer Vulnerability if I use Magento?

From the recently disclosed Zend-mail remote code execution vulnerability: Affected Zend Framework versions: Zend Framework < 2.4.11 Remote Code Execution (CVE-2016-10034) zend-mail < 2.4....
3
votes
1answer
268 views

how to solve Magento vulnerability issue

Magento website scan report says that it has some issue about security in website.following scan report says about my website vulnerability. vulnerability Name: Php Info File vulnerability Name: Web ...