Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [version]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
51 views

Compilation from source: LESS file is empty:

I have upgraded my magento version from 2.4.0 to 2.4.6-p3 and in exceptions.log file i am continuously getting one error i.e main.CRITICAL: Magento\Framework\View\Asset\ContentProcessorException: ...
Tisha Jhanwar's user avatar
0 votes
0 answers
37 views

Problem with Magento install on MAMP

I've been trying to install Magento(2-2.4) on MAMP Pro on my macbook. I downloaded the code and am trying to install and I've gotten close but I can't figure out how to get past this screen: There ...
angler's user avatar
  • 1
1 vote
3 answers
212 views

Facing issue in composer.json file for an extension

I have mentioned in my one of extension in composer.json. Could anyone tell what does it mean. I think it means that the php version should be greater than 7.4.0 but less than 8.2.0 but when i ...
Tisha Jhanwar's user avatar
2 votes
3 answers
195 views

Magento 2: Errors on running setup:di:compile after upgrade from Magento version 2.4.3 to 2.4.5:

I am getting this error after upgrading Magento version 2.4.3 to 2.4.5 I am unable to find any solution. please help.
kiran's user avatar
  • 597
0 votes
2 answers
17 views

How to install exact same module versions to production installation

I have tested all extensions and theme in staging installation and now I need to install the exact same versions of each module and theme to the production installation by using composer. What is the ...
Webninja's user avatar
  • 1,593
2 votes
1 answer
2k views

Deprecated Functionality: Zend_Http_UserAgent implements the Serializable interface in magento2.4.4

I am facing "Deprecated Functionality: Zend_Http_UserAgent implements the Serializable interface, which is deprecated. Implement __serialize() and __unserialize()" Error in magento2.4.4 All ...
Anikesh Shahi's user avatar
0 votes
1 answer
357 views

public static function getVersion() : m2

Setup Data Patch script is executed successfully after running setup:upgrade command. Now i want to execute same script with public static function getVersion() function. Module version is : <?xml ...
Jimit Bhavsar's user avatar
0 votes
2 answers
199 views

Magento installing different modules to those stated in composer.json

I have successfully updated to 2.4.3 and in doing so have upgraded a number of modules. For some reason, however, Magento is ignoring the module versions stated in the composer: Two modules for ...
Ian Rushton's user avatar
0 votes
1 answer
851 views

Magento 2 : Type Error occurred when creating object

Type Error occurred when creating object: Magento\Search\Model\EngineResolver, Argument 2 passed to Magento\Search\Model\EngineResolver::__construct() must be of the type array, null given This error ...
magedev's user avatar
  • 55
0 votes
1 answer
421 views

PHP ^7.1 meaning

Just to make something clear, when my Magento 2 module state: "require": { "php": "^7.1.0" }, Does that mean that the module support PHP version 7.1 and higher or ...
Jan-petter Havna's user avatar
0 votes
1 answer
53 views

Magento version upgrade from 2.1.7 to magento 2.3.3

I want to upgrade my magento version from 2.1.7 to magento 2.3.3 How can i do that. Because both the version supports different php version? Is there any way for direct upgrade.
Nafsss's user avatar
  • 760
1 vote
4 answers
63 views

How to make choice a between 2.3.7 and 2.4, current 2.3.3?

We are planning to upgrade our store, the current version is 2.3.3, but which version should we choose, 2.4.* or 2.3.7? Is there an LTS version?
Nathan Tsui's user avatar
0 votes
1 answer
263 views

how can i update magento 2.2.5 to 2.4.0 without data loss and bug?

Currently my website running on Magento 2.2.5. I want to upgrade it with current version 2.4.0. Please anyone suggests me how can I update it without getting any issues. wihtout lossing customized ...
Jitendra prajapat's user avatar
0 votes
3 answers
446 views

PHP version check error occur while installing Magento2 locally

I am trying to install Magento 2 in my machine locally but I am getting PHP version check error. How to fix this error. I am using PHP 7.4 version as a default installed by xampp. I have googled & ...
Salman Dalal's user avatar
1 vote
1 answer
128 views

Magento search is not working after upgrade to latest version

Does any one know how i can solve my problem ? . becuase my search is not workinig after upgrade magento version
Sanjay Shiyal's user avatar
1 vote
1 answer
203 views

What's security-only patch release and how to apply it?

I noticed we have security-only patch releases, what's it and how to use it? An example of these security-only patch releases, instead of having Magento 2.3.2 my client has installed Magento 2.3.3-p1....
Rafael Corrêa Gomes's user avatar
2 votes
1 answer
163 views

Magento upgrade version 1.9.4.1 to 1.9.4.3

How do I upgrade my site Magento version 1.9.4.1 to 1.9.4.3 Please give me suggestion how can I do this I take all backup file in an old version in site so how can I upgrade through a command line ...
MOHIT GOHEL's user avatar
3 votes
3 answers
94 views

Migrate from 2.2.1 to 2.3 CE

I have to redo a magento website from 2.1 CE to 2.3 CE. There are few orders with total sales of 230$. what is better to create from scratch and migrate customers and orders? or is there a way by ...
Amol Bhandari SJ's user avatar
3 votes
2 answers
2k views

Using Magento 2.3.2 with MySQL 8.0: Which problems could arise?

According to the DevDocs only MySQL 5.6 and 5.7 is supported. I have set up a shop now with MySQL 8.0 and it seems to work so far. However, it is not a fresh installation, instead I dumped the ...
robsch's user avatar
  • 311
0 votes
1 answer
2k views

Magento 2.2.9 Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE) magento setup:upgade command

I received the error when I try to run on the live site. ( I was able to upgrade to 2.2.9 for the test site, which was cloned from the live site). after i did composer require magento/product-...
Mage Explorer's user avatar
2 votes
1 answer
262 views

Magento 2. How can I properly extend vendor/composer/installed.json?

I assume that installed.json contains all the dependencies needed for Magento. How can I properly extend vendor/composer/installed.json? Context: Magento has a hard dependency on one of the ...
vitoriodachef's user avatar
0 votes
2 answers
2k views

Upgrade Magento vendor module(dependency|library) to a newer version

Magento uses multiple "external" dependencies|libraries for example one of them is dotmailer-magento2-extension. This specific module is at version 3.1.1 as it can be seen here vendor/dotmailer/...
vitoriodachef's user avatar
1 vote
0 answers
38 views

Local version of website is wrong

I want to fix a website that was done by another person but I do not want to break the live version of it. So I downloaded the whole website completely and the live database, installed everything on a ...
Telion's user avatar
  • 111
3 votes
1 answer
118 views

how to fix error occurred during upgrade magento from 2.2 to 2.3?

Process : Upgrade Magento version from 2.2 to 2.3 As per my client requirement, I tried to upgrade Magento from 2.2 to 2.3 as mentioned in this URL: https://devdocs.magento.com/guides/v2.3/comp-mgr/...
Yagnik Solanki's user avatar
3 votes
2 answers
98 views

Which Versions of Magento 2 are latest till date?

I was looking for latest and stable versions of Magento 2. Is there a proper guide which version is latest in different series like 2.4 or 2.7 ?
Ajwad Syed's user avatar
  • 1,591
0 votes
1 answer
536 views

Magento 2.3.0 setup:upgrade error unexpected '?' in PHP 7.2

I am facing this type of error.Unable to access any CLI on Setup. Version Compataible is also match but still no luck. Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE) ...
Anikesh Shahi's user avatar
4 votes
0 answers
2k views

Magento 2 : setup:upgrade throwing error. After Magento 2.1 to 2.3 update

I recently updated my Magento version form 2.1 to 2.3.0. Update was successful in my local system. Now its throwing error while running setup:upgrade like this. Schema creation/updates: PHP Fatal ...
Shajitha Banu's user avatar
0 votes
1 answer
61 views

Anyway of being Notified of a Magento 2 Update without logging in the Admin Panel

Say I have 2 sites that I don't really logon to the admin panel all that often, is there anyway to notify me of any updates to magento? e.g. RSS feed, Email ? I heard of a potential rss feed from a ...
Greg's user avatar
  • 399
0 votes
0 answers
292 views

Upgrade from magento 2.2.5 to 2.2.6

I got this error when tring to run this command : composer update magento/product-community-edition:2.2.6 --with-dependencies [Composer\Downloader\TransportException] Invalid credentials for '...
Developper Magento 's user avatar
1 vote
0 answers
72 views

getting error when upgrading from Magento 2.1.5 to Magento 2.2.6

I want to upgrade my website with the latest version. I am using below commands: composer require magento/product-community-edition 2.2.6 --no-update composer update I am getting below error:...
Vinod Kumar's user avatar
  • 2,065
2 votes
0 answers
457 views

How to find Magento version using API (JSON specifically)

Using the JSON RestAPI, I need to do things slightly differently depending on the version of Magento due to as-yet un-fixed bugs (specifically https://github.com/magento/magento2/issues/18005). I can ...
KolonUK's user avatar
  • 397
2 votes
2 answers
628 views

WAMP error 500 when attempting to setup Magento2

I'm attempting to setup my own WAMP server and use Magento 2. I've installed to my machine however in my apache error log I get IfVersion', perhaps misspelled or defined by a module not included in ...
Greg's user avatar
  • 399
1 vote
3 answers
2k views

How to know magento 1.9 version Using MySql?

I am having Magento1 Database details. Using that can we get the version of Magento? I found it can get with files or with some custom code. I am looking to get from the Database. In which table does ...
Jafar Pinjar's user avatar
  • 1,939
1 vote
0 answers
14 views

Problem with installation

I have an old and a new version of Magento 2 installed. However, I have to use the old version because the server only supports PHP 5. After installing this error has appeared. After that I tried to ...
Carmen Schweinzer's user avatar
4 votes
2 answers
2k views

Version Control Magento 2 on Git

What is the best way to version control Magento 2 store on Git? How should I set up the repo/s to be flexible and reliable in a long run? I use composer to install all third party modules (when that’...
Greg's user avatar
  • 2,729
0 votes
1 answer
220 views

Magento 2.2 is not Installing i have VPS

i have vps server from godaddy. i tried to install magento it gives me error. i also fulfilled all magento requirements by easyapache4.. With PHP7, Magento 2 require these PHP extensions on server: ...
Aadii Mughal's user avatar
1 vote
1 answer
22 views

How can I find out version info required to select correct update method?

I have been asked to help a client upgrade their Magento site from v2.1.9 to v2.2.3 but from what I'm reading on the magento.com website so far, this sounds like a very complex process that depends on ...
steevithak's user avatar
1 vote
1 answer
163 views

After upgrade magento 2.1.11 => 2.2.3, I got below error how to fixed it

Notice: Undefined index: src in /vendor/magento/framework/View/Page/Config/Generator/Head.php on line 125 How to fix it. please reply. Thanks
user64420's user avatar
1 vote
2 answers
796 views

Best way to Version Control whole Magento store

We are currently trying to implement a good version control system for our company with 3 Magento web-stores. These websites will be kept in three separate repositories on local server. We were ...
Greg's user avatar
  • 2,729
1 vote
1 answer
195 views

How do you update Magento2 version without any downtime of the website?

How do you update Magento2 version without any downtime of the website? If updating from the command line, at point of di:compile, the website is down during this period. If updating from Web Setup ...
MagentoMac's user avatar
  • 1,042
2 votes
1 answer
653 views

Changes or improvements in Magento 2.2.2

Magento will introduce Magento version 2.2.2. So what will be changes and improvements in Magento 2.2.2? I tried to search on google for version Magento 2.2.2 but didn't find anything about magento2....
Sharfaraz Bheda's user avatar
1 vote
0 answers
34 views

How to retrieve product photos and product info from (a non-working) Magento 1.3.1?

Magento 1.3.1 I had a store installed/running on Magento 1.3.1 on an old server. Then we setup another store (running Magento 1.9.1) on a new server. The newer server had higher versions of pHp and ...
Allysin's user avatar
  • 260
0 votes
2 answers
755 views

SQLSTATE[HY000]: General error: 145 Table './mysite_shop/log_visitor' is marked as crashed and should be repaired

Magento 1.9.1 OR 1.3 I had a running website on my old server but it never got any orders so I didn't worry about it much back then. After migrating to a new server I didn't even check it but now I ...
Allysin's user avatar
  • 260
8 votes
3 answers
7k views

How to check applied patches in magento 2

Is there a way in Magento 2 to check the applied patch status? Just like we can check the patch status in Magereport in Magento 1?
Purushotam Sharma's user avatar
2 votes
1 answer
28 views

Just want to know 2 simple question?

When the table with name sales_flat_order first introduced in Magento & in which version ? When the table with name log_visitor first introduced in Magento & in which version ?
Magento 2 Learner's user avatar
2 votes
1 answer
40 views

Upgrading from 2.1.4 to latest version

I have Magento 2.1.4 CE installed. I have browsed the devdocs and forums on upgrading and I am confused. What commands do I have to run exactly to do the upgrade? When I try to run composer require ...
marilena6's user avatar
  • 125
0 votes
1 answer
62 views

Patch 7405 v1.1 Installation error - Already Installed Patch 7405 v1.0

Installation error : How can i solve this Patch 7405 v1.1 Installation error?
zus's user avatar
  • 165
0 votes
1 answer
807 views

why is Magento 2 semantic versioning at 100?

I am using Composer to install Magento 2 and I've noticed that all packages are starting with 100. According to semantic versioning rules, Magento 2 packages should be at version 2.x.x something. ...
Elzo Valugi's user avatar
2 votes
0 answers
922 views

Magento 2 : Add child products return error using REST API

Magento 2.1.8. I firstly successfully use rest API to create a parent item (configurable item). Then I use the API to create a child item (simple product item) under the parent item. The Magento 2 ...
mzzhmh's user avatar
  • 31
0 votes
1 answer
508 views

Is it possible to downgrade 1.9.3.3 version to 1.9.3.2?

How to downgrade the the version from 1.9.3.3 to 1.9.3.2.. Is there any possibilities to do this?
Gowri Shankar's user avatar