Questions tagged [upgrade]

Questions related or caused by Magento upgrade process.

Filter by
Sorted by
Tagged with
0
votes
1answer
21 views

Upgrade from Magento 2.2.8 to 2.3.6, which steps do i have to follow?

I have a Magento store and want to Upgrade from Magento 2.2.8 to 2.3.6. I would like to retain customers and orders, reviews, newsletter data, category and products. Current store using Porto theme ...
0
votes
2answers
31 views

Magento 2.3.5 p1 latest?

Am i on the latest version of Magento? We are on 235p1 and version is community. Are there critical patches available? Thanks.
0
votes
1answer
63 views

“In State.php line 153 Area code is not set” error while upgrading to Magento 2.4.2

I tried to upgrade Magento core from 2.4.1 to 2.4.2 by changing composer.json and did composer install. After that, ran the upgrade command. The upgrade breaks and shows "In vendor/magento/...
0
votes
1answer
90 views

Magento upgrade from 2.4.0 to 2.4.1 Cannot allocate memory Error

I´m with a 4Gb RAM with 1Gb SWAP at Cloudways and try to upgrade my Magento from 2.4.0 to 2.4.1 following this procedure: https://forums.envato.com/t/how-to-upgrade-magento-version-from-2-4-0-to-2-4-1/...
0
votes
0answers
21 views

How long does it take to make amendments to an already uploaded and approved magento 2 extension

For example I am developing a payment method module for magento 2. Suppose I have submitted the module for review. All the tests pass, my module is approved, up and running. Some magento websites ...
0
votes
1answer
91 views

How to solve Magento 2 with composer 2 version error when sample data install

My application running AWS Bitnami platform. I am trying to upload sample data using composer after commands show warning message below Do you want to store credentials for repo.magento.com in /...
0
votes
0answers
38 views

Magento migration 1.9.3.1 to 2.3.5 p2

When i doing migration from magento 1.9.3.1 to magento 2.3.5 p2 getting this error. And after search this related issue i deleted some database tables but again and again i getting this issue on ...
1
vote
1answer
50 views

From upgrading Magento 2.3 to 2.4 setup upgrade command is struck

I have updated my Magento from version 2.3 to 2.4. But when i hit bin/magento setup:upgrade it will running from around 1 hr. When i check show processlist a command is running SELECT `...
2
votes
1answer
63 views

Magento 2: why we should pass all required fields to update one field of customer by REST API?

I have created rest api for customers who update the one customer field. This is below code to updaye customer by REST API Any other way to update the customer by REST API without the pass mandatory ...
0
votes
1answer
36 views

Getting error on updating magento 2.4

On updating Magento 2.4 from 2.3 it will be stopped after getting this error on installing that extension it gives me this error Issue on setup:upgrade command Any help is appriciated.
2
votes
3answers
86 views

How to update Magento 2.3 to 2.4?

I have a store in Magento 2.x.x I want to update Magento 2.3 to 2.4 but when I update it using the command: composer require magento/product-community-edition=2.4.0 --no-update I get the following ...
0
votes
0answers
27 views

Magento upgrade problem Fatal error: Uncaught Error: Cannot instantiate interface

I upgraded from Magento 2.3.4 to 2.4.0 And now I'm getting the following error when running the indexer. Fatal error: Uncaught Error: Cannot instantiate interface Magento\InventoryCatalogApi\Api\...
0
votes
2answers
45 views

Upgrade from Magento 2.3.2 CE to 2.4

I have a Magento site (v2.3.2 CE) hosted on Nexcess. It has several extensions (paid and free) that are very outdated. There are also some custom backend extensions and a custom theme. This site was ...
0
votes
1answer
68 views

Permission denied error when trying to access magento2 prior to installation on Ubuntu 20.04 / nginx / php 7.4

What I've done so far, Installed nginx 1.19.6 Installed php 7.4 and all required extensions in Magento Documentation Installed and configured MySQL as per documentation, and created magentodb ...
0
votes
1answer
374 views

Magento 2.4.2, Magento 2.4.1-p1 and Magento 2.3.6-p1 all available on 9 February 2021. Which to choose?

We tried upgrading to Magento 2.4.1 but are having many issues so we are going to postpone the upgrade. The full and final versions of Magento 2.4.2, Magento 2.4.1-p1 and Magento 2.3.6-p1 will be ...
0
votes
0answers
15 views

update-cron.WARNING: Update is already in progress

I'm running a Magento 2.3.2 B2B and opening my var/log/cron.log I see these messages below. setup-cron: Please check var/log/update.log for execution summary. update-cron: Please check var/log/update....
0
votes
0answers
26 views

Magento 2.4 upgrade Class 'Zend_Controller_Request_Http' not found

I recently updated from Magento 2.2 to Magento 2.4 and I have some custom modules which are throwing errors like these when I run setup:di:compile in my terminal. I have observed that in vendor folder ...
0
votes
1answer
33 views

Upgrade from 1.9.2.4 to 1.9.3.6 and have blank pages

I did an upgrade by installing a fresh 1.9.3.6 and then copied back my core files. Now i have a blank page and cant see any errors which make me think it is nearly there. I looked in the server logs ...
0
votes
1answer
38 views

Upgrade magento2.3.0 to 2.4.1- allowed memory error

I followed below steps: Part 1: php bin/magento deploy:mode:set developer php bin/magento cache:disable php bin/magento maintenance:enable composer require magento/product-community-edition 2.4.1 --no-...
1
vote
1answer
51 views

Upgrade Magento 2.3 and store code base is not found

I upgraded my Magento 2.3.1 to 2.3.6, I'm seeing this message in the frontend. The website with code base that was requested wasn't found. Verify the website and try again. How could I fix it?
0
votes
0answers
59 views

Magento 2: Composer error when trying to update from 2.2.9 to 2.4.1

I am trying to update magento to the latest version. "composer update" quits with this message: Problem 1 - Conclusion: don't install magento/framework 103.0.1 - Installation ...
0
votes
0answers
37 views

Login/Registration pages error/success messages don't show

i have migrated a magento 1.9 server to a magento 2.3 server. everything went fine and i am really happy with that. my only problem is that the page messages on the login and registration page don't ...
0
votes
1answer
345 views

Upgrade 2.4.0 to 2.4.1 composer fails

I'm working with a composer 2.4.0 and try to install 2.4.1 According docs [x] Determine whether your current catalog search engine is supported [x] Complete the Update and upgrade checklist [x] Set ...
0
votes
1answer
81 views

bin/magento command broken after 2.4.1. upgrade because of missing Magento\MediaGallerySynchronizationApi\Model\ImportFilesInterface

bin/magento command broken after 2.4.1. upgrade because of missing Magento\MediaGallerySynchronizationApi\Model\ImportFilesInterface we are not excluding or replacing anthing related to ...
0
votes
1answer
210 views

Upgrade M2.4.1 Error: Cannot instantiate interface Magento\LoginAsCustomerApi\Api\GetLoggedAsCustomerAdminIdInterface

When running upgrade we see no errors but on running the frontend we are surprised with this nice errror statement Error: Cannot instantiate interface Magento\LoginAsCustomerApi\Api\...
0
votes
1answer
61 views

Upgrade from 2.3.5 to 2.4.0 error related to scconnector_google_feed_cl

I'm upgrading Magento 2.3.5 to 2.4.0, but I'm getting this error when trying bin/magento setup:upgrade: Unable to apply data patch Magento\CatalogUrlRewrite\Setup\Patch\Data\UpdateUrlKeyForProducts ...
0
votes
0answers
66 views

how can i update magento 2.2.5 to 2.4.0 without data loss and bug?

Currently my website running on Magento 2.2.5. I want to upgrade it with current version 2.4.0. Please anyone suggests me how can I update it without getting any issues. wihtout lossing customized ...
0
votes
2answers
75 views

How do I upgrade Magento 2.4 using composer?

How do I upgrade Magento 2.4 using composer to e.g. Magento 2.4.1 or Magento 2.4.2 or Magento 2.4.3 for that matter? We've been reading https://devdocs.magento.com/guides/v2.4/comp-mgr/cli/cli-upgrade....
5
votes
2answers
751 views

Error upgrading to 2.4.1

I just tried upgrading from 2.4 to 2.4.1 and now the site is down. We get this error only when trying to access the admin {"0":"Type Error occurred when creating object: Magento\\...
2
votes
1answer
1k views

Magento 2.4: Catalog Search index exception: Could not ping search engine: No alive nodes found in your cluster

We have installed Magento 2.4 on our local machine. After installing, we have got the below error when doing the setup:upgrade Could not validate a connection to Elasticsearch. No alive nodes found ...
1
vote
1answer
292 views

InvalidArgumentException during Magento upgrade via Composer [Package is not installed: magento/project-community-edition-2.4.0.0]

We are seeing InvalidArgumentException during Magento upgrade via Composer [InvalidArgumentException] Package is not installed: magento/project-community-edition-2.4.0.0 It seems to be related to ...
0
votes
0answers
19 views

When upgrading from M2.3.5 (empty) to M2/4 what is the best way to go?

When upgrading from M2.3.5 (empty) to M2/4 what is the best way to go? We are 'already' on php 7.4.x Centos8 with Elastic and Redis/ Route 1 would be to ignore all that we have and run the following? ...
0
votes
3answers
176 views

Magento 2.3.4 - Best practice to do update magento files and modules without affect the website in Production Mode

If i update any modules or disable extensions my website showing an error message, i do following all the commands then coming back to normal, rm -rf var/di/* var/generation/* var/cache/* var/log/* ...
0
votes
0answers
34 views

The “componentType” configuration parameter is required for the “container_ts_dimensions_length” component

I'm having this problem after upgrading from Magento 2.3.3 to 2.3.5-p2 on catalog product edit. 1 exception(s): Exception #0 (Magento\Framework\Exception\LocalizedException): The "componentType&...
1
vote
0answers
247 views

Magento 2.4 Magento\CatalogSearch\Model\Adapter\Mysql\Filter\AliasResolver does not exist

After upgrading to magento 2.4 from 2.3.5-p1 and running setup:di:compile, the following error occurs: In ClassReader.php line 43: Class Magento\CatalogSearch\Model\Adapter\Mysql\Filter\...
0
votes
1answer
123 views

Magento Commerce Cloud Upgrade 2.4 issue

I am trying to upgrade to Magento 2.4 but I get the following error running composer update: - magento/framework 101.0.0-rc21 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) ...
0
votes
1answer
25 views

System upgrade from the admin panel

Magento 2 System upgrade from the admin panel shows the below message: magento/product-community-edition 2.4.0 requires php ~7.3.0||~7.4.0 -> your PHP version (7.0.33) does not satisfy that I have ...
0
votes
1answer
94 views

Change Magento 2 PHP version in SSH

I'm currently trying to upgrade Magento 2.3.4 CE, to 2.4.0 CE. However I was constantly getting "Component Dependency" errors. I then tried to upgrade in SSH but got the following error: ...
0
votes
1answer
40 views

Static content deploy error after upgrading magento 2.3.3 to 2.3.5 (EE)

I am facing Compilation from source: LESS file is an empty issue after Magento upgrade from 2.3.3 to 2.3.5 EE at the time of Static content deploy. Anyone face OR fixed such kind of issues?? ?
0
votes
0answers
58 views

Magento 2.4 upgrade porto CSS issue

I have upgraded my site from Magento 2.3.5 to Magento 2.4 for the previous version Porto was working fine when I upgraded my whole CSS is broken Need Help I Have tried by deploying static content
0
votes
1answer
88 views

Error magento 2.3.3-p1 with Smile ElasticsuiteCore

During magento upgrade to 2.3.5-p1, after doing a composer install this happened when I tried to do any command i.e: magento setup:upgrade The error on terminal: Class Smile\ElasticsuiteCore\Model\...
0
votes
0answers
46 views

Magento1.9 : array_key_exists deprecated in after upgrade php7.4

Am upgrading my magento1.9 site to php version 7.4. I got array_key_exists is deprecated in 7.4 version. In my magento site how to change that function. Some one says use isset or property_exists. How ...
0
votes
0answers
24 views

Stuck with a Magento override problem

Recently upgraded to Magento enterprise edition 2.3.5-p2, I have a problem that occurs with a specific module during compilation: SummaTheme\Widgets\Block\Banners\Product Incompatible ...
0
votes
0answers
21 views

Magento 2.3.2 version upgrade to 2.4.0

I am afraid of upgrading my magento version because my store is all setup. My php version is 7.3.20 and I thinking of upgrading to magento version 2.4.0 composer require magento/product-community-...
0
votes
0answers
84 views

After magento upgrade from 1.7 to 1.9 Order email custom variables are not showing in order emails

After magento upgrade from 1.7.0.2 to 1.9.4.5 Order email custom variables are not showing in order emails anymore. Actually /app/code/core/Mage/Sales/Model/Order.php is extended on website and '...
0
votes
0answers
109 views

Magento upgrade 2.3.4 to 2.4.0

I have problem upgrading from 2.3.4 to 2.4.0 I have elasticsearch and php version that is required.. composer require magento/product-community-edition=2.4.0 --no-update This is the error Im getting ...
0
votes
0answers
11 views

Editing 2 orders at the same time bug. Is there any patch released for this issue?

Is there any patch released for this issue? "when it comes to placing the orders after editing them whereby for instance the editing of 000000002 will result in it's new increment id being ...
0
votes
1answer
296 views

Magento 1 - How to update from 1.9.4.4 to 1.9.4.5

I'm very new to Magento 1 and I need to update from 1.9.4.4 to 1.9.4.5 on my staging system. How can I do that? I can't use composer or anything else. Thanks in Advance!
0
votes
0answers
24 views

Unable to upgrade from Magento2.1.7 to 2.3.5-p1

I am upgrading magento 2.1.7 to Magento 2.3.5-p1. But while running command "composer update" I get below message. "Killed" As showed some references, about increasing my php ...
1
vote
1answer
640 views

Magento 2.3.4 to 2.3.5-p2 upgrade composer google shopping error. Any ideas?

I am trying to upgrade Magento 2.3.4 to 2.3.5-p2 but i am facing a composer error regarding Google shopping. First i upgraded from 2.3.4 to 2.3.5-p1 without any problems, but when trying to upgrade ...

1
2 3 4 5
22