A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.

Questions tagged [upgrade]

Questions related or caused by Magento upgrade process.

Filter by
Sorted by
Tagged with
100
votes
16answers
180k views

New order email confirmation not being sent

I have upgraded my website to 1.9.1 and now my customers are not receiving order confirmation email. I tried sending through the admin panel but nothing happens, also no update email is being ...
63
votes
6answers
8k views

How do you give estimates for Magento upgrade?

Overview: This question was originally asked and later closed on StackOverflow. We stated in meta, that here is the right place for this question. This question is in favor to help to many people to ...
43
votes
9answers
44k views

Magento 1.9, php 5.6 - Use of iconv.internal_encoding is deprecated

Have the same with Magento CE 1.8 and 1.9 After update php from 5.5.16 to 5.6.0 on my VPS I got this 2 errors in [magento]/var/log/system.log: ERR (3): Deprecated functionality: iconv_set_encoding():...
43
votes
6answers
70k views

Magento upgrade from 1.7 to 1.9

I need to upgrade my Magento store from 1.7 to 1.9. I am very new to Magento, SSH and MySQL. I was just wondering what is the easiest way to upgrade without breaking my website.
38
votes
7answers
59k views

How to update Magento2 using composer

I can't seem to be able to update my magento2 ce using composer. I doesn't find any updates, the only one it found was 'fabpot'. I thought this was the whole point of a composer setup, so why would I ...
37
votes
1answer
14k views

Product.OptionsPrice is not a constructor magento 1.9.3

I have upgrade magento 1.9.2.4 to 1.9.3. I am facing the following error in the console in product page. TypeError: Product.OptionsPrice is not a constructor var optionsPrice = new Product....
33
votes
1answer
4k views

Why is Magento 2.1.0 released before 2.0.9?

Magento has released 2.1.0 on June 23 but has released 2.0.8 (July) and 2.0.9 (Aug) after that. (https://github.com/magento/magento2/releases) Why are they releasing lower versions? If anybody knows ...
29
votes
9answers
16k views

Future Support of Magento 1.9 - Coming Magento 2.0

We want to upgrade our current Magento 1.4.0.1 installation to 1.9.1.0 till autumn this year. The only thing we are unsure about is the future support of 1.9.1.0 since Magento 2.0 will be released end ...
27
votes
3answers
46k views

Error after magento upgrade

After firing this command in CLI php bin/magento setup:upgrade I am getting below error -: Fatal error: Uncaught exception 'Magento\Framework\Exception\LocalizedException' with message 'Can't ...
24
votes
9answers
36k views

How to update magento2 from 2.0.0 to 2.0.2

The docs here say that you should use the system upgrade utility: http://devdocs.magento.com/guides/v2.0/comp-mgr/upgrader/upgrade-start.html and do it from the admin. I thought that you would be ...
24
votes
4answers
3k views

what would be the official date of Magento 1 sunset?

Now we are in progress of Magento 2 upgrade. Some sources I read that early 2018 Magento 1 support will be closed. If we get the Magento 1 official close date, we can decide our due date of upgrade. ...
22
votes
5answers
9k views

What is the difference between magento 1.9.2.4 and magento 1.9.3.0?

Magento has released it's new community edition version 1.9.3.0. I am very curious to know what are the differences with previous Magento edition? I want to know full details about the what is the ...
22
votes
2answers
5k views

Install scripts: Creating tables vs. updating existing ones

have one question, recently I was developing one module with a lot of tables in DB, and concept was changing often, so was need to change existing tables in DB, and I noticed difference in table ...
20
votes
13answers
37k views

There are no commands defined in the “cache” namespace

Update Everything is working now but There are no commands defined in the "cache" namespace is still there. I tried chmod 777 -R var/generation, didn't fix a thing. AFAIK no module is enabled ...
15
votes
4answers
23k views

magento setup:upgrade error “deployment configuration is absent”

When I try to upgrade Magento 2 php bin/magento setup:upgrade I get I get [Magento\Setup\Exception] Can't run this operation: deployment configuration is absent. Run 'magento setup:...
15
votes
6answers
6k views

Invalid template file - Upgrade issue from 2.2.6 to 2.2.7 or 2.3

I have upgraded 2.2.6 version to 2.2.7 version but its showing below error in my website. 1 exception(s): Exception #0 (Magento\Framework\Exception\ValidatorException): Invalid template file: 'C:/...
13
votes
5answers
16k views

How to update Magento 2.1.7 to Magento 2.2 ? Is it possible to upgrade?

I wanted to know is it possible to update Magento from 2.1.7 to 2.2 ? Or what is a solution to update all Magento 2.1.7 stores to Magento 2.2 ? If we will update it then what are the challenges for ...
13
votes
6answers
11k views

Magento upgrade from 1.7 to 1.8 [duplicate]

I am upgrading magento from 1.7 to 1.8. This is the first time I am doing this. Can u tell me how to proceed on this. I had taken db backup using system->tools->backup. Should I take system backup ...
12
votes
8answers
14k views

Package fabpot/php-cs-fixer is abandoned message in Magento 2

I am using Magento 2.0.5. When I run the composer update or composer install command it's showing the following warning. Package fabpot/php-cs-fixer is abandoned, you should avoid using it. Use ...
12
votes
7answers
18k views

Fatal error: Call to a member function rewrite() on a non-object after upgrade

We tried to upgrade our Magento installation from 1.7.0.2 to 1.8.0.0. Now we got the following error on all pages: Fatal error: Call to a member function rewrite() on a non-object in /home/clientname/...
12
votes
7answers
15k views

Magento 2.2.1 Unable to serialize value

I have upgraded website from 2.1.6 to 2.2.1 and facing Unable to serialize value error in frontend and backend. {"0":"Unable to serialize value.","1":"#0 \/var\/www\/vhosts\/demo.com\/eiselec\/vendor\...
12
votes
3answers
2k views

Should I upgrade or patch Magento?

I am currently patching Magento with the latest patches and wondered whether it is worth applying the patches or upgrading to the latest version? As far as I can tell the only changes seem to be the ...
12
votes
1answer
948 views

Does the Magento Database Upgrade happen in a “transaction”?

We have this issue atm: A client gets his shop upgraded from CE 1.4 to CE 1.8. The file-upgrade went well, and the database upgrade went also well on our development machine. When we try to upgrade ...
11
votes
6answers
4k views

Migrate data from Magento 1 to Magento 2

Best way to Migrate data from Magento 1 to Magento 2. I found below tools provided by Magento and some third party but don't know exactly which one to follow and what is the best way. Magento tool: ...
11
votes
2answers
838 views

Magento 2: Upgrading a “Meta Package” Install

A while back, I installed Magento 2 via the composer meta-package. This is also known as the integrator install. This appears to have installed Magento CE 2.0.1. Is there a way to upgrade this ...
10
votes
2answers
8k views

Magento2 REST Update custom attributes

How can I update the custom attributes such as description? The following code properly update price and product name, but not custom attributes (unchanged). The new product is created properly with ...
10
votes
3answers
4k views

E-mail address missing in order

We have 2 stores (a 1.7.0.2 upgrade from 1.5.1 and a 1.6 install) that both have a problem that for some orders has a missing e-mail address (customer_email in sales_flat_order). The stores are two ...
9
votes
4answers
3k views

Cannot upgrade from 2.2.6 to 2.3 via composer

I have a clean Magento 2.2.6 with sample data that I installed using composer. I am trying to update it to Magento 2.3 so following the steps outlined here by the Magento team. After running ...
9
votes
1answer
4k views

ERROR: “/app/etc/” must exist for proper tool work magento 1.9

I am trying to install the newly release security patch for magento 1.9. I am working on window system. and I am getting the following error. D:\xampp\htdocs\magento>sh PATCH_SUPEE-1533_EE_1.13....
8
votes
3answers
15k views

Magento 1.9.2.2 Upgrade from Magento Downloader returned conflict error

What can be the reason for the following error when upgrading through Magento Connect Manager? I was upgrading from 1.9.2.1 to 1.9.2.2 Package community/Interface_Adminhtml_Default 1.9.2.2 conflicts ...
8
votes
6answers
5k views

How to check if Magento patch has been installed?

So I just installed recent critical patches SUPEE-5994 + SUPEE-5344 + SUPEE-1533 - through SSH on my server. I did the following steps for installing each patch: Downloaded the patches from: https://...
8
votes
6answers
10k views

Update is_required for Existing Attribute Code

I am thinking to update is_required data to "1" for existing "Region" attribute code. select * From eav_attribute where attribute_id = '28' However, I am wondering what is the practice here. Is it ...
8
votes
3answers
2k views

How to keep clients on Magento 1 given that end of life is in 11/2018

Magento will not release any new security patches from 11/2018 for Magento 1. Of course, there are a lot of small and not so small websites out there that are on Magento 1 that can't afford to move ...
8
votes
2answers
5k views

Can i use dataflow import to update products

I am really sorry for asking this. I feel like this is a stupid question, but honestly I have googled until the term googling has lost all meaning. I just want to do a bulk update of product ...
8
votes
2answers
2k views

How to perform automated regression testing for Magento upgrade

I see several questions related to testing a Magento website including "How to test Magento upgrade", which discusses manual testing. Are there any tools for automated regression testing of my ...
7
votes
3answers
20k views

MySQL error while importing database

I want to upgrade Magento. Therefor I first want to transfer the live production system to a development workspace. I am trying to import the production database into a clean database. But I can't get ...
7
votes
4answers
3k views

After upgrade from Magento 2.2.x to 2.3.x getting “No linked stock found” on multistore

We upgraded to 2.3.1 and get on product list pages of several stores an error: No linked stock found
7
votes
4answers
11k views

Magento Upgrade/Roadmap/Migration from 1.9 to 2.0

As we all know, Magento 2.0 is now available. Many of us are running an older version of Magento (atm). In my opinion, we need to build a roadmap to migrate Magento to the newest version. For older ...
7
votes
1answer
417 views

Magento 1.9.2.4 upgrade via downloader

We are upgrading Magento from 1.9.2.4 to Magento 1.9.3.4 through the downloader but downloader is not showing Upgrade Available. Please find the screenshot below: Please help us on this issue. ...
7
votes
2answers
694 views

setup:upgrade SQL error after update from 2.2.8 to 2.3.1

What could be the reason for this error on bin/magento setup:upgrade after updating from 2.2.8 to 2.3.1? SQLSTATE[42000]: Syntax error or access violation: 1061 Duplicate key name '...
7
votes
4answers
2k views

Upgrading compromised Magento from 1.7 to 1.9

I've been doing some research but there appears to be multiple solutions, and I want to get it right. I need to upgrade my Magento from 1.7.0.2 to the latest (1.9) being that our server was ...
7
votes
2answers
2k views

Add custom image upload attribute to product

I Have tried to add new image upload attribute to Magento Product using sql upgrade script, but I got the error message like: Invalid backend model specified: catalog/...
7
votes
4answers
794 views

Upgrading Magento 2.1.9 to Magento 2.2.2 is very slow

We are trying to upgrade a Magento 2.1.9 site to Magento 2.2.2 We have more than 130k products and the process seems to be stuck for more than 3 hours on, Upgrading data.. Module 'Magento_Backend': ...
6
votes
3answers
9k views

Magento 1.9.2.2 upgrade to 1.9.2.4 fails via Connect Manager

I am trying to upgrade all packages via Magento Connect Manager but keep getting the following: Checking dependencies of packages CONNECT ERROR: Package community/Phoenix_Moneybookers 1.9.2.4 ...
6
votes
4answers
12k views

Home page results in 404 after upgrade

We recently upgraded from 1.10 to 1.13 and are having some problems with our home page. All other cms pages are functioning properly, but the home page is consistently returning a cms 404. It doesn'...
6
votes
3answers
796 views

Upgrade magento 2.3.1 to 2.3.2

How to upgrade Magento 2.3.1 to Magento 2.3.2 ?
6
votes
1answer
2k views

I have problem when I update from 2.1.9 to 2.2.0

I'm trying to update magento2 from 2.1.9 to 2.2.0. But, I have got issue. What I did. composer require magento/product-community-edition 2.2.0 --no-update ./composer.json has been updated ...
6
votes
1answer
587 views

Does Magento 2's UpgradeSchema Pattern Handle non-contiguous Version Jumps

Magento 2 replaced Magento 1's Setup Upgrade scripts with a bin/magento setup:upgrade command. When a module's installed, this command looks for a InstallSchema and InstallData class in a module's ...
6
votes
1answer
19k views

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'db.design_config_grid_flat' doesn't exist

I just upgraded to Magento 2.1.3 and I'm getting the following error message when I go to the design configuration section: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'db....
6
votes
1answer
1k views

Install/Upgrade Scripts - Can they run multiple times when multiple users are hitting the site before they are done?

We have a couple of updates that we'd like to run by way of a module's upgrade script. One of them takes about 5 minutes to complete. The problem here that we are not sure about is that the site ...