Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [upgrade]

Questions related or caused by Magento upgrade process.

0
votes
1answer
26 views

Magento 2.3.1 upgrade Errors

I am trying to upgrade magento2.2.3 CE to 2.3.1CE on staging server (magemojo) After upgraded getting the below errors. Please can anyone face these below issues suggest me how to fix? 1.Unable to ...
4
votes
4answers
5k views

Why I'm having errors after install an update from 2.1.0 to 2.1.2 with composer?

Errors after installing update from 2.1.0 to 2.1.2 PHP Warning: require(/var/www/vendor/composer/../../app/etc/NonComposerComponentRegistration.php): failed to open stream: No such file or ...
0
votes
1answer
926 views

Magento 2.1 Upgrade Data Issue

Following directions from Magento Documentation for Command-line upgrade to Magento 2.1. Running into some errors when data is upgrading. Below are the errors i receive after running the upgrade ...
0
votes
1answer
595 views

Can't edit products after update to 2.1.4

I updated Magento to 2.1.4. Now, there are extension dependency issues when I tried to update the extensions. The more important issue is that I can't edit any products. The products are still on ...
4
votes
1answer
3k views

Magento 2 Check Component Dependency fail

I'm having problems upgrading Magento 2 (Current version 2.0.7). When I tried to upgrade I got the following error: Check Component Dependency We found conflicting component dependencies. Hide detail ...
2
votes
1answer
36 views

Upgrade to 2.3.1 from 2.2.7 fails on setup:upgrade

I am trying to upgrade a local copy of our site from 2.2.7 to 2.3.1 and have got through the composer cli pain and am now on the bin/magento setup:upgrade step. It gets all of the way to Running data ...
3
votes
1answer
2k views

Magento 2: System upgrade fails Readiness Check (always_populate_raw_post_data = 0)

I am trying to upgrade Magento 2.07 to 2.1. I pass all the checks apart from the one below: Your PHP Version is 5.6.22, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from ...
2
votes
1answer
39 views

Magento 2.3.1 - Cannot send email with attachment using template

This code was working before in M2.1 but it is not working anymore after upgrade as Zend1 is depricated. Can you please suggest how to fix this code. $transport = $this->_transportBuilder->...
2
votes
1answer
68 views

Magento 2.2.5 After Upgrade To 2.3 CLI commands don't work

I upgraded magento version by documentation, after upgrade this happens: When running php bin/magento cache:flush or any other bin/magento command error appears There are no commands defined in the "...
4
votes
1answer
1k views

Magento downloader upgrade conflict 1.9.2.0 > 1.9.2.2

I'm trying to update Magento from version 1.9.2.0 to 1.9.2.2. Unfortunately, there is a conflict error during installation/updating. For example when I try to upgrade a package I get the following ...
1
vote
0answers
25 views

Magento 2.3.1 update issue

We have recently updated magento from 2.2.3 to 2.3.1 using composer (with automated script), it went though fine but we get following error on indexing: Catalog Search indexer process unknown error:...
1
vote
4answers
2k views

Magento Backend pages not showing content properly after upgrade

We've just performed a manual upgrade from 1.8.1 to 1.9.2 and thought everything had gone alright. The frontend seems properly with pages and products and loading fine. But, the backend is messed up....
3
votes
1answer
51 views

After upgrade from Magento 2.2.x to 2.3.x getting “No linked stock found” on multistore

We upgraded to 2.3.1 and get on product list pages of several stores an error "no linked stock found"
1
vote
1answer
339 views

dependency error upgrading from 2.2.7 to 2.3.0

I have been trying to update my site to 2.3 and I am getting the error posted below when I use CLI with command composer update. I have also tried to use the online system upgrade tool and get the ...
97
votes
16answers
174k views

New order email confirmation not being sent

I have upgraded my website to 1.9.1 and now my customers are not receiving order confirmation email. I tried sending through the admin panel but nothing happens, also no update email is being ...
0
votes
0answers
11 views

Updating theme results in 500 error

I have magento 2.3.1, and I'm using the pearl theme. I tried to update the theme per their directions , but after doing that my site is down and all that I am getting is 500 errors. What can I do to ...
0
votes
1answer
25 views

Can't access admin after update Magento 2.3.1

I recently updated my Magento 2.3.0 to 2.3.1, and my site works, but I when I try to go to my admin url I get a 504 error. I have tried clearing my cache, and I tried following advice to clear the ...
0
votes
1answer
94 views

How upgrade magento 2 via composer to alternative version PHP

Alternate version php 7.0.24 - my site. Native version PHP 5.2.6 - my server. Composer doesn't want to update magento (it defined version PHP 5.2.6). How to specify for the script an alternative ...
3
votes
1answer
67 views

MsrpPriceCalculator exception after upgrade to 2.3.1

Preconditions (*) After performing an upgrade to the last magento version, I faced the following message: 1. 2.3.0 to 2.3.1 Steps to reproduce (*) Perform Magento upgrade from 2.3.0 to 2.3.1 ...
1
vote
1answer
31 views

Magento 2 upgrade 2.3

Currently trying to upgrade to the newest magento 2.3 using a script. https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html Whenever I type: php -f pre_composer_update_2.3.php -- --...
1
vote
0answers
20 views

Changing encryption key on Magento 2.3 | secret key size should be SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES bytes

Magento 2.3 has introduced a new encryption method and requires the encryption key to be 32 characters long / 32 bytes in size. If you run a setup:upgrade with a wrongly sized encryption key you will ...
0
votes
1answer
2k views

Magento Configurable Product Page Update Custom Dropdown With Attribute Value

So I have a configurable product which has a number of associated simple products. I am trying to obtain functionality on product page where the user can choose a colour for the product, and then ...
0
votes
1answer
587 views

Upgrading Magento 2.2.6 to 2.3.0: Component Dependency

Is there any way to upgrade from Magento 2.2.6 to 2.3 using the Web Setup Wizard? I'm getting the following error: Check Component Dependency We found conflicting component dependencies. Hide detail ...
2
votes
2answers
2k views

Failed to initialize storage module in magento

When I upgraded Magento 1.7 to Magento 1.8 500 internal errors started to come on the page. I have removed this by changing the permission of index files (644). But still I am facing an issue. 500 ...
2
votes
2answers
5k views

magento 2 how to update stock using import csv

I need to update my stock everyday in magento 2 but i dont know how it works. Do i have to import the same full stock with all columns of my stock.csv and set the qty,is in stock columns with new ...
3
votes
2answers
52 views

Updating Magento 1.9.3.9 to 1.9.4.1

I need to update my magento platform from 1.9.3.9 to 1.9.4.1. I know that is possible to do it with Magento connect but I see that it isn't safety. Are there any other ways to update Magento securely?...
1
vote
1answer
72 views

Magento 2 — 2.3.1 “Each method must have a doc block. See Magento\Eav\Api\AttributeSetRepositoryInterface::getList()”

We are installing several modules and receiving the message Each method must have a doc block. See Magento\Eav\Api\AttributeSetRepositoryInterface::getList() after the command php bin/magento setup:...
0
votes
2answers
358 views

Compile error in theme after updating to 2.1.8

I have just updated from 2.1.7 to 2.1.8 but when I run: php bin/magento setup:di:compile I get an erroe which is: [Exception] Warning: Declaration of Plazathemes\Override\Controller\...
14
votes
11answers
28k views

There are no commands defined in the “cache” namespace

Update Everything is working now but There are no commands defined in the "cache" namespace is still there. I tried chmod 777 -R var/generation, didn't fix a thing. AFAIK no module is enabled ...
0
votes
1answer
66 views

Set a value for DATA_CONVERTER_BATCH_SIZE — not a valid id

I am trying to update my Magento 2.3 instance to 2.3.1. So I'm trying to finish the update and upgrade checklist, but when I get to the step: Set a value for DATA_CONVERTER_BATCH_SIZE, I copied ...
2
votes
1answer
45 views

How to solve upgrading Magento 2.1.1 to Magento 2.1.17?

I am faced issue when I upgrade Magento 2.1.1 to Magento 2.1.17 I changed some values in composer.json "magento/product-community-edition": "2.1.1", =>"magento/product-community-edition": "2.1.17"...
0
votes
3answers
592 views
2
votes
1answer
463 views

Magento 2.2.6 Cannot create a symlink for… after Update

I update my magento webstore to 2.2.6 using following guide: https://devdocs.magento.com/guides/v2.0/comp-mgr/cli/cli-upgrade.html Not everything seems to be fine. I have some css files that do not ...
1
vote
2answers
2k views

How to update Magento 2.2.5 to Magento 2.3.1? possible issues?

I wanted to know is it possible to update Magento from 2.2.5 to 2.3.1? Or what is a solution to update all Magento 2.2.5 stores to Magento 2.3.1? If we will update it then what are the challenges for ...
5
votes
1answer
3k views

Magento 2.2.0 - Upgrade / Migrate from Magento 2.1.9 to Magento 2.2.0 with Sample Data

Followed below commands to upgrade Magento 2.1.9 to 2.2.0 using terminal 1. composer require magento/product-community-edition 2.2.0 --no-update 2. composer require \ magento/module-bundle-...
2
votes
2answers
646 views

Column not found: 1054 Unknown column 'at_status_default.value'

I'm actually kind of desperate.I tried many times to update my Community Edition from 2.2.1 to 2.2.5, always failing due to what I guess is a database inconsistency.After the update procedure - done ...
1
vote
1answer
1k views

Magento upgrade to 1.9.3.4 - is forms working without form_key output in templates

I've just upgraded to Magento v1.9.3.4 and have Enabled Form Key Validation On Checkout as recommended. Magento also advices: Important! Enabling this option means that your custom templates used ...
0
votes
1answer
333 views

Check Component Dependency, no obvious error

I am creating a test environment for magento, hoping that I can replicate later for some work on it, and have come up an issue on Check Component Dependency. the base config is as followed: Specs ...
12
votes
4answers
17k views

magento setup:upgrade error “deployment configuration is absent”

When I try to upgrade Magento 2 php bin/magento setup:upgrade I get I get [Magento\Setup\Exception] Can't run this operation: deployment configuration is absent. Run 'magento setup:...
2
votes
1answer
50 views

how to fix error occurred during upgrade magento from 2.2 to 2.3?

Process : Upgrade Magento version from 2.2 to 2.3 As per my client requirement, I tried to upgrade Magento from 2.2 to 2.3 as mentioned in this URL: https://devdocs.magento.com/guides/v2.3/comp-mgr/...
0
votes
1answer
32 views

Magnto 2 update the cart custom option value

Currently am using magento 2.2.5, while adding the product to the cart the custom options values are stored in the quote_item_option table correctly. while updating the custom options ...
0
votes
0answers
12 views

Magento 2 Update Cronjob Status is giving error readiness_checks failed auth.json.sample

Magento 2 Update Cronjob Status is giving an error readiness_checks failed for file auth.json.sample as "file_permissions_verified": false Is this something to worry about? Or should we just restore ...
1
vote
2answers
29 views

Move category description from admin panel (Layout Update XML) in Magento 2

Our customer wanted to show category description after the product list by default, so we added a new container and the following line to the default.xml in out theme: <move element="category....
2
votes
0answers
32 views

Fatal error: Call to a member function setData() on boolean in /app/code/core/Mage/Eav/Model/Config.php on line 651

Combined a Magento 1.9.0. database with a Magento 1.9.4.1. basic installation and get this error: Fatal error: Call to a member function setData() on boolean in /app/code/core/Mage/Eav/Model/Config....
3
votes
2answers
810 views

Magento 2.3 — Invalid Form Key. Please refresh the page

Getting Invalid Form Key. Please refresh the page error not able to do any action after upgrade of Magento 2.2.5 to Magento 2.3.
2
votes
2answers
26 views

How to uninstall an update?

I tried to update magento 2.3 to magento 2.3.1, but it failed. I tried to backup from my server and that failed too. How do I roll back the changes to get it to back to 2.3? I followed the steps ...
0
votes
0answers
11 views

Display conflicting component dependencies

I have a magento 2.3 instance and I'm trying to update it to 2.3.1, and I have the error: Check Component Dependency We found conflicting component dependencies. How do I find out what the ...
0
votes
1answer
151 views

How to update magento 2.3.0 to 2.3.1 in cloud

Magento just released new versions of Magento Commerce and Open Source to increase product security, performance, and functionality. One of it is the Magento Commerce and Open Source 2.3.1. My ...
0
votes
2answers
100 views

Error when upgrading from magento 2.2.5 to magento 2.2.8

When upgrading Magento version 2.2.5 to version 2.2.8 it throws the following error Problem 1 - Can only install one of: temando/module-shipping-m2[1.3.10, 1.3.7]. - Can only install one of: temando/...
0
votes
1answer
557 views

Magento 1.9.3 - “Warning: strpos() expects parameter 1 to be string” warnings

I'm seeing a lot of the following warnings after upgrading to 1.9.3.1 in the system.log: "Warning: strpos() expects parameter 1 to be string, array given in ../app/code/core/Mage/Eav/Model/Entity/...