We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [upgrade]

Questions related or caused by Magento upgrade process.

Filter by
Sorted by
Tagged with
2
votes
0answers
16 views

Linking Magento 2.3.2 to an SQL DB?

Hoping for some help - its my first post here! I am looking to link my newly created Magento website (using v2.3.2) to an Microsoft SQL server database. Would anyone be able to reccomend the best ...
100
votes
16answers
178k views

New order email confirmation not being sent

I have upgraded my website to 1.9.1 and now my customers are not receiving order confirmation email. I tried sending through the admin panel but nothing happens, also no update email is being ...
0
votes
0answers
26 views

Magento 2.3.0 > 2.3.3 update

I'm getting error messages when trying to update my magento installation via the admin panel. When I log on to my server and give the command crontab -l the only 1 listed is MAILTO="". The magento ...
0
votes
0answers
25 views

Magento setup upgrade Break

I am running setup upgrade. But, I'm getting the below error in Magento2.3.3 version. Fatal error: Uncaught TypeError: Argument 3 passed to Magento\Framework\Setup\Declaration\Schema\Declaration\...
0
votes
0answers
18 views

Module Upgrade Issue

I have created db schema and also write the code for upgrade schema. Also changed the version in module.xml file. After that i am running this comman "php bin/magento setup:upgrade" and running cache ...
0
votes
1answer
661 views

Magento connect not showing available update

We have a client with an old Magento version 1.7.0.0 we wanted to upgrade this version to the latest version. So what we did is made a copy to a our test environment, used Magento connect manager and ...
0
votes
2answers
736 views

Can't upgrade to 2.2.3 from 2.2.2. Memory limit reached

I'm trying to upgrade my Magento installation but experiencing problems with the process: I was trying to update my site to the latest release as advised and I did so via the command line but I ran ...
0
votes
1answer
24 views

How to solve “The stock item was unable to be saved”?

I was using the Magento 2.3.2 normally, but since I updated to Magento 2.3.3 I'm not able to create a new product anymore. I'm receiving this message below. The stock item was unable to be saved. ...
0
votes
1answer
17 views

Magento2: issues after composer update with store ID

I updated all modules: composer update But after update I try add product to the basket and after "Go to checkout" return issue: 1 exception(s): Exception #0 (Magento\Framework\Exception\...
1
vote
2answers
212 views

After updating from 2.3.1 to 2.3.2, unable to export products

After updating from version 2.3.1 to 2.3.2 community edition, I can not export products. The usual method - system - export, select entity type products, CSV format, fields enclosure checked, gives ...
4
votes
3answers
3k views

Magento 2.3 — Invalid Form Key. Please refresh the page

Getting Invalid Form Key. Please refresh the page error not able to do any action after upgrade of Magento 2.2.5 to Magento 2.3.
2
votes
2answers
97 views

How to downgrade Magento 2.3.3 to Magento 2.3.1 or 2.3.2

I have upgraded my Magento from 2.2.7 to 2.3.3. But now, my Magento has so many issues. Is there any way to downgrade Magento 2.3.3 to 2.3.1 or 2.3.2?
0
votes
1answer
50 views

Magento 2.3 Upgrade magento inventory MSI

I've got a store that is suffering performance issues. And I've been able to pinpoint this to MSI. I started to seriously look at this today. How do you upgrade MSI on Magento 2.3? I've read help ...
0
votes
3answers
728 views

Magento2 CLI won't run locally

I can run php bin/magento on my remote server, but locally, when i attempt to run it, I get the following errors: D:\Magento2>php bin/magento PHP Fatal error: Cannot instantiate interface Magento\...
1
vote
2answers
40 views

How to update themes in magento 2.3.2

Currently my site is using porto 3.1.7 theme. I want to upgrade the theme to 3.2.0. My version is Magento 2.3.0. How can I upgrade the theme. Is there something I need to take care of ? Will it affect ...
0
votes
0answers
32 views

Magento 2: issue with update module | PHP Version

I want to update the payment module Dotpay to 1.0.15 - require PHP Version 7.1+ So I run command with PHP 7.1: composer71 require dotpay/magento2-payment:1.0.15 But during update I received issue: ...
0
votes
1answer
43 views

Products are not visible after update 2.2.8 -> 2.3.3 (CE)

After update the category view won't show any products: "we can't find products matching the selection" Some products will show up if I filter the results enough, but usually none will show up. I ...
1
vote
2answers
55 views

Magento Update to 2.3.3 backend after login Specified invalid parent id Magento_Analytics

i have a problem while upgrading Magento from 2.3.2 to 2.3.3. The update works fine and i have all done which mentioned here: https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html ...
4
votes
1answer
3k views

Magento 2 Check Component Dependency fail

I'm having problems upgrading Magento 2 (Current version 2.0.7). When I tried to upgrade I got the following error: Check Component Dependency We found conflicting component dependencies. Hide detail ...
3
votes
2answers
2k views

Could not find a matching version of package magento/product-community-edition

I am working on the upgrade process of Magento from version 2.1.9 to 2.2.6. When I run the below command: composer require magento/product-community-edition 2.2.6 --no-update I got below error: ...
0
votes
1answer
39 views

After upgrade to 2.3.3, got SQLSTATE[23000]: Integrity constraint violation: 1022 when trying to run bin/magento setup:upgrade

I just upgrade to Magento 2.3.3 from Magento 2.2.9 following these steps (https://magento.stackexchange.com/questions/251778/how-to-upgrade-magento-version-from-2-2-x-to-2-3-0). However, at the step ...
0
votes
2answers
112 views

Magnto 2 update the cart custom option value

Currently am using magento 2.2.5, while adding the product to the cart the custom options values are stored in the quote_item_option table correctly. while updating the custom options ...
0
votes
2answers
46 views

Unique constraint violation found after upgrading to Magento 2.3.3

I just recently upgraded from Magento 2.3 to Magento 2.3.3 and whenever I'm trying to run php bin/magento setup:upgrade SSH command it just stick on Unique constraint violation found. Any idea how do ...
0
votes
2answers
258 views

In Checkout while Magento upgrade to 2.3.1 Exception #0 (InvalidArgumentException): Unable to serialize value

Getting below issue at checkout step after upgrade of magento to 2.3.1 from 2.1.8. 1 exception(s): Exception #0 (InvalidArgumentException): Unable to serialize value. Exception #0 (...
1
vote
3answers
66 views

Magento 2.3: After install Magento by CLI not work upgrade command

After Install Magento2.3 by cli and when try upgrade command getting below Error: php bin/magento setup:upgrade The directory "generated/code/Magento/Backend/App/Request" cannot be deleted Warning!...
8
votes
3answers
2k views

How to keep clients on Magento 1 given that end of life is in 11/2018

Magento will not release any new security patches from 11/2018 for Magento 1. Of course, there are a lot of small and not so small websites out there that are on Magento 1 that can't afford to move ...
0
votes
1answer
22 views

File exists but 404 for jquery-ui-1.9.3.2.js only one file

I upgraded magento 2.3.2 from 2.3.0. And getting this error in admin panel. GET https:///pub/static/adminhtml/Magento/backend/nl_NL/jquery/jquery-ui-1.9.2.js net::ERR_ABORTED 404 (Not Found). I ...
0
votes
1answer
802 views

Base tables already exist

Hi guys I have been trying hard to upgrade a magento 1.3.2.4 to magento 1.7 but it is not playing ball: it keeps saying that the base tables already exists. In particular these are: index_event, ...
7
votes
2answers
442 views

setup:upgrade SQL error after update from 2.2.8 to 2.3.1

What could be the reason for this error on bin/magento setup:upgrade after updating from 2.2.8 to 2.3.1? SQLSTATE[42000]: Syntax error or access violation: 1061 Duplicate key name '...
1
vote
0answers
25 views

Upgrading Magento and missing files

If I do the following php bin/magento maintenance:enable composer require magento/product-community-edition 2.3.3 --no-update composer update rm -rf var/di var/generation php bin/magento cache:flush ...
1
vote
1answer
61 views

Upgrading 2.2.8 to 2.3.3

If you are upgrading from 2.2.8 to 2.3.3 would it be advisable to start a fresh eg composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition myproject and ...
2
votes
5answers
2k views

Magento Backend pages not showing content properly after upgrade

We've just performed a manual upgrade from 1.8.1 to 1.9.2 and thought everything had gone alright. The frontend seems properly with pages and products and loading fine. But, the backend is messed up....
0
votes
0answers
31 views

Upgrade magento version 2.3.2 successfully upgraded but still magento old version 2.1.1 is running

I am using Magento 2.1.1 version in my website. Now, I want to upgrade Magetno 2.3.2. I upgraded successfully but still my website running in old version (Magento 2.1.1). Upgrade version doesn’t ...
0
votes
1answer
27 views

upgrade magento community edition to latest version

Today we receive an email from Magento company pointing that customers with magento commerce 2.2.x must upgrade their product version from 2.2.x to 2.3 because there will not be supported no longer. ...
1
vote
1answer
871 views

Changed PHP 5.6 to PHP 7 with Magento 1.9

I changed the version of PHP [5.6.30] to PHP [7.0.17]. But now Magento 1.9.2.1 returns the following error: SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client I ...
0
votes
3answers
96 views

Magento 2 upgrade 2.1.7 to 2.3.2 give error Foreign key constraint is incorrectly formed modify column customer_group_id in table of customer_group

Can anyone please explain about this type of error Like http://prntscr.com/oow1oz Also, I refer to this link Magento 2 failed database rollback cannot add foreign key constraints but not working for ...
1
vote
0answers
174 views

Admin Error after Update: Specified invalid parent id (Magento_Analytics::business_intelligence)

After upgrading from 2.1.17 to 2.1.18, I'm receiving this error when accessing the admin panel: Specified invalid parent id (Magento_Analytics::business_intelligence)";i:1;s:3699:"<pre>#1 ...
1
vote
2answers
33 views

disable or remove foreign keys during upgrade

During upgrade from v1.5.1.0 to v1.6.0 it is trying to drop a key but can't because of a foreign key. relevant lines in update script $installer->getConnection()->dropIndex( $installer->...
0
votes
0answers
10 views

BSS MultipleStoreViewPricing enbled error

we have a problem after install BSS MultipleStoreViewPricing module ,we trying to enable the extension Stores then Configuration then Catalog.Store View to enable the module. Save Config the problem ...
2
votes
2answers
865 views

Update Minicart programatically in magento 2

I have create problematically adding number of products at a time in Magento 2 cart and there I can one see one first product in mini cart other products are also in mini-cart but not showing the ...
0
votes
0answers
15 views

BSS MultipleStoreViewPricing error [duplicate]

Dears, I have a problem in Magento 2.3.2 . - BSS MultipleStoreViewPricing Module It shows error I run the below command php bin/magento setup:upgrade Please check attached screenshot of error enter ...
1
vote
2answers
980 views

Dashboard graph showing orders, but no amount

We just migrated our webshop to a new domain. Now, whenever an order is placed, the order does show up in the admin dashboard graph as order, but doesn't show op in the amounts tab. Also revenue is ...
3
votes
2answers
100 views

Magento 2 Backend fails when using CLI “setup:upgrade”

When I try to use the following command in CLI: php bin/magento setup:upgrade The entire Admin part of my Magento 2 site stops working and only shows a white page with the following error: 1 ...
1
vote
0answers
721 views

Can't update products qty in cart Magento 2

I have some trouble with updating products quantity in cart. When I change qty in the mini cart and click update, nothing happened. I saw a similar problem in Magento 1.9 and there were answers to ...
1
vote
1answer
1k views

Magento upgrade to 1.9.3.4 - is forms working without form_key output in templates

I've just upgraded to Magento v1.9.3.4 and have Enabled Form Key Validation On Checkout as recommended. Magento also advices: Important! Enabling this option means that your custom templates used ...
5
votes
2answers
76 views

Upgrade Magento2

Currently i have a Magento ver 2.2.8 now I want to upgrade my Magento version to Magento ver. 2.3.2 so I want to know about what will be the best approach to achieve this smoothly.
0
votes
1answer
33 views

Magento 2 Uninstall or update Authorize.net module

I wan't to know how can I uninstall Authorize.net module from Magento 2.2.7 without affecting other modules, because as far as I know it's a core module. The reason I want to do this is because ...
2
votes
2answers
211 views

Magento 2 Readiness check error

I am getting the following error on the readiness check step: We found conflicting component dependencies. Command "update" failed: Loading composer repositories with package information ...
0
votes
1answer
120 views

Type Error occurred when creating Interceptor after Updating to 2.3.2

After updating Magento from 2.1.6 to 2.3.2 and PHP from 5.6.30 to 7.2.20, now running into errors on page load. Have a module called Inquiry, which consists of forms to request things, and there is a ...
-1
votes
3answers
59 views

Upgrade Magento 2.3.0 to 2.3.2

I want to upgrade my Magento store from 2.3.0 to 2.3.2. I am doing the upgrade thing for the first time. Can anyone please guide me.