Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [semantic-versioning]

The tag has no usage guidance.

4
votes
0answers
75 views

Module version in composer.json

I'm running the static tests on one of my modules and on magento version 2.3 it reports an inconsistency: Version must not be specified in the root and package composer JSON files in Git Failed ...
0
votes
1answer
249 views

why is Magento 2 semantic versioning at 100?

I am using Composer to install Magento 2 and I've noticed that all packages are starting with 100. According to semantic versioning rules, Magento 2 packages should be at version 2.x.x something. ...
3
votes
1answer
78 views

Magento 2 Marketplace and Semantic Versioning

For folks who've purchased and downloaded extensions from Magento Marketplace, are the module's there using semantic versioning? i.e. -- do the third party modules have a require section in their ...
32
votes
1answer
4k views

Why is Magento 2.1.0 released before 2.0.9?

Magento has released 2.1.0 on June 23 but has released 2.0.8 (July) and 2.0.9 (Aug) after that. (https://github.com/magento/magento2/releases) Why are they releasing lower versions? If anybody knows ...
10
votes
2answers
357 views

Magento 2: How to Specify “Semantic Versioning” Dependencies in my Module's composer.json

Magento 2's development and deployment includes a formal process for versioning, where major and minor versions of core Magento modules will be bumped up based on changes in backwards compatible ...
22
votes
11answers
14k views

How to get Magento version in Magento2 ? (Equivalent of Mage::getVersion())

How do I get the Magento version in Magento2.x (e.g. 2.0.0) ? In Magento1.x, I could do it with Mage::getVersion() So what's the equivalent in Magento2.x ?