2022 Developer Survey is open! Take survey.

Questions tagged [php-7.3]

Marks questions related to Magento on php 7.3

Filter by
Sorted by
Tagged with
0 votes
0 answers
13 views

Magento 1.9.4.2: upgrade Debian from 9 to 10

I own an installation of Magento 1.9.4.2 which is running on Debian 9 with PHP 7.0. Can I upgrade Debian from 9 to 10 which it will run PHP 7.3?
user avatar
  • 115
0 votes
1 answer
38 views

How to get product list by multiple categories with multiple SKUs in Magento 2.3.5

I'm trying to get product collection by Multiple Category Ids with Multiple SKUs. The result has been coming wrong. I can't understand where I'm wrong. The code is given below <?php namespace ...
user avatar
0 votes
0 answers
10 views

How to fire multiple page requests on server at the same time for a Magento 2 website

Can anyone please suggest to me how can I fire multiple page requests approx 50,000+ requests/second at the same time on a Magento 2 website to check for the server storage and request handler? Is ...
user avatar
0 votes
0 answers
166 views

After upgrading PHP 7.2 to 7.3 php command line not working. bin/magento must be run as a cli application error

After upgrading the hosting plan, php version migrated from 7.2 to 7.3 (server no longer supports 7.2) and I can't run the php commands any more. I have tried all the top 10 solutions on Google to fix ...
user avatar
0 votes
1 answer
247 views

Magento 2.3.7 upgrade cron error

I've recently upgraded from Magento 2.3.6-p1 to 2.3.7. Front end and everything works great (and on PHP7.3), but the following cron fails: /usr/bin/php7.x /path/to/magento/bin/magento setup:cron:run &...
user avatar
0 votes
1 answer
403 views

__autoload() is deprecated, use spl_autoload_register() instead in app/code/core/Mage/Core/functions.php on line 61

In Magento 1.9.3.x..we have upgrade php version from 5.6 to 7.3.after that we are facing issue like Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in app/code/core/Mage/...
user avatar
0 votes
1 answer
30 views

Magento 2 SSH reindexing not working? [duplicate]

I just installed a Magento 2.3.6 version. and I tried to run the Command Reindexing but it's not working. I tried with diff commands like cache clear and flush none of the commands are not working ...
user avatar
0 votes
1 answer
40 views

Magento 2 SSH CLI reindexing not working

I just installed a Magento 2.3.6 version. and I tried to run the Command Reindexing but it's not working. I tried with diff commands like cache clear and flush none of the commands are not working ...
user avatar
0 votes
1 answer
68 views

How to make function run even if getUsername() is null

How can I make this function run - also when getUsername() is null $authSession = $objectManager->get('Magento\Backend\Model\Auth\Session'); $UUsername = $authSession->getUser()->getUsername()...
user avatar
1 vote
0 answers
276 views

ElasticSearch Error on Re-index

Every time I run the indexer - elastic search fails and the catalog search is never indexed. I am on Magento 2.4 CE with PHP7.3 Catalog Search index PHP Fatal error: Uncaught Error: Wrong parameters ...
user avatar
  • 123
0 votes
1 answer
177 views

Magento 2.4 - AdapterFactory Error

I have PHP 7.3.24 installed, After upgrading to Magento 2.4.1 I am getting the following error - I have upgraded the MagePlaza extensions. {"0":"Missing required argument $adapters of ...
user avatar
  • 123
3 votes
4 answers
3k views

Type Error occurred when creating object: Magento\Framework\Session\Generic\Interceptor, setcookie() expects parameter 3 to be integer, array given

After clear/setting/configuring so many errors & configurations installed the Magento V2.4.1 successfully, now getting below errors. Type Error occurred when creating object: Magento\Framework\...
user avatar
  • 3,886
0 votes
1 answer
45 views

Magento 2.3.2 version upgrade to 2.4.0

I am afraid of upgrading my magento version because my store is all setup. My php version is 7.3.20 and I thinking of upgrading to magento version 2.4.0 composer require magento/product-community-...
user avatar
0 votes
0 answers
135 views

Magento2 Unable to send mail: Unknown error, on php 7.2.3

I've created a custom email functionality. It's working fine on the PHP 7.2.2 version server. But it's not working on a PHP 7.2.3 server. Case 1 Magento Version: 2.3.3 Php version: 7.2.2 Result: ...
user avatar
  • 81
0 votes
2 answers
30 views

How to setup and configure perfect webserver on centos for magento2

I want to Build a new AWS EC2 centos webserver with the best configuration for Magento2 ? there is any clear steps or script? Regards, Ahmed
user avatar
0 votes
1 answer
386 views

Call to a member function setMessageType() on null

Using Ultimate Followup Email extension for Magento 2 but throws me an error when cron is trying to send out emails: main.CRITICAL: Error when running a cron job {"exception":"[object] ( ...
user avatar
  • 3
0 votes
1 answer
369 views

Multistore magento error: Call to a member function getDefaultCurrencyCode()

I have a running version of magento 2.3, php 7.3 and nginx. The default store and another store work fine and are displayed correctly. Whenever i try to use a different store code other than the 2 ...
user avatar
  • 1
0 votes
0 answers
16 views

magento2.3.4 installation page showing blank white color

i am trying to install magento 2.3.4 with php 7.3.16 but the installation page is showing blank white color.
user avatar
5 votes
6 answers
9k views

Problems with friendsofphp/php-cs-fixer and php7.3

Hello to all users of the forum, I need help. I upgraded from version 2.3.2-p2 to 2.3.4 and after that the error is occurring: composer update Do not run Composer as root/super user! See https://...
user avatar
3 votes
3 answers
10k views

Uncaught Error: Call to undefined method - Magento 2.3.3

I tried find a solution to this magento 2 theme problem. How should be edit the theme file? PHP Fatal error: Uncaught Error: Call to undefined method Magento\CatalogSearch\Model\ResourceModel\...
user avatar
  • 431
5 votes
2 answers
3k views

Magento 2.3.3 Class argument is invalid issue

I have "mass change attribute set" extension with Magento 2.3.3. All works with Magento 2.3.2 but now is issue with magento 2.3.3. How i can fix this error? Class argument is invalid: ...
user avatar
  • 431
0 votes
2 answers
2k views

Magento 2 CSS inlining error

Getting following error in magento 2 email. CSS inlining error: Warning: DOMXPath::query(): Invalid expression in /home/patios/public_html/vendor/pelago/emogrifier/Classes/Emogrifier.php on line 294 ...
user avatar
  • 439