Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [patches]

Questions about the official Magento Security patches (SUPEE-xxxx)

0
votes
0answers
92 views

Magento 2 Finding the applied Patches list

I applied the composer patch for Magento 2.1.15 using the command patch –p0 < PRODSECBUG-2198-2.1-CE.composer.patch It got applied without any errors, but the patch.applied.list file in app/etc ...
1
vote
0answers
15 views

Does Magento 2 have an app/etc/applied.patches.list file like Magento 1

Apologies if this is a duplicate. Searched SO and couldn't see that this has been asked before. In Magento 1 you have a app/etc/applied.patches.list file which is updated when applying security ...
0
votes
0answers
20 views

Magento 2 recommended approach to applying patches

So far had to apply patches through command line. Bugs me there is not version control for this as in some cases changing vendor folder contents which is ignored. More for accountability with time and ...
1
vote
1answer
20 views

Patch SUPEE 11086 Hunk #1 FAILED at 144

I want to apply the patch SUPEE 11086 on magento 1.7 store but it gives me the following error: Checking if patch can be applied/reverted successfully... ERROR: Patch can't be applied/reverted ...
1
vote
1answer
31 views
1
vote
2answers
1k views

How to apply patches for Magento 1.x in Windows?

I don't know how to update patches for magento. I tried cygwin in Windows but without success: Can anybody help me to solve these problems?
15
votes
14answers
5k views

SUPEE-10975 Potential Issues

SUPEE-10975 has been released, it would be great to know if anyone runs into any issues while trying to apply this, will this conflict with the most recent patch that adds 7.2 support? So far these ...
0
votes
2answers
377 views

SUPEE-10266 HUNK Failed [closed]

How can I solve this error: # bash PATCH_SUPEE-10266_CE_1.9.1.0_v1-2017-09-13-06-34-33.sh Checking if patch can be applied/reverted successfully... ERROR: Patch can't be applied/reverted ...
0
votes
2answers
39 views

SUPEE-11086 Patch for Magento CE 1.9.3.9

as my question says, I need to know if there is the released of Magento Patch SUPEE-11086 for M1 versione 1.9.3.9.
1
vote
1answer
30 views

Patch PRODSECBUG-2198 for Magento Enterprise Cloud

it has been some time after my last experience with Magento 2 and I've been asked to install a security patch, as in the title. My problem is due to the fact that I've never used a cloud ...
24
votes
17answers
4k views

Security Patch SUPEE-11086 - Possible issues?

Magento has released a new security patch for M1, and updates for M1 and M2. These releases include critical security fixes. "We strongly recommend that all merchants upgrade as soon as possible." ...
0
votes
1answer
83 views

Want to install SUPEE-11086 patch for magento 1.9.2.0 version

I want to install SUPEE-11086 patch Magento 1.9.2.0 version. Does anyone have an idea about this?
4
votes
1answer
1k views

magento:Fatal error: Call to a member function getMethodInstance() on boolean in /var/www/html/rmcstore/app/code/core/Mage/Sales/Model/Order.php

I installed magento patches(7405,8788,6788) to site,after that when clicking on admin sales > order >view getting error like Fatal error: Call to a member function getMethodInstance() on boolean ...
3
votes
3answers
208 views

Can Patch SUPEE-8167 be installed on older Magento 1.9 version?

I am on an older version of Magento. Can the patch still be applied even on an old version or does it need to be on 1.9? Thank you for you help.
1
vote
0answers
15 views

M2 Patch getDependencies

In patch which implements DataPatchInterface there is a method "getDependencies()" which seems to be used if one patch need to be played before current one. But problem is if required patch define in ...
2
votes
2answers
369 views

Magento 1.9.2.3 and SUPEE 7405

I upgraded from Magento 1.9.2.2 to 1.9.2.3, can you tell me if should I install also the SUPEE 7405 or it isn't necessary? How can I know if my site is vulnerable?
1
vote
1answer
75 views

Magento 1.9.2.0 problem with patch SUPEE-11086

I have been having the below error when I try to patch my Magento store 1.9.2.0 patching file app/code/core/Mage/Cms/etc/config.xml Hunk #1 FAILED at 190. 1 out of 1 hunk FAILED -- saving rejects to ...
2
votes
1answer
67 views

magento2 apply patch prodsecbug issue found

seems simple enough to aplly prodsecbug patch but I get this ... public_html$ bash PRODSECBUG-2198-2.2-CE.composer-2019-03-27-06-12-19.patch diff: unrecognized option '--git' diff: Try 'diff --help' ...
1
vote
1answer
65 views

Patch SUPEE-10975 can't be installed successfully

I have a Magento 1.9.2.4 instance and I am trying to install patch SUPEE-10975 so that I can install patch SUPEE-11086. When I try to install, I get the following message: Checking if patch can be ...
7
votes
5answers
8k views

How to apply the Magento 2 patches?

I'm using the Magento 2.1.6 and I want to apply the patch CE-MAGETWO-67805.patch. How can I apply the *.patch files?
0
votes
1answer
80 views

which dedicated patch file to Install patch SUPEE-11086 for Magento 1.14.2.0 EE

I know how to install a patch file. But which dedicated patch file to Install patch SUPEE-11086 for Magento 1.14.2.0 EE. Does anyone know which is the patch I should apply for 1.14.2.0 EE?
1
vote
1answer
444 views

SUPEE-11086 Missing patches for magento versions

I don't see a patch for 1.9.0.1 is this an error by the magento team or is it not supported?
14
votes
15answers
8k views

Security Patch SUPEE-10752 - Possible issues?

A new security patch is out for Magento 1, addressing 25 APPSEC issues https://magento.com/security/patches/supee-10752 What common issues do you have to watch out for when applying this patch? ...
0
votes
2answers
48 views

Issue while applying Patch

I am trying to install Magento 2.2 patch on my site. Showing error like this. root@server www/html# patch -p1 < PRODSECBUG-2198-2.2-CE-2019-03-25-08-43-16.patch -bash: patch: command not found ...
1
vote
1answer
191 views

PRODSECBUG-2198 - Installation Steps

I am having a Magento 2.2.6 site. I want to install PRODSECBUG-2198 patch. Little bit confusing with the flow. Can anyone guide me? Magento Decribed the Patch like this: This patch provides ...
3
votes
2answers
68 views

Magento 2.3: How Magento knows that a certain patch is already executed while it didn't use any versioning?

As Magento introduces patches instead of upgrade data and upgrade schema. In earlier version of Magento upgrade data and upgrade schema works by versioning but in Magento 2.3 it only executed the one ...
0
votes
0answers
18 views

Magento1 website Security patch installation by script then error show

Magento1 website Security patch installation by script and when run url in browser (like http://www.mywebsite.com/applypatch.php)then below error show: ERROR: "/app/etc/" must exist for proper ...
2
votes
1answer
150 views

Install patch SUPEE-11086

Magento has just released the patch SUPEE-11086 i am using Magento Version 1.9.2.2 I have scan my site in https://magereport.com it is not showing the SUPEE-11086 patch details. i have also checked ...
0
votes
1answer
25 views

Magento1 website Security patch installation by script

Magento1 my website i have installing following Security patch: Security patch 10975 Security patch 10415 Security patch 9767 Security patch 8788 Security patch 7405 but i want script in my root ...
0
votes
1answer
59 views

Magento 1.9 Patch MPERF-10509 - Invalid HTTP response version

We're on Magento 1.9.2.4 CE and applied patch MPERF-10509-CE. In the admin dashboard, the dashboard sales chart is broken and returning a 503 error in console. Magento error report shows: a:5:{i:0;s:...
1
vote
0answers
119 views

I Have Install this (SUPEE 11086 ) Patch in Magento 1.9.0.4 but Data.php is not working?

I have Install SUPEE 11086 Patch install successfully but not work Properly in backed side? Thanks.
0
votes
2answers
277 views

Patch SUPEE 11086

My Magento version is 1.9.2.2 Which file should I choose between the below given options? PATCH_SUPEE-11086_CE_1.9.1.0_v1-2019-03-26-03-03-13 PATCH_SUPEE-11086_CE_1.9.2.4_v1-2019-03-26-03-03-...
2
votes
2answers
150 views

Failed Magento SUPEE 6482 Security Check (APPSEC-1030) with Version 1.9.3.7 CE

The new Magento Security Scanner reports that there are vulnerabilities on the website and that patch SUPEE 6482 is required. This occurs even when there are no Modules enabled. However, we are ...
0
votes
1answer
52 views

How to install git patch of Authorize.net Direct Post Signature Key?

I am using Magento2.3 and download the Authorize.net Direct Post Signature Key Patch file and put it to magento's root directory then go to the putty and run below command: patch --p0<...
1
vote
1answer
513 views

Magento1 SUPEE-11086 Potential Issues? [duplicate]

The Description of the patch SUPEE-11086 is: SUPEE-11086, Magento Commerce 1.14.4.1 and Open Source 1.9.4.1 contain multiple security enhancements that help close remote code execution (RCE), ...
0
votes
0answers
28 views

Multiple Magento SUPPEE Patches Not Installing

I am having issues applying patches to my Magento store, below I have included the current installed patches and a link to each log of the failing patches. I am unsure why half of these patches ...
0
votes
2answers
640 views

Magento 1.* SUPEE 9767 "Reversed or previously applied patch detected

I am currently trying to apply patch SUPEE 9767 v2 to one of our legacy sites running Magento 1.9.2.4, however when I try to run it, I receive the following: checking file app/design/frontend/base/...
2
votes
2answers
441 views

Magento 2 : How To Apply Authorize.net Direct Post Signature Key Patch?

Read https://support.magento.com/hc/en-us/articles/360024368392 Issue : Magento implements the Authorize.Net Direct Post payment method, using Authorize.Net's AIM (Advanced Integration Method) and ...
2
votes
1answer
207 views

Magento 2 Authorize-Net-Direct-Post-Patch installation

I need to update this patch on magento 2.1.7 - I am confused with file structure. CE-2.0.0 to CE-2.3.0/vendor/magento/module-authorizenet/ where should I upload these files and what is my CLI ...
0
votes
2answers
231 views

Magento 2 Authorization.net patch Md5 to SHA giving error

I am using Magento 2.1.3 EE and i applied patch using patch -p1 < patchfile.patch which applied patch in 5 files of vendor/magento/module-authorizenet I did follow the instruction given by the ...
3
votes
3answers
274 views

SUPEE-11085 not working

I SSH the patch - Authorize.net Direct Post Signature Key patch - PATCH_SUPEE-11085_CE_1.14.4.0_v1-2019-02-28-05-21-55.sh and it was successful then following the directions here I entered my ...
2
votes
1answer
774 views

Magento security patch issue

I scanned my site from the New Magento Security Tool available from magento partner portal. The report showed me two Vulnerability issues 1) SSL TLS - Your server supports TLSv1.0. Please update ...
0
votes
0answers
52 views

Applying Authorize.net Direct Post Patch [duplicate]

We have a magento 2.2.6 installation that was set up via composer, I am unsure of how to apply the .patch file required to use the new encryption.
1
vote
1answer
282 views

Regarding Authorize.net new patch

I am using magento v2.2.6. I am getting notification regarding the new patch release by magento for authorize.net payment method. But i am not using authorize.net payment method in my magento setup. ...
2
votes
2answers
759 views

Can't install PHP 7 support patch?

I downloaded the official php7 support patch PATCH-1.9.3.0_PHP7-2018-09-13-07-59-59.2_v2 from here. I noticed that the file is downloaded without any extension, so I renamed it from PATCH-1.9.3.1-1.9....
2
votes
1answer
30 views

Security Report - patch 8788

Patch 8788 is available for <= 1.9.2.4. I have 1.9.3.4. How can I fix the issues addressed?
1
vote
0answers
88 views

Necessary to apply Magento PHP 7.2 patch before installing SUPEE-10888?

I'm running Magento 1.9.2.1 and patched up to SUPEE-10752. I'm wanting to apply the SUPEE-10888 patch, but it's not clear to me from the documentation whether or not the PHP 7.2 patch, which was ...
-2
votes
1answer
35 views

Remove the custom patch in magento 2.2.5

I want to remove the custom patch applied to the cloud.
0
votes
1answer
674 views

Image Background Gets Black after installing patch SUPEE-9767

I have installed patch SUPEE-9767 on 1.9.2.1 store, Now the new products images is having a black color around it. I attached a sample product image. I have tried this fix Watermark get black ...
1
vote
2answers
61 views

Verify the patch was installed

How can I tell if the patch SUPEE-10570 v2 was installed on my magento store? What are the differences between the v1 and v2 of the patch and how can I tell which version I have installed? Note: I ...