Questions tagged [monolog]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
35 views

Error after data-migration-tool update

After updating data-migration-tool I get this error every time I try to run the command: Warning: Could not check compatibility between Migration\Logger\Logger::addRecord(int $level, string $message,...
user avatar
  • 3
0 votes
1 answer
30 views

How to make a custom logger with append functionality in Magento 2?

I created a custom log for my module like this app/etc/di.xml <?xml version="1.0"?> <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:...
user avatar
  • 68
0 votes
0 answers
18 views

How to fix the Monolog 1.x to 2.x for magento 2.4.4 beta4? array no match string?

Test Magento 2.4.4 beta4 with Pearl theme, Just got en error for the Monolog Extension. It showed that Monolog's Logger.php as below: <?php declare(strict_types=1); /* This file is part of the ...
user avatar
  • 11
0 votes
0 answers
33 views

customLogger depends on customLogger and vice versa issue after Magento upgrade

I'm getting the below error after upgrade from Magento 2.3.6 to 2.4.2-p1 from Docker Image. LogicException: Circular dependency: customLogger depends on customLogger and vice versa. in /var/www/html/...
user avatar
1 vote
1 answer
851 views

How use Logstash in Magento2 in Docker?

I want to have Docker container with Magento2 shop and container with Logstash. Also I have independent Elasticsearch server. I want to send all logs from Magento with build-in Monolog logger to ...
user avatar
0 votes
1 answer
789 views

Problems with Monolog version(s) installing Data Migration Tool 2.1.7

OSX Sierra php 7.1.5 apache/httpd 2.4 I have installed Magento 2 into my localhost Sites folder OK, set up the database etc. now trying to install data migration tool from github. This step (1) ...
user avatar
1 vote
0 answers
558 views

Magento 2: Update monolog/monolog

I want to update monolog/monolog version to ^1.17 I tried to do the same using below commands composer require monolog/monolog:^1.17 composer update But it gives below errors. Your requirements ...
user avatar