Questions tagged [mcrypt]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
0answers
78 views

Fatal error lib/Varien/Crypt/Mcrypt.php

When accessing payment methods menu in admin panel (Magento 1.9.2.2) I get the following fatal error. And in the frontend this: I asked my hosting company to instal mCrypt module on Server as shown ...
1
vote
1answer
366 views

Function mcrypt_module_close() is deprecated in magento 2.3.1

Array ( [type] => 8192 [message] => Function mcrypt_module_close() is deprecated [file] => /vendor/magento/framework/Encryption/Adapter/Mcrypt.php [line] => 94 ) PHP ...
3
votes
1answer
168 views

Magento Fatal Error: Call to undefined function mcrypt_module_open() using WampServer

I am using Magento 1, installed on a Windows 10 php(7.2) WampServer. I tried to add this extension=php_mcrypt.dll in php.ini, but continued to receive the error. How to add extension=php_mcrypt.dll ...
0
votes
1answer
3k views

Warning: Use of undefined constant MCRYPT_RIJNDAEL_256 - assumed 'MCRYPT_RIJNDAEL_256'

I have setup magento 2.2.6 website on local system. PHP Version 7.2.12 installed on the local system. When I have run url on local system then getting error: [2018-12-12 06:51:27] main.CRITICAL: ...
1
vote
1answer
613 views

Why does Magento 1.9.3.10 does not include /lib/mcrypt_compat/mcrypt.php

Magento released a patch for magento 1.9.3.x to be able to support php7.2. The patch includes /lib/mcrypt_compat/mcrypt.php so that php7.2 which does not have the mcrypt module (at least officially), ...
6
votes
4answers
4k views

Use of undefined constant MCRYPT_RIJNDAEL_256 - assumed 'MCRYPT_RIJ NDAEL_256

I got an error when i execute this command php bin/magento setup:upgrade && php bin/magento setup:di:compile && #php bin/magento setup:static-content:deploy && chown -R www-...
0
votes
1answer
1k views

MCRYPT_BLOWFISH Error in magento server migration

I'm getting this error followed in the Magento exception.log. I made a migration to a new server running PHP7 + and the mcrypt module is working. [2018-04-14 13:54:44] main.CRITICAL: Warning: Use of ...
0
votes
2answers
429 views

Installing error

I am using XAMPP with PHP 7.2.3 When I try to install Magento 1.9.2 It's giving the following error PHP extension "mcrypt" must be loaded. PHP extension "soap" must be loaded. Please, guide ...
2
votes
3answers
9k views

PHP extension “mcrypt” must be loaded [duplicate]

I'm trying to install Magento 1.9.3 but got stuck on PHP extension mcrypt must be loaded. I have two versions of PHP (5.6, and 7.1) both have mcrypt installed and running, checked on both versions ...
5
votes
1answer
9k views

Problem with magento 2.0.2 CE after upgrading to php7.0

I had a perfectly good and running magento 2.0.2 CE but after I updated the php version from php5.6 to php7.0 everything stopped working and i get the fallowing output in the var/report/...
1
vote
2answers
472 views

Can I use Magento without mcrypt? [duplicate]

My shop was moved to a server without mcrypt and for some reason mcrypt can not be installed (don't ask me why!). Looks like passwords are only encrypted with md5 with a salt (bad!) so I wonder what ...